-   Gentoo (
-   -   Gentoo:Can't write to NTFS volume (

pgb205 07-26-2008 10:16 AM

Gentoo:Can't write to NTFS volume
I've enabled all the ntfs settings in the kernel except ntfs debugging and I'm am actually able to chown/chmod some of the files on the volume. However when I try to do 'touch test' I get permission denied. When I try to chown some of the files I get "Operation not supported" . Using Fedora 9 I was able to read and write to the volume just fine.
Here is the command I use to mount volume (as root)
mount -t ntfs -w /dev/sdb1 /path/to/share/

thanks for all the help

FredGSanford 07-26-2008 11:24 AM

Are you using ntfs-3g driver? If so, the mount command would be:


mount -t ntfs-3g /dev/sdb1 /path to mountpoint
e.g. mount-t ntfs-3g /dev/sdb1 /media/windows

I hope this helps.

jomen 07-26-2008 12:48 PM


sys-fs/ntfs3g is the name of the ebuild you need to be able to use this

pgb205 07-26-2008 02:54 PM

ok I emerged the sys-fs/ntfs-3g ok but when i try to mount the sdb1
I get an error that fuse module is not found. When i try to emerge it I get an error that my kernel is too new and I need to create module from source.

jomen 07-26-2008 04:24 PM

in Gentoo you create everything from source...

Eighter you need to rebuild your kernel to include the FUSE (Filesystem in USErspace) -
or you just need to load the module "fuse"

modprobe fuse

and you need to "emerge" of course:


pgb205 07-27-2008 10:16 AM

that worked!!
rebuild kernel with fuse option and now all is


All times are GMT -5. The time now is 01:48 AM.