LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices



Reply
 
Search this Thread
Old 03-08-2012, 08:32 AM   #1
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 448

Rep: Reputation: 19
emerge blocking problem


How do I get past the following blockage?
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

  (x11-libs/qt-script-4.7.4::gentoo, installed) pulled in by
    ~x11-libs/qt-script-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)

  (x11-libs/qt-script-4.8.0::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-script-4.8.0[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

x11-libs/qt-core:4

  (x11-libs/qt-core-4.8.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.8.0[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-dbus-4.8.0::gentoo, ebuild scheduled for merge)
    (and 10 more with the same problem)

  (x11-libs/qt-core-4.7.4-r1::gentoo, installed) pulled in by
    ~x11-libs/qt-core-4.7.4[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.4::gentoo, installed)
    <x11-libs/qt-core-4.8.0 required by (kde-base/kstyles-4.7.4::gentoo, installed)
    (and 4 more with the same problems)

x11-libs/qt-sql:4

  (x11-libs/qt-sql-4.7.4::gentoo, installed) pulled in by
    ~x11-libs/qt-sql-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, installed)

  (x11-libs/qt-sql-4.8.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-sql-4.8.0[aqua=,c++0x=,qpa=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

x11-libs/qt-dbus:4

  (x11-libs/qt-dbus-4.8.0::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-dbus-4.8.0[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-webkit-4.8.0::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/qt-dbus-4.7.4::gentoo, installed) pulled in by
    ~x11-libs/qt-dbus-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.8.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-gui-4.8.0[accessibility=,aqua=,c++0x=,qpa=,debug=,qt3support=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 7 more with the same problem)

  (x11-libs/qt-gui-4.7.4-r1::gentoo, installed) pulled in by
    <x11-libs/qt-gui-4.8.0 required by (kde-base/kstyles-4.7.4::gentoo, installed)
    ~x11-libs/qt-gui-4.7.4[accessibility=,aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, installed)
    (and 1 more with the same problems)

x11-libs/qt-qt3support:4

  (x11-libs/qt-qt3support-4.8.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-qt3support-4.8.0[accessibility=,aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/qt-qt3support-4.7.4::gentoo, installed) pulled in by
    ~x11-libs/qt-qt3support-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)
I have 4.7.4 installed. I've tried unmerging the 4.7.4 versions to no effect. Do I have to remove all of 4.7.4?

Problems like this are driving me away from gentoo.

Frustrated,
Jim
 
Old 03-10-2012, 03:03 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,049

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Try unmerging kstyles. If that doesn't work, look out for custom entries under /etc/portage/*, maybe you put something in there that's blocking a new version for some kde package.

If not, you might get better info by using the -t parameter for emerge. The output will probably be much longer though.
 
Old 03-10-2012, 04:51 AM   #3
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 448

Original Poster
Rep: Reputation: 19
Thanks. kstyles was already gone, but cleaning out /etc/portage did the trick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cant emerge samba : Failed to emerge sys-libs/tdb-1.2.1 Adol Gentoo 2 03-09-2011 12:51 PM
[SOLVED] blocking and non blocking TCP send/recv problem golden_boy615 Programming 5 12-27-2010 04:27 PM
python: can't open file 'emerge\bin\emerge.py' Virtuality Programming 5 01-30-2008 02:23 PM
gentoo, emerge problem exodist Linux - Distributions 27 12-29-2004 01:15 AM
emerge errors during emerge -u world busbarn Linux - Distributions 6 04-23-2003 10:37 AM


All times are GMT -5. The time now is 01:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration