LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Gentoo (http://www.linuxquestions.org/questions/gentoo-87/)
-   -   ClamAV is outdated. (http://www.linuxquestions.org/questions/gentoo-87/clamav-is-outdated-806781/)

gdiza 05-09-2010 09:07 AM

ClamAV is outdated.
 
Okay, so my next mission is to get ClamAV updated and running.

Now... I know the basics, so I ran:

Quote:

emerge clamav
It did everything, then eventually, I restarted clamav and then I get told this:
Quote:

/etc/init.d/clamd restart
* Stopping clamd ... [ ok ]
* Stopping freshclam ... [ ok ]
* Starting clamd ...
LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***************************************************** [ ok ]
* Starting freshclam ... [ ok ]
Now, when I look at the log file, it says this:

Quote:

freshclam daemon 0.95.3 (OS: linux-gnu, ARCH: i386, CPU: i686)
ClamAV update process started at Sun May 9 15:58:49 2010
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.95.3 Recommended version: 0.96
DON'T PANIC! Read http://www.clamav.net/support/faq
Trying host database.clamav.net (193.1.193.64)...
Downloading main-52.cdiff [100%]
main.cld updated (version: 52, sigs: 704727, f-level: 44, builder: sven)
WARNING: getfile: daily-9956.cdiff not found on remote server (IP: 193.1.193.64)
WARNING: getpatch: Can't download daily-9956.cdiff from database.clamav.net
WARNING: getfile: daily-9956.cdiff not found on remote server (IP: 130.59.10.36)
WARNING: getpatch: Can't download daily-9956.cdiff from database.clamav.net
WARNING: getfile: daily-9956.cdiff not found on remote server (IP: 130.59.10.36)
WARNING: getpatch: Can't download daily-9956.cdiff from database.clamav.net
WARNING: Incremental update failed, trying to download daily.cvd
Downloading daily.cvd [100%]
daily.cvd updated (version: 10946, sigs: 63625, f-level: 51, builder: guitar)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 44, recommended = 51
DON'T PANIC! Read http://www.clamav.net/support/faq
Database updated (768352 signatures) from database.clamav.net (IP: 130.59.10.36)
Clamd successfully notified about the update.
I was under the impression, running emerge clamav would install the latest version but it's not, and yet, I get the OUTDATED! error.

Help with this, thanks. :D

sploot 05-09-2010 10:11 AM

There is a newer ebuild available in the portage tree:

Code:

# emerge -av =app-antivirus/clamav-0.96
But it is probably masked or missing keyword since it did not install with emerge clamav. This one may yield better results doing the update.

gdiza 05-09-2010 12:12 PM

Hi sploot;

I typed:

Quote:

emerge -av =app-antivirus/clamav-0.96
And...

Quote:

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=app-antivirus/clamav-0.96".
:(

sploot 05-09-2010 12:15 PM

Code:

# emerge --sync
# emerge -av =app-antivirus/clamav-0.06

you might need to update your portage tree.

gdiza 05-09-2010 12:24 PM

Quote:

Originally Posted by sploot (Post 3962303)
Code:

# emerge --sync
# emerge -av =app-antivirus/clamav-0.06

you might need to update your portage tree.

Okay, so I ran:

Quote:

emerge --sync
and ultimately ended up with this:

Quote:

>>> Starting retry 3 of 3 with rsync://172.0.23.4/gentoo-portage
>>> Checking server timestamp ...
timed out
rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(544) [receiver=3.0.6]
>>> Exceeded PORTAGE_RSYNC_RETRIES: 3
So, before I can further, I might need to fix this problem... do I have a old 'portage' setup ? How do I fix it?

Thanks!

sploot 05-09-2010 12:33 PM

Can you connect to the internet on this machine? or are you posting from a different setup? It seems that emerge is failing to access the server to update, but I'm not sure what would cause that to fail while you can still get to LQ.

gdiza 05-09-2010 12:37 PM

Quote:

Originally Posted by sploot (Post 3962325)
Can you connect to the internet on this machine? or are you posting from a different setup? It seems that emerge is failing to access the server to update, but I'm not sure what would cause that to fail while you can still get to LQ.

Hi sploot;

I can ping 8.8.8.8 from the box.
I can also ping 196.25.1.1 from the local and...
I can also ping www.linuxquestions.org :D

Could it maybe be my shorewall setup?
My linux box also functions as my 'glorified' router (splitting traffic etc)

:)

sploot 05-09-2010 12:39 PM

can you paste the contents of your make.conf file? maybe you need more / different rsync servers

gdiza 05-09-2010 12:45 PM

Quote:

Originally Posted by sploot (Post 3962335)
can you paste the contents of your make.conf file? maybe you need more / different rsync servers

Here you go:

Quote:

CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
USE="-ipv6 posix sockets xmlwriter xmlrpc xmlreader curl curlwrappers simplexml -gdbm -berkdb -X -truetype -freetype -pdflib -gtk -gnome -kde -gtkhtml -fontconfig -opengl -svga -qt php mysql cli cgi session pcre vhosts acl perl imap pam apache xml snmp"
SYNC="rsync://172.0.23.4/gentoo-portage"
GENTOO_MIRRORS="http://gentoo-mirror.kabtech.co.za http://gentoo.mirrors.pair.com http://gentoo.mirrors.pair.com http://www.mirrorservice.org/sits/www.ibiblio.org/gentoo"
FEATURES="CCACHE"
CCACHE_SIZE="2G"

sploot 05-09-2010 12:49 PM

try using this one. It might be a little slower but I know its up.


SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"

gdiza 05-09-2010 01:31 PM

Quote:

Originally Posted by sploot (Post 3962350)
try using this one. It might be a little slower but I know its up.

SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"

Thanks for this;

I've put this in the make.conf file and saved it with :wq
I ran it.
Yeap, you were right sploot, it was slow but at least it worked - took nothing short of forever! hahaha.

Afterwards, I ran the command:

Quote:

emerge -av =app-antivirus/clamav-0.96
It worked.

gdiza 05-09-2010 02:12 PM

Update!

Okay, so, It finished EVENTUALLY downloading 38MB and installing and then I did:

Quote:

/etc/init.d/clamd start
* Starting clamd ... [ ok ]
* Starting freshclam ... [ ok ]
* Virus databases are already up to date.
Thanks for the help guys, but I have 1 more question, how do I make sure that when the server reboots, it starts clamav as default?

sploot 05-09-2010 03:01 PM

Great!

add it to the default runlevel:

Code:

rc-update add clamd default
Happy to have helped. :)

gdiza 05-09-2010 03:46 PM

Quote:

Originally Posted by sploot (Post 3962486)
Great!

add it to the default runlevel:

Code:

rc-update add clamd default
Happy to have helped. :)

sploot, you legend!
Thanks! :)


All times are GMT -5. The time now is 08:16 AM.