LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   General (http://www.linuxquestions.org/questions/general-10/)
-   -   USB keyboard not functional in bootloader (http://www.linuxquestions.org/questions/general-10/usb-keyboard-not-functional-in-bootloader-206944/)

lotheac 07-19-2004 10:40 AM

USB keyboard not functional in bootloader
 
Hey. My USB keyboard (which is a Logitech Internet Navigator Keyboard SE) doesn't work in my bootloader, which is GRUB. I am fairly certain it didn't work with LILO either, but not 100% sure. This can be worked around by using the USB/PS/2 adapter, but regardless I'd like to find out why wouldn't this work.

I emailed my motherboard manufacturer (MSI) about it, asking about "USB Legacy Support" which is, according to the manual, supposed to add USB support for OS's that don't support USB otherwise (ok, GRUB's no OS). If I turn the 'legacy support' on, GRUB freezes. If it's off, the keyboard doesn't work. The keyboard works fine in the BIOS. MSI's 'convenient' answer to this was:
Quote:

Please tell us your OS. And does this issue occurs with the particular keyboard?
(at this point I explained to them how GRUB is a bootloader and this has nothing to do with OS's. I also pointed out I don't have other USB keyboards to test with)
According to your description, it does not seems to be a hardware issue
of the motherboard.

We suspect that it might be due to the application/driver
compatibility. You may have your software supplier check to see if any
updated for this issue.
I'm just curious, where is the problem? :)

david_ross 07-19-2004 11:45 AM

What version of grub are you using? perhaps try upgrading to a later version.

lotheac 07-19-2004 11:50 AM

GNU GRUB 0.95, which is the latest version as far as I know (not counting 'GRUB 2' which I stumbled upon while checking the latest version).

explorer 07-20-2004 01:38 PM

Try turning off ( or on if allready off ) PNP operating system option in the motherboard BIOS. Also see if there is an option in the BIOS to turn off the PS2 keyboard and make sure USB is enabled.


All times are GMT -5. The time now is 08:29 PM.