LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices

Reply
 
Search this Thread
Old 04-12-2010, 09:37 PM   #1
ajatshatru
LQ Newbie
 
Registered: Nov 2009
Posts: 3

Rep: Reputation: 0
some command in cygwin is not working


i recently install cygwin in my windows xp laptop. it is successfully installed. some commands is working like cd history etc but some command is not working like cat ll ls etc pls tell me what can i do in it.
 
Old 04-13-2010, 10:31 AM   #2
deadeyes
Member
 
Registered: Aug 2006
Posts: 605

Rep: Reputation: 79
Are these commands not working or are these not installed on your system?
Do you get any error message?

If it is not installed, restarted the setup.exe for cygwin and select the base system. This should include all basic tools.
 
Old 04-14-2010, 06:16 AM   #3
ajatshatru
LQ Newbie
 
Registered: Nov 2009
Posts: 3

Original Poster
Rep: Reputation: 0
thank you for repling

thank you dead eyes for repling

Last edited by ajatshatru; 04-14-2010 at 06:23 AM. Reason: thank you
 
Old 04-14-2010, 06:16 AM   #4
ajatshatru
LQ Newbie
 
Registered: Nov 2009
Posts: 3

Original Poster
Rep: Reputation: 0
i have solved this problem but still have some problem.

i have Cygwin Bash shell its command prompt is shown as bash-3.2#
when i run cat command it shows error
bash: cat: command not found
but when i run it as
Bash-3.2# /bin/cat (filename)
then it works
so pls help me what is the problem why i could't run cat command directly?
 
Old 04-14-2010, 06:20 AM   #5
Sayan Acharjee
Member
 
Registered: Feb 2010
Location: Bangalore, India
Distribution: Linux Mint 13
Posts: 590

Rep: Reputation: 64
Quote:
Originally Posted by ajatshatru View Post
i have Cygwin Bash shell its command prompt is shown as bash-3.2#
when i run cat command it shows error
bash: cat: command not found
but when i run it as
Bash-3.2# /bin/cat (filename)
then it works
so pls help me what is the problem why i could't run cat command directly?
Check /root/.bash_profile, see if the following line is there:
PATH=$PATH:$HOME/bin
 
Old 04-14-2010, 06:32 AM   #6
ajatshatru
LQ Newbie
 
Registered: Nov 2009
Posts: 3

Original Poster
Rep: Reputation: 0
dear mr. sayan

cygwin is for windows. there is no any folder named root.
 
Old 04-14-2010, 06:34 AM   #7
Sayan Acharjee
Member
 
Registered: Feb 2010
Location: Bangalore, India
Distribution: Linux Mint 13
Posts: 590

Rep: Reputation: 64
Oops!! did not notice that, sorry.
 
Old 04-14-2010, 10:50 AM   #8
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Debian
Posts: 2,455

Rep: Reputation: 843Reputation: 843Reputation: 843Reputation: 843Reputation: 843Reputation: 843Reputation: 843
How are you starting cygwin? I seem to remember that cygwin gets installed with a .bat file that sets up the PATH and other environment variables.
 
Old 04-15-2010, 02:58 AM   #9
deadeyes
Member
 
Registered: Aug 2006
Posts: 605

Rep: Reputation: 79
Quote:
when i run cat command it shows error
bash: cat: command not found
but when i run it as
Bash-3.2# /bin/cat (filename)
then it works
Your PATH variable is incorrect.
 
Old 04-15-2010, 11:56 PM   #10
ajatshatru
LQ Newbie
 
Registered: Nov 2009
Posts: 3

Original Poster
Rep: Reputation: 0
how can i set path variable

as i know it is in environment variable
ii set PATH as .;C:\cygwin\bin
is it correct?
 
Old 04-16-2010, 05:53 AM   #11
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
No, it is not correct. Here is my path variable:

Code:
/home/kenny-strawn/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
It is composed of directories separated by colons. And in your case, C:\Cygwin is read as '/' by the Cygwin shell.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
make command is not found in cygwin udayakumarsv General 3 07-16-2012 07:00 AM
The command wget does not work on cygwin 1.5 even though it is installed. edgarosy Linux - Newbie 3 03-19-2010 10:35 PM
'make' command still not working on cygwin acharyaa Linux - Newbie 2 01-22-2010 01:42 PM
Have you ever used cygwin, i've met a problem with the command stat from cygwin andy820303 Linux - Newbie 0 03-11-2009 03:37 AM
Cygwin problem: lex: Command not found EasyLife Linux - Distributions 1 07-28-2008 10:19 AM


All times are GMT -5. The time now is 09:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration