Share your knowledge at the LQ Wiki.
Go Back > Forums > Non-*NIX Forums > General
User Name
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!


  Search this Thread
Old 07-17-2011, 03:37 PM   #1
LQ Newbie
Registered: Jul 2011
Posts: 0

Rep: Reputation: Disabled
Post shader model 3 (sm3) support is needed

this is very strange as i have previously been able to play the game its only since i formated my hard drive and re installed windows and the games ive been having this problem ive tryed updating drivers the lot theres even a repaire tool with the game and everything cheacks out if its a case of getting a new vid card i cant do that as im using a laptop and it has onbord graphics and vid
Old 07-17-2011, 04:13 PM   #2
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 884
Blog Entries: 11

Rep: Reputation: 105Reputation: 105
Hi, I see you posted this from windows 7, does this issue affect linux? If yes which distro? If you want help with Windows, you're in the wrong place.
Mesa 7.11 might adress the issue you're having : it brings a part of GLSL 1.30 with it.

Please use punctuation and separate sentences, it will be a lot easier to read.

Old 07-17-2011, 04:22 PM   #3
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 16,865
Blog Entries: 2

Rep: Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678Reputation: 4678
Which graphics card do you have in your laptop? For SM 3.0 you need at least a NVidia Geforce 6xxx (or higher), ATI/AMD X1xxx (or higher) or Intel G35 (or higher). You also need the latest drivers in case of the Intel models.
Old 07-17-2011, 04:40 PM   #4
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,047
Blog Entries: 11

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
Moved: This thread is more suitable in <GENERAL> and has been moved accordingly to help your thread/question get the exposure it deserves.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
HP laserjet CP1525nw model specific drivers unavailable - workaround needed please DJB Linux - Hardware 3 12-18-2010 02:07 PM
LXer: Wine 1.3.5 Betters Its Shader Model 4 Support LXer Syndicated Linux News 0 10-16-2010 03:20 AM
LXer: Porting to Qt4 and its model view concept - testers needed LXer Syndicated Linux News 0 02-02-2010 10:10 AM
GLSL Shader Dev IDE needed Simon Bridge Linux - Software 6 06-08-2009 11:04 PM
LXer: WINE 1.1.21 Starts On Shader Model 4 Support LXer Syndicated Linux News 0 05-09-2009 03:50 AM

All times are GMT -5. The time now is 03:00 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration