LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices

Reply
 
Search this Thread
Old 12-14-2012, 12:01 AM   #1
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Glendale, AZ
Distribution: Distro-homeless. Lost.
Posts: 1,868

Rep: Reputation: 62
I want headphones to make speakers cut out


When I listen to audio with headphones/earphones plugged into my front headphone jack, the audio simultaneously comes from the external speakers that are plugged into the same jack in the back. I would prefer the external speakers to automatically cut out when I plug in headphones. How do I set that in the audio settings? I'm using KDE Trinity, and if it matters, the speakers are part of my monitor and I don't have separate speakers. It seems to me that that at one time, my external speakers did cut out for headphones and I thought that was normal, but it might have been a long time ago and I'm not sure I was using Linux then.

If this can be a problem with the hardware, I suppose it very well might be. One of the front USB ports (next to the audio ports) has been dead for a while and I've supposed a connection is disconnected or broken.

Last edited by newbiesforever; 12-14-2012 at 12:12 AM.
 
Old 12-26-2012, 01:49 AM   #2
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
To ask the obvious, are the head phones fully plugged in? Do all headphones you try act the same way? (Try another set to see)

I find that unplugging the headphones and then replugging them in eliminates this issue if done after the media is playing.
 
Old 12-26-2012, 10:20 AM   #3
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Glendale, AZ
Distribution: Distro-homeless. Lost.
Posts: 1,868

Original Poster
Rep: Reputation: 62
Yes, they're fully plugged in. I have only one set to try, but I'm sure there was a time when plugging headphones (some pair) in did make the speakers cut out.
 
Old 12-26-2012, 01:50 PM   #4
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 365

Rep: Reputation: 34
Have you tried a different driver or soundcard? There are other drivers besides alsa. There is usually a master volume control and audio in settings, which normally requires root access. In some distros, the defaults are flat out weird.

If all else fails, try a different desktop or switch distros entirely. Just download 2 or 3 live DVDs and see what works.

PC-BSD has an entirely different driver set with the exception of the Nvidia driver which is ported. See if Mint, Fedora, Mandriva or SuSE doesn't work. Test PC-BSD as well. Its very user friendly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
plugging in headphones or speakers doesn't disable my laptop's built in speakers moljac024 Linux - Software 11 02-18-2009 09:24 AM
Headphones plugged in from do not cut out speakers completely TuxLives Mandriva 3 05-18-2008 03:10 PM
Sound from speakers not from headphones crimsontide Linux - Hardware 2 12-21-2006 08:55 AM
Laptop speakers off when plug in headphones garyozzy Linux - Hardware 8 02-04-2006 02:44 PM
USB headphones / Speakers ShuttleAU Linux - Hardware 1 04-18-2005 01:48 AM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration