LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   General (http://www.linuxquestions.org/questions/general-10/)
-   -   I want headphones to make speakers cut out (http://www.linuxquestions.org/questions/general-10/i-want-headphones-to-make-speakers-cut-out-4175441397/)

newbiesforever 12-14-2012 01:01 AM

I want headphones to make speakers cut out
 
When I listen to audio with headphones/earphones plugged into my front headphone jack, the audio simultaneously comes from the external speakers that are plugged into the same jack in the back. I would prefer the external speakers to automatically cut out when I plug in headphones. How do I set that in the audio settings? I'm using KDE Trinity, and if it matters, the speakers are part of my monitor and I don't have separate speakers. It seems to me that that at one time, my external speakers did cut out for headphones and I thought that was normal, but it might have been a long time ago and I'm not sure I was using Linux then.

If this can be a problem with the hardware, I suppose it very well might be. One of the front USB ports (next to the audio ports) has been dead for a while and I've supposed a connection is disconnected or broken.

mdlinuxwolf 12-26-2012 02:49 AM

To ask the obvious, are the head phones fully plugged in? Do all headphones you try act the same way? (Try another set to see)

I find that unplugging the headphones and then replugging them in eliminates this issue if done after the media is playing.

newbiesforever 12-26-2012 11:20 AM

Yes, they're fully plugged in. I have only one set to try, but I'm sure there was a time when plugging headphones (some pair) in did make the speakers cut out.

mdlinuxwolf 12-26-2012 02:50 PM

Have you tried a different driver or soundcard? There are other drivers besides alsa. There is usually a master volume control and audio in settings, which normally requires root access. In some distros, the defaults are flat out weird.

If all else fails, try a different desktop or switch distros entirely. Just download 2 or 3 live DVDs and see what works.

PC-BSD has an entirely different driver set with the exception of the Nvidia driver which is ported. See if Mint, Fedora, Mandriva or SuSE doesn't work. Test PC-BSD as well. Its very user friendly.


All times are GMT -5. The time now is 12:22 PM.