LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices

Reply
 
Search this Thread
Old 04-30-2004, 12:23 AM   #1
netquest1
Member
 
Registered: Aug 2003
Distribution: Gentoo 1.4, Slackware 9, Suse 9.0
Posts: 35

Rep: Reputation: 15
grub or windows error and how to fix


I realize that this is a linux form so i am sorry for this post. I chose this site because it has fast results and i couldn't think of a better one for this problem. This is both a windows problem and a linux/ Grub boot questio, and i was wondering if anyone was able to help.

the problem:
I use both windows and linux. I hade a 120 GB Maxtor hard drive with the following partitions:
hda1: win xp
hda2: grub\gentoo boot
hda3: swap
hda4: extended partition
hda5: gentoo linux stage 3
hda6: slackware
hda7: suse linux
hda8: gentoo stage 1
hda9: win 2000

i installed the Operating Systems in the same oarder listed above.
1st question: if i have a grub boot loader then why do i see a boot menu for windows allowing me to choose eather 2000 and xp no matter witch one i choose in the grub boot menu. shouldn't the grub boot menu pass that?

problem2: one day after cleaning out my computer and putting it back to geather my harddrive started to not work and click. I thought it was bad and decided to buy a Western Digital 80 GB. I installed win xp on that but still havn't had time to install linux. i dicided to try the old harddrive once again and it strangly started working again. so i decided to make the old one the master because it had the grub boot loader on it and make the newone with only xp on it the slave. and i added xp boot script to the grub config file.

the problem is that no matter witch windows os i choose i only get the choises in the win boot menu for the xp and 2000 on hd1 my primary hard drive and can not boot the win xp installiaton on hd2.

can anyone help me fix these 2 problems?

again i am sorry that these are more windows problems then linux.

thanks in advance,
NETQUEST1
 
Old 04-30-2004, 12:28 AM   #2
netquest1
Member
 
Registered: Aug 2003
Distribution: Gentoo 1.4, Slackware 9, Suse 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
this is what my grub config file looks like:

default 0
timeout 30
splashimage=(hd0,1)/boot/grub/splash/linuxbox.xpm.gz


title=Windoze XP
root (hd0,0)
chainloader (hd0,0)+1

title=Gentoo Linux 1.4
root (hd0,1)
kernel (hd0,1)/boot/kernel-2.4.22-gentoo-r5 root=/dev/ram0 real_root=/dev/hda5 init=/linuxrc vga=0x317 splash=verbose
initrd (hd0,1)/boot/initrd-2.4.22-gentoo-r5

title=Slackware Linux
root (hd0,1)
kernel (hd0,5)/boot/vmlinuz-ide-2.4.22 root=/dev/hda6

title=SuSE Linux
kernel (hd0,6)/boot/vmlinuz root=/dev/hde7 vga=0x317 splash=verbose
initrd (hd0,6)/boot/initrd

title=Gentoo Linux 1.4 Stage1
root (hd0,8)
kernel (hd0,8)/boot/kernel-2.4.22-gentoo-r7 root=/dev/ram0 real_root=/dev/hda8 init=/linuxrc vga=0x317 splash=verbose
initrd (hd0,8)/boot/initrd-2.4.22-gentoo-r7

title=Windoze 2000 Professional
root (hd0,9)
chainloader (hd0,9)+1

title=Windoze XP (Hard Drive 2)
root (hd1,0)
chainloader (hd1,0)+1
 
Old 04-30-2004, 02:27 AM   #3
netquest1
Member
 
Registered: Aug 2003
Distribution: Gentoo 1.4, Slackware 9, Suse 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
ok sorry for the post. I was able to fix the problem of windows not beaing able to load. the problem was that the the old harddrive i installed win 2000 last and it overwrite some important files that win xp was using to boot. used the bios to boot into the slave hard drive and copied over the system files from the slave xp to the master xp installiation. now it works.

the only problem now is that i am wondering how to get windows to bypass the windows os choice menu and not have the win xp on the master partition take over the booting for the win 2000 installiation partition and the win xp on the slave drive.

any ideas?
if i tell grub to boot my win 2000 partition at (hd0,8) or my win xp partition at (hd1,0) why would my win xp partition at (hd0,0)'s boot.ini file evan be read? im not telling grub to look at that partition.

this is the problem that bugs me the most because i half to deal with 2 boot menus when i only want to half to deal with grubs menu and dont evan want to see MS's ugly os selection menu!

anyone know a work arround this?

your help would be greatly appreciated!

thanks in advance,
NETQUEST1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is Grub loading error 21, and how can I fix the problem! logiplex Linux - Software 26 06-30-2009 03:20 PM
SuSE 9.1 and Windows Xp refuse to live in harmony: error loading windows through GRUB sanctumtacete Linux - Newbie 3 10-19-2004 07:47 AM
How do I fix a "Grub read error"?? Tiyogi Linux - Newbie 1 06-02-2004 08:55 AM
How to fix GRUB after reformatting Windows? X-Crawler Linux - General 1 05-29-2004 10:18 AM
Error w/ grub booting windows xp Ryknow215 Linux - General 26 05-22-2004 02:10 AM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration