LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices

Reply
 
Search this Thread
Old 08-16-2011, 11:54 PM   #1
archieval
Member
 
Registered: Apr 2007
Location: Philippines
Distribution: Kubuntu, Ubuntu, CentOS
Posts: 289

Rep: Reputation: 41
Google language settings is annoying


Hello everyone,

Have you encountered the automatic language settings of google in you google account? This happens to me always, I am not in hongkong but when I go to google, it always redirects to google.hk! The annoying part is all words are displayed in chinese characters. I tried logging in to my google account after that all are still chinese. I found out that google automatically detects your language based on ip address, but I am not in hongkong and I never indicated any language preference to be chinese. How can I fix this? Thanks


Regards,
archieval
 
Old 08-16-2011, 11:59 PM   #2
SigTerm
Member
 
Registered: Dec 2009
Distribution: Slackware 12.2
Posts: 379

Rep: Reputation: 233Reputation: 233Reputation: 233
Quote:
Originally Posted by archieval View Post
Hello everyone,

Have you encountered the automatic language settings of google in you google account? This happens to me always, I am not in hongkong but when I go to google, it always redirects to google.hk! The annoying part is all words are displayed in chinese characters. I tried logging in to my google account after that all are still chinese. I found out that google automatically detects your language based on ip address, but I am not in hongkong and I never indicated any language preference to be chinese. How can I fix this? Thanks


Regards,
archieval
http://www.google.com/ncr ("no country redirect"), If I remember correctly.

AFAIK some browsers (opera, for example) that use google search might ignore cookie installed by NCR(AFAIK visiting the page installs cookie), and (when you search via browser) will use region based on browser's settings (in case of opera setting is located in operaprefs.ini and is called "Google TLD Default").

Last edited by SigTerm; 08-17-2011 at 12:01 AM.
 
Old 08-17-2011, 10:50 PM   #3
archieval
Member
 
Registered: Apr 2007
Location: Philippines
Distribution: Kubuntu, Ubuntu, CentOS
Posts: 289

Original Poster
Rep: Reputation: 41
Thanks for the info SigTerm, it seems to work!
 
  


Reply

Tags
google, language


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Google's Go Language: No Way, Right? LXer Syndicated Linux News 0 11-16-2009 04:30 PM
Language Settings in Fedora 9 shreks Fedora 0 06-17-2008 01:25 AM
Mepis language settings cosm MEPIS 1 11-01-2006 11:26 AM
Confusing language settings powadha Slackware 0 12-17-2003 12:39 PM
Language settings in GNOME Aldebaran Linux - Newbie 4 08-16-2003 07:41 PM


All times are GMT -5. The time now is 07:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration