LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices

Reply
 
Search this Thread
Old 11-14-2012, 01:24 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,052

Rep: Reputation: 45
An eye strain problem.


Hi:

I'm writing /etc/lilo.conf in a terminal (/dev/tty1) running under VESA BIOS. Any command to switch on the fly to normal video?
 
Old 11-14-2012, 03:57 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Assuming you use Slackware with lilo, have a look here:

- VGA framebuffer, lilo.conf, and Slackware64 13.37
- Slackware Install Script (the # setup.liloconfig part)

In short: change this line in your lilo.conf file: vga=xyz to an entry you like.

I'm not aware that this can be done on-the-fly.
 
Old 11-14-2012, 04:05 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,052

Original Poster
Rep: Reputation: 45
You see. I always put 'vga = normal' in lilo.conf, with the result I wanted: an 80 x 25 characters screen. With slackware 14.0 I'm doing the same, but at a certain point during boot, the screen switches to high resolution. It's a cul de sac, because I see almost anything that is written on the screen and its my first experience with 14.0.
 
Old 11-14-2012, 04:26 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Instead of using vga=normal, try the following:
Code:
vga=normal video=vesafb:off
 
Old 11-14-2012, 04:40 AM   #5
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Thread seems to be continued here: https://www.linuxquestions.org/quest...nd-4175437057/
 
Old 11-14-2012, 04:41 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,407
Blog Entries: 2

Rep: Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994
With drivers that implement kernel mode setting the vga= option is deprecated. Try video=1024x768@60 with exchanging the resolution and refresh rate with your preffered settings, of course.
 
Old 11-14-2012, 04:54 AM   #7
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,052

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by TobiSGD View Post
With drivers that implement kernel mode setting the vga= option is deprecated. Try video=1024x768@60 with exchanging the resolution and refresh rate with your preffered settings, of course.
Quite a pity. 'video=' gets 'Unrecognized token' when running lilo. Perhaps as an argument at the boot prompt? How do I get a list of all these arguments?
 
Old 11-14-2012, 05:00 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,052

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by druuna View Post
Instead of using vga=normal, try the following:
Code:
vga=normal video=vesafb:off
I get 'unrecognized token 'video'' when running lilo. I'll continue reading the links. Thanks.
 
Old 11-14-2012, 05:37 AM   #9
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,052

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by druuna View Post
Assuming you use Slackware with lilo, have a look here:

- VGA framebuffer, lilo.conf, and Slackware64 13.37
- Slackware Install Script (the # setup.liloconfig part)

In short: change this line in your lilo.conf file: vga=xyz to an entry you like.

I'm not aware that this can be done on-the-fly.
The first link I think will provide the solution to my problem, with it's reference to CHANGES_AND_HINTS.TXT that I should have read before posting. Slack recommends
append="video=mxn" for some m, n and still use
vga=[normal|extended]

Now I have another question ... Humm, I'll open another thread because, although related, the subject is quite another thing.

Last edited by stf92; 11-14-2012 at 05:48 AM.
 
Old 11-16-2012, 06:07 AM   #10
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,052

Original Poster
Rep: Reputation: 45
The problem:

Quote:
Originally Posted by stf92 View Post
You see. I always put 'vga = normal' in lilo.conf, with the result I wanted: an 80 x 25 characters screen. With slackware 14.0 I'm doing the same, but at a certain point during boot, the screen switches to high resolution. It's a cul de sac, because I see almost anything that is written on the screen and its my first experience with 14.0.
The solution:

Following CHANGES_AND_HINTS.TXT for Slackware 14.0, I inserted the line 'append=nomodeset' in lilo.conf, together with 'vga=normal' (not strictly necessary but recommended by them). As a side-effect it will be impossible to run X. This depending on the GPU you have. But I was lucky with my GPU.

The great change responsible for the switch to VESA in the middle of boot is the jump made by the kernel developers, to Kernel Mode Setting for graphics cards. What it means I do not know well, but I know the remedy (yes, it's a decease).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New monitor and eye strain bloodsugar Slackware 10 08-06-2009 11:13 AM
Reducing eye-strain on LCD monitor.(reading text) ErV General 15 12-16-2008 03:00 PM
Eye strain and head aches. 180 Linux - Hardware 9 03-27-2006 10:08 AM


All times are GMT -5. The time now is 01:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration