LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 02-09-2004, 09:23 PM   #1
DBarry
LQ Newbie
 
Registered: Feb 2004
Posts: 2

Rep: Reputation: 0
Question XP on main HD. Fedora on second HD. How do I remove Fedora and get back to only XP?


OK. I decided that I might want to switch from XP Pro to Fedora. I thought that it would be a good idea to just set it up so it had the dual boot option and have them both on the same computer. I now have a second computer and I have decided that I would rather just run Fedora on that to see how I like it and see if I would prefer it. My problem is now that I have installed Fedora on the secondary hard drive XP Pro no longer acknowledges the drives exsistance. Which makes it rather hard for me to format the drive and bring it back for use with XP. I believe I can fix the master boot record after I get the drive formatted but I am not sure about how to get it done. Anyone have any ideas? Please help. LOL
 
Old 02-09-2004, 11:31 PM   #2
DBarry
LQ Newbie
 
Registered: Feb 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Answer to my own question

While sitting around I came up with a round about way to get rid of Fedora without having to buy any partitioning software or any of that. It is extreamly round about though.

1.) Unhooked the primary hard drive and hooked up the secondary in place of it.

2.) Put in the XP Pro setup CD and booted from that and went into the install program. I used the XP setup CD's partitioning to delete the three partitions that Fedora had made and then make a new partition out of the total unpartitioned space.

Once that is done EXIT THE SETUP before it goes any further.

3.) Shut the computer down and andhook your harddrives up the way they were originally. YOUR MASTER BOOT RECORD HAS NOT BEEN FIXED YET AND YOUR COMPUTER WILL NOT REBOOT INTO XP AT THIS POINT IN TIME.

4.) Turn your computer back in with the XP SETUP CD still in your CDROM and boot from it. Use the Recovery section to get into your command promt. At that point type in "Fixmbr" This will take care of the dual boot problem.

When you reboot your computer it should take you right back into XP PRO and then let you format your freshly repartitioned second hd and get back to your normal business.

Its a round about way but it didnt cost me anything and it worked for me. You just have to be comfortable with a little basic wire swapping
 
Old 02-23-2004, 10:59 AM   #3
sgtbob
Member
 
Registered: Jan 2004
Location: Kansas
Distribution: Windows 7, iMAC Lion 8.5, Ubuntu
Posts: 92

Rep: Reputation: 15
Good for you DBarry - It may not be pretty but it seemed to work for you. I'm copying the data just in case I need to refer to a similar situation.\\Bob
 
Old 02-27-2004, 01:02 AM   #4
jjustin01
Member
 
Registered: Feb 2004
Posts: 34

Rep: Reputation: 15
Here's another way. Might be a little easier.

Use the old school method. Boot up with a win98 boot disc that has fdisk on it. If you don't have one, or have access to win98 to make, I just put the files up on my server for someone else on this forum (http://www.gener8.com/bootdisc/boot_disc.zip). Just unzip the file and save the files to a floppy.

Put the floppy in the drive and let it boot up to the A:\ prompt. Type, "fdisk" and select the drive you want to partition. It's extremely cut and dry on how to do it. I would just remove the partition and then boot into XP and use XP to setup new partition and format.

So that takes care of removing all the partition on the hard drive Linux was installed on. Next you want to fix your master boot record. After removing the partitions, exit fdisk until you are back at the A:\ and then type "fdisk /mbr". This will clear your mbr and set it back to the default of booting to the OS loaded on your C:\ drive.

There ya. 5 minutes and you've got your old PC back in business the way was originally. I hate the fact that you can't find FDISK anymore unless you have an old boot disc. It comes in handy in situations like this.

P.S.
If you've already completed this little project, still feel free to download the file. You never know when it's going to come in handy.
 
Old 02-28-2004, 03:08 PM   #5
Unix4Ever
LQ Newbie
 
Registered: Feb 2004
Location: London, United Kingdom
Distribution: Fedora Core 1, Debian (Soon), Mandrake (Soon)
Posts: 5

Rep: Reputation: 0
Wouldn't it just be better to stick with Linux, because Linux is better in so many ways more than Windows I can't even begin to list them .

To be honest, XP is a pile of crap, it has so many issues I changed to Fedora & have been using it for a week without ANY problems whatsoever.

Windows :
Linux :
 
Old 03-13-2004, 06:32 PM   #6
gilesh1
LQ Newbie
 
Registered: Mar 2004
Location: Oxford, UK
Distribution: Fedora Core 1 and JDS
Posts: 1

Rep: Reputation: 0
Hi
Boot with your XP CD and select R (Recovery Console) at the appropriate screen. This will boot you to a prompt. Type "FIXMBR" and return. Then type "exit" and return. System will reboot to Win XP...a real pity

Good luck
 
Old 03-18-2004, 12:58 PM   #7
WebGuyBob
LQ Newbie
 
Registered: Mar 2004
Location: Dallas, TX
Distribution: Fedora Core 1
Posts: 4

Rep: Reputation: 0
Similar Dual-Boot Question

Hi, folks.

I have similar issue, but with a twist..

When I installed FC1 to dual boot with my XP Home, everything went fine. FC1 was on my secondary hard drive and working great. I even rebooted several times to ensure that I could indeed boot into either XP or FC1. Everything's great, right?

Here's the twist...after about four or five boots, the system boots into FC1 ONLY! What's bizarre is that I went into the bootloader utility and my XP still showed up as an option. I set bootloader to boot into XP, BUT when I reboot, it still goes directly into FC1.

What can I do to get my dual-boot configuration back???

TIA
WebGuyBob
 
Old 03-18-2004, 01:12 PM   #8
om3ga
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 9

Rep: Reputation: 0
Fix

Well,
Another way is to use the system management thingymawotsit...
Go into your XP control panel and choose adminastrative tools. Now choose computer management. Now goto Storage>>Disk Management. Now, it should show you all of the devices. On the hd that fedora is installed on, it should be split up into a few boxes. Right click on each of these and choose "Delete partition". Now, create all of the windows partitions you need by right clicking on the free space and doing so.
Now, format the drives as you have windows access to them, and pat yourself on the back for rescuing your hds without using the XP cd.
(I worked this out when my Blag installation messed up...)
Hope this helps...
-om3ga
 
Old 03-18-2004, 01:15 PM   #9
om3ga
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 9

Rep: Reputation: 0
If you have a dual boot problem, when booting, press Delete, or whatever it says to goto setup. Choose advanced options, and set the 1st boot device to be the IDE channel that Windows is installed on. Now edit your C:\boot.ini file accordingly so you can choose with the windows bootloader.

(Ps, windows SUCKS!)

Last edited by om3ga; 03-19-2004 at 02:05 AM.
 
Old 03-18-2004, 05:24 PM   #10
Pauli
Member
 
Registered: Feb 2004
Location: Montreal
Distribution: Gentoo/Debian
Posts: 365

Rep: Reputation: 30
You people have no clue. Your a bunch of people who bitch about windows sucking even though FC1 is so filled with dependancy problems it makes you gag. I happen to never install anything on FC1, because every time I do it seems that I get a dependancy error. FC1 is not a great disto IMO, it tries to be easy for n00bs but ends up with many many problems. I wouldn't suggest to anyone to use FC1 over Slack. If you want to go uber Linux, go Gentoo or Slack period. Dont say windows sucks compared to Fc1, because its obvious you havent been installing too much on FC1 or else you would be bitching about dependancy problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Back with Fedora mohapi Fedora 4 12-12-2004 04:43 PM
Gahhhh! Fedora core 2's main files are write protected (4nd th!5 n00b n33d5 h3lp) charlie_man Fedora 1 10-30-2004 03:33 AM
Fedora Core 1, Issues with then Main Menu. linxchic24 Fedora 0 05-05-2004 11:27 AM
How do I turn the main volume up in Fedora Core 1 reesee Linux - Newbie 3 02-16-2004 07:02 PM
Changing the fedora main menu icon in redhat 8 fox2213 Linux - Distributions 0 01-11-2003 05:23 PM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration