LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora - Installation (http://www.linuxquestions.org/questions/fedora-installation-39/)
-   -   Software Update - Transaction Error (http://www.linuxquestions.org/questions/fedora-installation-39/software-update-transaction-error-832610/)

dzo 09-16-2010 11:39 AM

Software Update - Transaction Error
 
I have 3 packages listed in Software update that will not install. They carry out the "Resolving Dependencies" Then give transaction errors but the detail says "No Transaction to Process".

Other updates are happily being processed. The problem transactions are:
firefox-3.5.12-1.fc12 (x86_64)
xulrunner-1.9.1.12-1.fc12 (x86_64)
xulrunner-devel-1.9.1.12-1.fc12 (x86_64)

The output of "yum repolist" only lists firefox 12 updates.

Any ideas or suggestions of what the problem is and how I can resole it.

Thanks All

unSpawn 09-16-2010 06:20 PM

You could install packages that don't fail and after that attach the plain text file ("/tmp/yum-errors.log") result from running '/path/to/yum --verbose -d 3 -e 1 update 2>&1 | tee /tmp/yum-errors.log'?

DrLove73 09-17-2010 09:27 AM

If you have only F12 "updates" repository, then dependancies must be in "os" or "base" repositories, so you must enable them also in /etc/yum.repos.d/ repo files.

dzo 09-19-2010 05:54 PM

@unSpawn: Here is the output from yum:

# yum --verbose -d 3 -e 1 update 2>&1 | tee /tmp/yum-errors.log
Not loading "blacklist" plugin, as it is disabled
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Config time: 0.062
Yum Version: 3.2.28
Setting up Package Sacks
pkgsack time: 0.092
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
up:Obs Init time: 0.528
up:simple updates time: 0.557
up:obs time: 0.009
up:condense time: 0.000
updates time: 2.280
Not Updating Package that is already updated: xulrunner.x86_64 0:1.9.1.11-2.fc12
Not Updating Package that is already updated: xulrunner.x86_64 0:1.9.1.11-2.fc12
Not Updating Package that is already updated: firefox.x86_64 0:3.5.11-1.fc12
Not Updating Package that is already updated: xulrunner-devel.x86_64 0:1.9.1.11-2.fc12
Not Updating Package that is already updated: xulrunner-devel.x86_64 0:1.9.1.11-2.fc12
Resolving Dependencies
--> Running transaction check
Checking deps for firefox.x86_64 0:3.5.11-1.fc12 - None
---> Package firefox.x86_64 0:3.5.12-1.fc12 set to be updated
Checking deps for firefox.x86_64 0:3.5.12-1.fc12 - u
looking for ('xulrunner', 'GE', ('0', '1.9.1.12', None)) as a requirement of firefox.x86_64 0:3.5.12-1.fc12 - u
Checking deps for xulrunner.x86_64 0:1.9.1.11-2.fc12 - None
---> Package xulrunner.x86_64 0:1.9.1.12-1.fc12 set to be updated
Checking deps for xulrunner.x86_64 0:1.9.1.12-1.fc12 - u
Checking deps for xulrunner-devel.x86_64 0:1.9.1.11-2.fc12 - None
---> Package xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 set to be updated
Checking deps for xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 - u
looking for ('xulrunner', 'EQ', ('0', '1.9.1.12', '1.fc12')) as a requirement of xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 - u
looking for ('pkgconfig(nspr)', 'GE', ('0', '4.8.6', None)) as a requirement of xulrunner-devel.x86_64 0:1.9.1.12-1.fc12 - u
xulrunner-devel-1.9.1.12-1.fc12.x86_64 requires: pkgconfig(nspr) >= 4.8.6
--> Processing Dependency: pkgconfig(nspr) >= 4.8.6 for package: xulrunner-devel-1.9.1.12-1.fc12.x86_64
Searching pkgSack for dep: pkgconfig(nspr)
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 0.523
Error: Package: xulrunner-devel-1.9.1.12-1.fc12.x86_64 (updates)
Requires: pkgconfig(nspr) >= 4.8.6
Installed: nspr-devel-4.8.4-2.fc12.x86_64 (@updates)
pkgconfig(nspr) = 4.8.4
Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
pkgconfig(nspr) = 4.8.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

dzo 09-19-2010 06:29 PM

@DrLove73: I appreciate your suggestion but I do not see anything listed as a pre-req that is not already installed. Your point is well taken though and I will follow up on the os and base repository configs. Thanks!

It looks as though the problem is that nspr is currently installed at 4.8.4 but the installer wants it to be 4.8.6

I have checked and do not see 4.8.6 as being available for download.

I currently use FC12 and pull everything from fedoraproject.org mirrors.

rhood 09-20-2010 11:28 AM

same problem
 
I'm having the same problem. Were you able to figure out how to resolve it? Thanks.

unSpawn 09-21-2010 09:07 AM

Quote:

Originally Posted by dzo (Post 4102820)
@unSpawn: Here is the output from yum:

Error: Package: xulrunner-devel-1.9.1.12-1.fc12.x86_64 (updates)
Requires: pkgconfig(nspr) >= 4.8.6
Installed: nspr-devel-4.8.4-2.fc12.x86_64 (@updates)
pkgconfig(nspr) = 4.8.4
Available: nspr-devel-4.8.2-1.fc12.i686 (fedora)
pkgconfig(nspr) = 4.8.2

Try 'yum remove xulrunner-devel', then 'yum update'. Also see Bug 632126 and Bug 635334 (awaiting triage).

dzo 09-22-2010 02:23 AM

Perfect! removing xulrunner-devel did resolve the problem.

Thank you

unSpawn 09-23-2010 05:32 PM

You're welcome.


All times are GMT -5. The time now is 09:54 AM.