LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 09-29-2006, 03:37 PM   #1
Turnthepage
LQ Newbie
 
Registered: Sep 2006
Location: Eastern Ontario,Canada
Distribution: Fedora Core 5
Posts: 3

Rep: Reputation: 0
no grub after fedorea 5 duel boot install


First I'd like to say hello to everybody.
Second, I'm totally new to linux and duel boot configuration.
My problem, After I install Fedora core 5 on my xp home machine,I reboot as requested and the computer boots directly to windows.
I don't get Grub.
Xp is installed on an IDE drive which has 2 partitions, one for xp the other for data.C: and F:.Fedora is installed on a sata drive, first partition. There are 2 other ntfs partitions on the drive.
This is info from the partition window during fedora install;
LVM Volumegroups
VolGroup00
LogVol 00 / ext 3
LogVol 01 swap

Hard Drives
/dev/hda
/dev/hda 1 ntfs
/dev/hda 2 ntfs
/dev/sda
/dev/sda 1 /boot ext3
/dev/sda 4 extended
/dev/sda5 VolGroup LVM PV
/dev/sda 2 ntfs
/dev/sda 3 ntfs

I've tried the install 3 times and I get the same result each time.
Any help would be greatly appreciated.

Thanx
 
Old 09-29-2006, 05:20 PM   #2
d3L0s
LQ Newbie
 
Registered: Mar 2005
Distribution: Debian and Slackware
Posts: 16

Rep: Reputation: 0
There is nothing wrong with your install. The problem is the boot order of your hard drives. Somewhere in your bios settings there will be a boot order for your drives, you have hda above sda and that is why it boots into windows. This is different than where you select to boot from your cd-rom, thumb drive etc. If you put sda above hda you should see grub when you reboot.
 
Old 09-29-2006, 06:27 PM   #3
Turnthepage
LQ Newbie
 
Registered: Sep 2006
Location: Eastern Ontario,Canada
Distribution: Fedora Core 5
Posts: 3

Original Poster
Rep: Reputation: 0
Thanx for the advice d3LOs but when I change the boot order of the drives in bios I get this message "Error loading operating system".
any other suggestions?
Thanx

Should add I can't boot to either os after that message.Had to set the boot order of the drives back to orignal to boot to windows.

Last edited by Turnthepage; 09-29-2006 at 06:34 PM.
 
Old 10-02-2006, 06:45 PM   #4
digital8doug
Member
 
Registered: Aug 2006
Location: Near Binghamton, NY-the recent FLOOD zone
Distribution: Sabayon 351, Mepis8, oSuse11.3, Kubuntu8.1, Fed10, Slack12.1 #426299 RLU
Posts: 145
Blog Entries: 1

Rep: Reputation: 15
Question Where did U put your BL: Boot is on 1st part 2ndHD/Sata , Root (FC5 O/S) in Ext Part

Similar problem on LT, but I thought was due to install of BL to 1st sector of boot partition, instead of the MBR! I had same LVM VolumeGroups, but I deleted them & created what I wanted. If I understand it right, your boot is on 1st part of the 2ndHDD/Sata, but root (FC5 O/S) is actually on 1st part of Extended on sata. Can you access all Linux part fm M$ Home or when FC5 up the NTFS parts OK fm fc5?
Quote:
Originally Posted by Turnthepage
when I change the boot order of the drives in bios I get this message "Error loading operating system". I can't boot to either O/S after that message.Had to set the boot order of the drives back to orignal to boot to windows.
I do not know of any special drivers required to mount SATA as WinXP (F6) does on start of install. Do you have any BIOS virus warning enabled or your System BIOS cached?
 
Old 10-03-2006, 02:18 PM   #5
Turnthepage
LQ Newbie
 
Registered: Sep 2006
Location: Eastern Ontario,Canada
Distribution: Fedora Core 5
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry it took me so long to get back.
I didn't get the original problem solved, but I do have FC 5 up and running.
I cleaned the 2nd partition on the ide drive up and installed fedora there. I still have no idea why I couldn't get grub to install to mbr with FC 5 installed on the sata drive???
Thanks for your help,I'll be back, I am a newbie.

peace
 
Old 10-03-2006, 02:38 PM   #6
d3L0s
LQ Newbie
 
Registered: Mar 2005
Distribution: Debian and Slackware
Posts: 16

Rep: Reputation: 0
When I had windows and linux on two different drives I could never get grub configured either. I had to put them both on the same drive too. I found out this question gets asked a lot so you could search these forums to edit grub.conf for a dual boot on separate drives.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No internet acces after install with duel boot XP on DSL. Dougal Suse/Novell 6 02-07-2006 01:22 PM
GRUB problems - duel boot camman977 Fedora - Installation 3 04-16-2005 03:57 PM
how to install printer in fedorea 3? keiwu Linux - Newbie 6 03-04-2005 06:45 PM
how to hide GRUB bootloader while booting a duel boot system ( linux/windows ) ? dommini Linux - General 0 12-03-2003 03:48 AM
Windows XP RH 7.2 Grub Duel Boot LinnyNewbie Linux - Newbie 4 03-04-2002 08:18 AM


All times are GMT -5. The time now is 01:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration