LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 12-27-2007, 03:31 PM   #1
azastro
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
LSI Logic SAS based MegaRAID. HDD not seing.


Hi all,

At first I try install Fedora Core 8.
At boot it load megaraid_sas(success I think, see log on F4). then try to load pata_amd(not loaded and frizen).
On F4 screen write:
load pata_amd ....... versionn of driver on so on
megasas: 00.00.03.05-rc5 Mon Oct 02 11:21:32 PDT 2006
megasas: 0x1000:0x0413:0x1000:0x1005: bus 6:slot 3:func 0
ACPI: PCI Interrupt Link [LNEC] enabled at IRQ 18
ACPI: PCI Interrupt 0000:06:03.0[A] -> Link [LNEC] -> GSI 18 (level, low) -> IRQ 18
megasas: FW now in Ready state
scsi 0:0:0:0: megasas: RESET -1 cmd=12
megasas: [ 0]waiting for 1 commands to complete
megasas: [ 5]waiting for 1 commands to complete
megasas: [10]waiting for 1 commands to complete
..............
..............
megasas: [180]waiting for 1 commands to complete
megasas: cannot recover from previous reset failures
scsi 0:0:67:0: scsi: Device offlined - not ready after error recovery

and frizen.............



then I boot from gentoo Live CD, it boot but problems are begining after boot.

server configuration
Dual-Core AMD Opteron(tm) Processor 2212
2 x Hitachi 500Gb HDT725050VLA360

At boot time I configure raid contoller
to use two HDD like RAID1.
I try boot from Gentoo Linux Minimal Installation CD for amd64.
Driver for raid is loaded.
dmesg
----cat----------------
megasas: 00.00.03.05 Mon Oct 02 11:21:32 PDT 2006
megasas: 0x1000:0x0413:0x1000:0x1005: bus 6:slot 3:func 0
ACPI: PCI Interrupt Link [LNEC] enabled at IRQ 18
ACPI: PCI Interrupt 0000:06:03.0[A] -> Link [LNEC] -> GSI 18 (level, low) -> IRQ 18
megasas: FW now in Ready state
----cat----------------

but not see any HDD.

I try to connect to another computer without RAID controller HDDs are working

I try to create equal disk partition (on another computer). reboot.
problem not solved.

Try create RAID0 at boot time. Problem not solved.

at some time after boot on console I see
error like this:


scsi0 : LSI Logic SAS based MegaRAID driver
scsi 0:0:0:0: megasas: RESET -1 cmd=12
megasas: [ 0]waiting for 1 commands to complete
megasas: [ 5]waiting for 1 commands to complete
megasas: [10]waiting for 1 commands to complete

after this:
megasas[0]: Dumping Frame Phys Address of all pending cmds in FW
megasas[0]: Total OS Pending cmds : 1

megasas[0]: 64 bit SGLs were sent to FW
megasas[0]: Pending OS cmds in FW :
megasas[0]: Frame addr :0x7bada000 : <3>megasasscsi 0:0:67:0: megasas: RESET -68 cmd=12
megasas: cannot recover from previous reset failures
scsi 0:0:67:0: megasas: RESET -68 cmd=12
megasas: cannot recover from previous reset failures
scsi 0:0:67:0: scsi: Device offlined - not ready after error recovery
[0]: frame count : 0x1, Cmd : 0x4, Tgt id : 0x0, lun : 0x0, cdb_len : 0x6, data xfer len : 0x24, sense_buf addr : 0x7bad9200,sge count : 0x1

at last:
scsi 0:0:67:0: megasas: RESET -68 cmd=12
megasas: cannot recover from previous reset failures
scsi 0:0:67:0: megasas: RESET -68 cmd=12
megasas: cannot recover from previous reset failures
scsi 0:0:67:0: scsi: Device offlined - not ready after error recovery

How solve this problem

livecd ~ # uname -a
Linux livecd 2.6.19-gentoo-r5 #1 SMP Fri Mar 23 22:03:13 UTC 2007 x86_64 Dual-Core AMD Opteron(tm) Processor 2212 AuthenticAMD GNU/Linux

livecd ~ # lsmod
Module Size Used by
ipv6 184992 14
megaraid_sas 24540 1
rtc 7552 0
tg3 87364 0
e1000 90944 0
nfs 87224 0
lockd 43760 1 nfs
sunrpc 106632 2 nfs,lockd
jfs 128912 0
dm_mirror 12224 0
dm_mod 32848 1 dm_mirror
pdc_adma 4996 0
sata_mv 12296 0
ata_piix 8456 0
ahci 11268 0
sata_qstor 5188 0
sata_vsc 4100 0
sata_uli 3076 0
sata_sis 3652 0
sata_sx4 8388 0
sata_nv 5060 0
sata_via 4740 0
sata_svw 3844 0
sata_sil24 8580 0
sata_sil 5704 0
sata_promise 6852 0
libata 61472 15 pdc_adma,sata_mv,ata_piix,ahci,sata_qstor,sata_vsc,sata_uli,sata_sis,sata_sx4,sata_nv,sata_via,sata_ svw,sata_sil24,sata_sil,sata_promise
sbp2 16452 0
ohci1394 24008 0
ieee1394 56440 2 sbp2,ohci1394
sl811_hcd 8576 0
usbhid 29728 0
ohci_hcd 13892 0
uhci_hcd 16080 0
usb_storage 59648 0
ehci_hcd 20744 0
usbcore 84648 7 sl811_hcd,usbhid,ohci_hcd,uhci_hcd,usb_storage,ehci_hcd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LSI Megaraid SCSI problems humbletech99 Linux - Hardware 0 08-09-2006 09:52 AM
LSI MegaRAID U320-1 and RedHat 7.2 majeztik Linux - Hardware 4 04-13-2005 05:19 AM
LSI MegaRAID 320-1 install Phaethar Linux - Hardware 1 11-11-2003 09:10 AM
AMI/LSI MegaRAID help whysyn Linux - Hardware 2 10-17-2003 12:07 PM
Experience w/ AMI/LSI Logic MegaRAID SCSI cards? JMCraig Linux - Hardware 1 07-18-2003 02:45 PM


All times are GMT -5. The time now is 04:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration