LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices



Reply
 
Search this Thread
Old 05-11-2004, 04:30 PM   #1
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Rep: Reputation: 15
Post Installing Red Hat 9.0 Problem


Hey..

I just decided to switch from Fedora Core 2 Test 3 to Red Hat 9.0

If I browse up the installation (CD ISO is succesfully burned I tested it) I get after the booting of "anaconda" a dark screen.. yes you know it.. OUT OF RANGE.. I also tried it with a Monitor with other resoultions. A Monitor which linux knows.. Flatron LCD 563LE. If I boot up with this Monitor the Red Hat I just get a black screen without anything on it after the boot up anaconda..


Please help me with this.. I want to fix this problem so fast as I can..
Im greatful for every help I can get

Mortified Pengu
 
Old 05-11-2004, 04:59 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Try using media check in install (if you get to there). Else download checksums and try them to see if you have the whole isos.
 
Old 05-11-2004, 05:09 PM   #3
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Have you tried running the non-gui install? It may be that it's not picking it up correctly during the install.

Also, as Marghorp says, check your md5sums.
 
Old 05-11-2004, 05:10 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Moved: This thread is more suitable in Fedora-Installation and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 05-12-2004, 01:15 PM   #5
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
hey you two.. Thanks for your replies..

Well the md5sum is correct.. A friend of mine also installed it with the same ISO CD's and it worked perfectly for him.

I also tried the following:
In the bootup well I mean in the install dialog I entered:
linux resolution=1280x1024

This time I got the error: NO SIGNAL IMPUT.. Wow very great.. not always this OUT OF RANGE error..

The 3rd thing I tried is to install Red Hat on a diffrent computer.. So I switched my Monitor to my diffrent box.. entered:
linux resolution=1280x1024 again..

And it worked..

But well i'm not happy with that because it's the box of my girlfriend and I don't want to use it there..

Thanks in advance..
 
Old 05-12-2004, 02:24 PM   #6
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
Ok.. After playing with all the scripts I know I found something interesting.

linux resolution=1280x1024 this time i got a response.

-

XIO: fatal IO error 104 (Connection reset by peer) on X server ":1.0" after 0 requests (0 known processed) with 0 events remaining.

Great so now I know that it's a fatal error..

Im a n00b but I know that a fatal error is nothing good..

Last edited by Mortified Pengu; 05-12-2004 at 02:39 PM.
 
Old 05-12-2004, 04:43 PM   #7
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
more news by me..

I installed red hat now through the text mode. The installation seemed to work perfectly.. Well that said the message after the 100%. But now when I start Linux I get a OUT OF RANGE error again..

Anybody knows if I can do some code in the start up "grub 2" like linux resolution= or setting my HZ's whatever ?
 
Old 05-12-2004, 06:27 PM   #8
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Boot into single mode. (at grub press "a" and type " single") that should get you into the command line. cd to /etc/X11

MAKE A BACKUP COPY OF XF86Config (in case you mess up) with

cp XF86Config XF86Config.backup

edit the file XF86Config especially the Section Monitor and Screen and set them to your values. Search Google for your monitor specs if you don't have the manual. Look at the vertical and horizontal refresh rate. And your max resolution. It is set up to loopback.

"1280x1024" "1024x768" "800x600"

Just delete the ones that are to big for your monitor to handle. Save the file. and reboot.
 
Old 05-13-2004, 12:58 PM   #9
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
Ok marghorp

I also tried that.. Guess the answer ? yes it didn't work..
well that's what I tried:

I booted up linux till grub 2.. and marked the red hat boot up.. then I pressed the "a" button on my keyboard.

After I done that I get to another section with some code at it.. I tried everything there like deleting the whole code and adding "single" or just straight adding "single" or adding "single" with a space.

It always just booted up linux as always with the "OUT OF RANGE" error.

Well then I had more 2 hours spare time and went into the command line by using "c" on the startup.. I tried all the codes you gave me there too.. but nothing happens

Just if I add there a "single" or anything.. And if I want to boot up from there I get this error:

Kernel panic: No init found. Try putting init= option to kernel
Underneath this message I have a command line but I can't enter anything there..

I'm lost like always.. I think the best solution might be to change to another distro.. my computer hates red hat and red hat hates me
 
Old 05-13-2004, 02:52 PM   #10
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Just put in your Red Hat 9 CD 1 and boot from that into

linux rescue
(yes that's what you type in at the first screen, where you just pressed ENTER when installing)

This should get you into single mode. Once there do:

chroot /mnt/sysimage

From there just follow the steps form the previous post

Peace!
 
Old 05-13-2004, 04:39 PM   #11
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
marghorp thanks man you are very helpful.

I managed now to get into single.. and in your first post you wrote cd to /etc/X11 ok. Is that the command i have to insert ? I remember on the windows shell using cd \ for getting to the C: drive.. but can you please write this more detailled ?.. I think im on the right trip but im very bad with all this scripts.. so a little help, hint I would be very greatful

Thanks anyway

Mortified Pengu
 
Old 05-13-2004, 05:04 PM   #12
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
no problem, you'll get it in time

There are some changes in Linux.

cd..(windows) = cd ..(Linux)
cd name_of_directory(the same in both)

cd cwindows) = cd /(Linux, "sort of")

The hierarchy of Linux file organizing is a little different. You don't have a c: d: e: .... but you have all organized in one big tree. This tree of directories starts at / (called root). You can change to a directory in two ways.

if you are in /home/your_username

and do

cd Desktop (is the same as) cd /home/your_username/Desktop

The first way was from your home directory and the second way was an absolute way to the Desktop directory.

cd to /etc/X11 means you have to change directory to /etc/X11. And by now you probably know how to: (just type in these lines)

cd /etc/X11
cp XF86Config XF86Config.backup (make a backup copy in case you mess up )
emacs XF86Config

(a text editor called Emacs will open the config file for your XF86 (the GUI(Graphical User Interface) server or the X).

Use Emacs like any other text editor, and scroll through the file to find the lines saying

Section "Monitor"

(Here adjust the HorizSync and VertRefresh to your monitors default values (find them in your monitors manual, or search the web. Just replace the values with yours.)

and

Section "Screen"
(Here adjust the resolution if it is to big for your monitor. Just replace values with the one from your manual.)

When you're done editing, you have to do two more things.

press CTRL + x --> + s (this means first CTRL + x (still holding CTRL (release x) and press s(while holding CTRL) (this saves the file)

press CTRL + x --> + c (the same way as above) (this closes emacs)

reboot

Hopefully you will now be answering from Linux
 
Old 05-14-2004, 08:03 PM   #13
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
Ok.. I have been trieng all you wrote now.. for exactly 9 hours

I learned much on that.. And I've done everything right..

but now on the startup my "31337" monitor says "NO SIGNAL IMPUT".. damn im really frustrated ..

so marghorp
what would you do ?

- The Problems of tomorow. TODAY. Linux
 
Old 05-14-2004, 08:15 PM   #14
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
The first thing I would ask myself would be, why FC 2 test 3 and why not FC 1?

But nevermind that.

What you must see here is the file XF86Config.

Once you got that setup right, there is no reason for X not to work. My supply of solutions is gone. All you can do now is wait for some more solutions from someone or you can study the XF86Config file and make the proper changes.

One more thing. Could you post your monitor name and model. And for your graphics card too. I am curious what type of hardware you have that is not recognized from FC2.

Thanks! Peace!
 
Old 05-14-2004, 08:24 PM   #15
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
marghorp look at my first submission here.

Hey..

I just decided to switch from Fedora Core 2 Test 3 to Red Hat 9.0 I think that's self explionairy..

Well about my monitor I can say:

Linux doesn't know it .. on boot up it says UNKNOWN MONITOR
I also can say that my graphic card is known it's a nvidia..

Do you need it more detailled ?..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem while installing Wine in Red hat 9.0 m.parthiban Red Hat 7 11-29-2005 05:57 AM
Problem Installing Red Hat 9 kingwaz Linux - Software 4 01-16-2004 11:36 PM
problem installing red hat DeathByDefault Linux - Newbie 7 09-19-2003 06:34 PM
Problem installing Red hat 9 chamanrana Linux - Software 1 08-13-2003 07:42 AM
Problem installing Red Hat 9 blas Linux - Distributions 1 05-09-2003 02:26 PM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration