LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 07-18-2006, 12:41 PM   #1
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Rep: Reputation: 31
how to update to FC5 (from FC4) from internet?


Hi!

I've been using FC4 for quite a long time now, and I'm planning to update to FC5.
How to achieve this, without downloadind the Image files, i.e. updating directly from the internet?

--polemon
 
Old 07-18-2006, 12:57 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
download the fedora-release rpm for fc5, install it and do a "yum upgrade"
 
Old 07-18-2006, 03:42 PM   #3
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
Hmm, I downloaded the fedora-release-5-5.noarch.rpm and installed it.
I have an x86_64 system, but yum keeps trying to upgrade everything to the i386 architecture.
Additionally, it throws plenty of errors, stating, that mirrors can not be reached.

Alas, seems like another blank has to be burned (pun intented)
 
Old 07-19-2006, 03:52 AM   #4
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
I moved some repos back and forth, and the upgrade process starts.

But at the end I get a quite large list of Errors:

Code:
Error: Missing Dependency: libssl.so.5 is needed by package xchat-tcl
Error: Missing Dependency: libcrypto.so.5 is needed by package xchat-perl
Error: Missing Dependency: /usr/bin/iiimf-le-tools is needed by package iiimf-le-sun-thai
Error: Missing Dependency: libgs.so.7 is needed by package xine-lib
Error: Missing Dependency: libWand.so.6 is needed by package xine-lib
Error: Missing Dependency: libgnutls.so.11 is needed by package vlc
Error: Missing Dependency: hpoj = 0.91-13 is needed by package hpoj-devel
Error: Missing Dependency: avahi = 0.6.9 is needed by package avahi-devel
Error: Missing Dependency: libssl.so.5 is needed by package xine
Error: Missing Dependency: libcrypto.so.5 is needed by package xchat
Error: Missing Dependency: libcrypto.so.5 is needed by package xchat-tcl
Error: Missing Dependency: libcrypto.so.5 is needed by package perl-RPM2
Error: Missing Dependency: libssl.so.5 is needed by package xchat-python
Error: Missing Dependency: libdevmapper.so.1.01 is needed by package lvm2-cluster
Error: Missing Dependency: libssl.so.5 is needed by package pine
Error: Missing Dependency: libcrypto.so.5 is needed by package pine
Error: Missing Dependency: libcrypto.so.5 is needed by package xchat-python
Error: Missing Dependency: libgnutls.so.11(GNUTLS_REL_1_0_9) is needed by package vlc
Error: Missing Dependency: libiiimcf.so.3 is needed by package iiimf-qt
Error: Missing Dependency: libMagick.so.6 is needed by package xine-lib
Error: Missing Dependency: libgulm.so.1.0 is needed by package lvm2-cluster
Error: Missing Dependency: libssl.so.5 is needed by package xchat
Error: Missing Dependency: libssl.so.5 is needed by package xchat-perl
Error: Missing Dependency: libdevmapper.so.1.01(Base) is needed by package lvm2-cluster
Error: Missing Dependency: libiiimp.so.1 is needed by package iiimf-qt
Error: Missing Dependency: libdbus-1.so.1 is needed by package vlc
Error: Missing Dependency: libcrypto.so.5 is needed by package xine
Error: Missing Dependency: libssl.so.5 is needed by package perl-RPM2
Error: Missing Dependency: iiimf-server is needed by package iiimf-le-sun-thai
Error: Unable to satisfy dependencies
Error: Package vlc needs libdbus-1.so.1, this is not available.
Error: Package dlm-kernel needs /lib/modules/2.6.17-1.2145_FC5, this is not available.
Error: Package avahi-devel needs avahi = 0.6.9, this is not available.
Error: Package xine-lib needs libgs.so.7, this is not available.
Error: Package xchat needs libssl.so.5, this is not available.
Error: Package xchat-python needs libssl.so.5, this is not available.
Error: Package xine-lib needs libWand.so.6, this is not available.
Error: Package xine needs libcrypto.so.5, this is not available.
Error: Package lvm2-cluster needs libdevmapper.so.1.01, this is not available.
Error: Package pine needs libcrypto.so.5, this is not available.
Error: Package iiimf-le-sun-thai needs iiimf-server, this is not available.
Error: Package xine needs libssl.so.5, this is not available.
Error: Package xchat-python needs libcrypto.so.5, this is not available.
Error: Package initscripts needs kernel < 2.6.12, this is not available.
Error: Package lvm2-cluster needs libgulm.so.1.0, this is not available.
Error: Package lvm2-cluster needs libdevmapper.so.1.01(Base), this is not available.
Error: Package vlc needs libgnutls.so.11, this is not available.
Error: Package cman-kernel needs /lib/modules/2.6.17-1.2145_FC5, this is not available.
Error: Package hpoj-devel needs hpoj = 0.91-13, this is not available.
Error: Package iiimf-qt needs libiiimp.so.1, this is not available.
Error: Package iiimf-le-sun-thai needs /usr/bin/iiimf-le-tools, this is not available.
Error: Package xchat-tcl needs libcrypto.so.5, this is not available.
Error: Package GFS-kernel needs /lib/modules/2.6.17-1.2145_FC5, this is not available.
Error: Package vlc needs libgnutls.so.11(GNUTLS_REL_1_0_9), this is not available.
Error: Package perl-RPM2 needs libssl.so.5, this is not available.
Error: Package xchat-perl needs libssl.so.5, this is not available.
Error: Package xchat-tcl needs libssl.so.5, this is not available.
Error: Package kudzu needs kernel < 2.6.13, this is not available.
Error: Package pine needs libssl.so.5, this is not available.
Error: Package gnbd-kernel needs /lib/modules/2.6.17-1.2145_FC5, this is not available.
Error: Package perl-RPM2 needs libcrypto.so.5, this is not available.
Error: Package xchat-perl needs libcrypto.so.5, this is not available.
Error: Package iiimf-qt needs libiiimcf.so.3, this is not available.
Error: Package xine-lib needs libMagick.so.6, this is not available.
Error: Package xchat needs libcrypto.so.5, this is not available.
Can I get rid of this?

--polemon
 
Old 07-20-2006, 12:47 PM   #5
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
could someone help ne on this please?
I don't really like bumping my own thread, but it seems this is the only chance...

PLEASE HELP

--polemon
 
Old 07-20-2006, 12:51 PM   #6
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
could someone help ne on this please?
I don't really like bumping my own thread, but it seems this is the only chance...

PLEASE HELP

--polemon
 
Old 07-23-2006, 03:16 AM   #7
Raveolution
Member
 
Registered: Mar 2004
Distribution: Fedora & CentOS
Posts: 210
Blog Entries: 2

Rep: Reputation: 25
There isn't a fedora-release rpm for the 64 bit arch??
 
Old 07-23-2006, 05:27 AM   #8
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
it is, and that's the one I downloaded...
But I still get those errors.

Any Idea how to work-a-round those?

--polemon
 
Old 07-23-2006, 05:36 AM   #9
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I tried to do an upgrade from FC4 to FC5 and everything broke. It was easier to restore the FC4 install (I'd created a disk image), back up all my data, config files, etc. and then do a clean install and re-setup the server.
 
Old 07-23-2006, 06:00 PM   #10
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
I just read the Fedora Wiki, and they said, it is advised to update with the CDs or the DVD, rather than with yum. In fact, updating with yum is clearly NOT ADVISED, since it will stop the update process as soon as it encounters any problems (see my fail).

I just downloaded the DVD image, and I will try to upgrade from that media.

The result, I will post here.

--polemon

Last edited by polemon; 07-23-2006 at 06:02 PM.
 
Old 08-15-2006, 06:17 PM   #11
fuct
LQ Newbie
 
Registered: Dec 2005
Location: Pittsburgh
Distribution: Fedora Project 4
Posts: 6

Rep: Reputation: 0
so how did that go for you??
cause i'm finding myself with the same issue
 
Old 09-05-2006, 11:28 AM   #12
billkamp
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
how to update to FC5 (from FC4) from internet?

The answer to the iiimf-qt error is buried in the issue that
this is an upgrade, and not an update;

the answer is at:
mumble mumble
I cannot put the http at the front since I am a newbie,
and the system blocks it.

Here is the relevant Item 2:


2. After the upgrade, remove any iiimf-qt package(s) before running yum
update. If those packages are installed, they will raise a couple of
dependency errors that will cause the yum update to fail:

Error: Missing Dependency: libiiimcf.so.3 is needed by package iiimf-qt
Error: Missing Dependency: libiiimp.so.1 is needed by package iiimf-qt

Today, two weeks after the FC5 ISOs were released, there are 136
packages updates to an "everything" install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
package manager from FC4 to FC5 brunog Fedora 11 10-14-2006 04:41 PM
libg2c on FC4 and FC5 hhegab Linux - Software 1 04-10-2006 04:39 PM
I can boot after upgrade from fc4 to fc5 yumener Fedora 2 03-24-2006 09:28 AM
FC4 --> FC5: GDM hosed Kropotkin Fedora - Installation 1 03-21-2006 04:42 PM
Red Hat Update Agent freezing, unable to update (FC4) Malakye Fedora 1 12-09-2005 08:02 PM


All times are GMT -5. The time now is 08:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration