LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 01-23-2007, 08:54 PM   #1
valdimore
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
Fedora 6 Installation problem on Dell Optiplex 320


Hi All,
I know this question might be a asked again and again. Somehow I couldnt get the answer from anywhere.
I am trying to install Fedora 6 on Dell Optiplex 320 (Pentium D, ATI mother board, ATI sata harddisk(i think), PATA dvd drive) and am running into problems.
I used the pci=nomsi option to find the sata drives during installtion and I could install successfully. But when I try to boot for the first time, as expected, the GRUB is giving me problems. It is not booting up properly.
The message "root (hd0,0)
Filesystem type ext2fs, partition type 0x83
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ pci=nomsi rhgb quiet
[Linux-bzImage, setup=0x1e00, size=0x1e157e]"
and the system hangs.
I know that there is some problem with Grub and I need to recompile the kernel using proper sata options.
If someone can give me detials about how to procede, I will be very grateful as I am relatively new to Linux.

Thanks
 
Old 01-24-2007, 05:01 PM   #2
valdimore
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Original Poster
Rep: Reputation: 0
please guys help me out..
Grub is giving me a problem. so i'm trying to install lilo. but the installation of FC6 never gives me an option of lilo while getting installed. can someone please tell me how to install lilo and make my kernel boot.. Please help. I'm badly struck.
Thanks
 
Old 02-10-2007, 09:27 AM   #3
hoist2k
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by valdimore
Hi All,
I know this question might be a asked again and again. Somehow I couldnt get the answer from anywhere.
I am trying to install Fedora 6 on Dell Optiplex 320 (Pentium D, ATI mother board, ATI sata harddisk(i think), PATA dvd drive) and am running into problems.
I successfully got Fedora 6 running on the Optiplex 320. I have a detailed writeup on my blog.
 
Old 02-10-2007, 09:28 AM   #4
hoist2k
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by hoist2k
I successfully got Fedora 6 running on the Optiplex 320. I have a detailed writeup on my blog.
And the link. (Sorry - You can't post links as a new user on the forum)
 
Old 02-10-2007, 11:28 PM   #5
valdimore
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Original Poster
Rep: Reputation: 0
hoist2k...
I did the same process with Debian Etch. Except, in debian I dont have the video driver problem. But the rest of the process is same.
In short -
1) Boot the install CD with pci=nomsi
2) Install lilo instead of grub
3) The other problem I had was, the Xorg was configuring the monitor with the correct horizontal sync (This may be a problem with my monitor-Dell 19 inch analog E19FP only). I edited the Xorg config file (depends on the distro) and set the correct horizontal refresh and vert sync frequencies.

I was exhausted by the time I installed and got the system up.. its a really weird system for any distro

hope this post helps more people.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Optiplex SX280 NIC and DVI Problem wbdune Linux - Hardware 0 08-05-2005 09:03 AM
Display & Kernel Problem with Sarge on Dell Optiplex GX280 sshiv Debian 8 07-26-2005 12:41 PM
[SOLVED] Fedora Core 4 (test 3) and Dell Optiplex GX280 maximusGeek Fedora 5 06-13-2005 03:21 PM
SuSE 9.2 on Dell optiplex SX280 installation problem neerq Suse/Novell 3 12-04-2004 09:50 AM
Resolution Problem:RH 9 Installation on Dell Optiplex 170L tiwarya Linux - Hardware 1 09-17-2004 05:28 AM


All times are GMT -5. The time now is 06:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration