LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 10-31-2006, 04:54 PM   #1
sancho
Member
 
Registered: Sep 2003
Distribution: Ubuntu 9.04/9.10 (64-bit)
Posts: 149

Rep: Reputation: 15
FC6: "mount: could not find filesystem '/dev/root'"


Hey all.

I just installed FC6 over my old FC5 installation on my desktop (I did *not* upgrade--I formatted both the root and boot partitions). Installation went without incident; however, upon trying to boot FC6, I receive the following block of error messages:

Code:
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
...at which point it obviously hard-locks. Some things to note:

1. This is a dual-boot machine with Ubuntu. When I boot Ubuntu, I can then mount Fedora's root which does appear to contain a complete Fedora installation.

2. Both Fedora and Ubuntu get their own respective /boot partitions (/dev/sda1 and /dev/sda2). Both also get their own LVM-contained root filesystems as well (/dev/SystemMain/FedoraRoot and /dev/SystemMain/UbuntuRoot).

3. Grub has the kernel finding the root fs through the "root=LABEL=[fslabel]" clause. In my case, it's "root=LABEL=FedoraRoot". I checked the filesystem label of the root fs by running 'e2label /dev/SystemMain/FedoraRoot', which returned no label. I then set the label to "FedoraRoot" and tried to boot into Fedora. Still go the same error.

4. I have tried modifying the "root=[blah]" clause to find the root fs by means other than the fs label. Some variations I have tried are...
* root=/dev/SystemMain/FedoraRoot
* root=/dev/mapper/SystemMain-FedoraRoot

In either case, I still receive the same message. All I know is that the kernel is being found, the root fs does exist and is not corrupt, the kernel is being passed the proper argument to find root; yet the root fs cannot be mounted. I'm stumped.

Think it's an initrd issue? Any help is greatly appreciated!
 
Old 11-01-2006, 10:29 AM   #2
jamie_h
LQ Newbie
 
Registered: Oct 2006
Distribution: Gentoo and occasionally Slackware 10.2
Posts: 11

Rep: Reputation: 0
I'm thinking it could be an issue with your /etc/fstab file, as it looks to me like its just failing to mount the root partition. The line for your root partition should read something like...

/dev/hda4 / ext3 noatime 1 2

(obviously with /dev/hda4 replaced with whatever the right partition is and ext3 changed if you're using a different filesystem)
 
Old 11-01-2006, 05:11 PM   #3
sancho
Member
 
Registered: Sep 2003
Distribution: Ubuntu 9.04/9.10 (64-bit)
Posts: 149

Original Poster
Rep: Reputation: 15
I made sure that fstab was pointing at the correct filesystem. It was originally referencing the filesystem by the label, but I've changed it to point directly at the LVM partition. So it is looking for "/dev/mapper/SystemMain-FedoraRoot".

I booted up from the recovery CD, chroot'ed into /mnt/sysimage, and recreated the initrd. I tried booting with the new initrd and *still* get the exact same error message.

Still stumped...
 
Old 12-01-2006, 05:19 PM   #4
rsashok
Member
 
Registered: Nov 2006
Location: USA, CA
Distribution: RedHat, Debian
Posts: 202

Rep: Reputation: 31
I had similar problem while ago, and the reason was that the label of the RedHat partition was different that the one in "grub.conf". I recommend booing up your Ubuntu kernel. At the prompt check out RedHat partition name by issuing 'e2label /dev/hdx#' command, where 'hdx#' is RedHat partiion, and make sure that the line in 'grub.conf' containg LABEL=root=xxxx (in my case LABEL=root=/) matches the label name.

GL.
 
Old 06-15-2007, 02:48 AM   #5
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
I have the same problem (with Fedora 7).
Did you solve the problem and if so, how please?
 
Old 06-22-2007, 02:01 AM   #6
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
I solved the problem finally.
Actually my problem was that for some reason, mkinitrd didn't find any volume group when launched from the chrooted rescue CD environment.
I edited the script and replaced the line :
Quote:
vg_list=""
by
Quote:
vg_list=myrootvolumegroup
and regenerated the initrd file.
Checked the vgchange line in the init script and rebooted fine.
 
Old 07-26-2007, 10:32 AM   #7
cheerful
Member
 
Registered: Jul 2007
Posts: 36

Rep: Reputation: 15
I have exactly same problem

I have the same problem. Re-making the image file didn't help. I would like to try your method but couldn't understand it completely. How can I know what "myrootvolumegroup" is? I run "vgdisplay", the result is "vgdisplay -- no volume groups found".

Sorry I'm new at Linux. Thank you very much!

Last edited by cheerful; 07-26-2007 at 10:44 AM.
 
Old 07-26-2007, 04:29 PM   #8
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
Are you using your LVM with another system?
 
Old 07-26-2007, 06:01 PM   #9
cheerful
Member
 
Registered: Jul 2007
Posts: 36

Rep: Reputation: 15
Sorry that I am new to Linux so I don't quite understand the terminology. Here is what I got from vg. Maybe my node is not using LVM?

>vgdisplay
vgdisplay -- ERROR: "/etc/lvmtab" doesn't exist; please run vgscan

>vgscan
vgscan -- LVM driver/module not loaded?

Here is some detailed thread I posted about the image file.

Thanks in advance for your help.

my thread

Last edited by cheerful; 07-27-2007 at 11:52 AM.
 
Old 07-27-2007, 03:23 PM   #10
RLIN
LQ Newbie
 
Registered: Oct 2004
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by rsashok
I had similar problem while ago, and the reason was that the label of the RedHat partition was different that the one in "grub.conf". I recommend booing up your Ubuntu kernel. At the prompt check out RedHat partition name by issuing 'e2label /dev/hdx#' command, where 'hdx#' is RedHat partiion, and make sure that the line in 'grub.conf' containg LABEL=root=xxxx (in my case LABEL=root=/) matches the label name.

GL.
I have the same problem!
The original system was upgraded from FC3 to F7, and it was very slow, so I had to move hard disk to a faster machine, and got exactly the same panic screen.
Do I have to reconfig kernel?
or
Could this be hardware dependent?
The original system is custom built machine
CPU - Celeron 700Mhz, 768MB memory
IDE bus - disk is set to single disk
The new system is Dell GX260
CPU - P4 2GHz, 512 MB memory
IDE bus - disk is set to single disk also.
 
Old 07-28-2007, 09:15 PM   #11
RLIN
LQ Newbie
 
Registered: Oct 2004
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by RLIN
I have the same problem!
The original system was upgraded from FC3 to F7, and it was very slow, so I had to move hard disk to a faster machine, and got exactly the same panic screen.
Do I have to reconfig kernel?
or
Could this be hardware dependent?
The original system is custom built machine
CPU - Celeron 700Mhz, 768MB memory
IDE bus - disk is set to single disk
The new system is Dell GX260
CPU - P4 2GHz, 512 MB memory
IDE bus - disk is set to single disk also.

I think this is hardware related, so I re-install FC7 instead,
Everything looks great except squirrelmail does not work.

Hopfully some one can give me some idea,

Here is the avc info regarding dovecot when I used squirrelmail:

avc: denied { create } for comm="dovecot-auth" egid=0 euid=0 exe="/usr/libexec/dovecot/dovecot-auth" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 pid=3343 scontext=system_u:system_r:dovecot_auth_t:s0 sgid=0 subj=system_u:system_r:dovecot_auth_t:s0 suid=0 tclass=netlink_audit_socket tcontext=system_u:system_r:dovecot_auth_t:s0 tty=(none) uid=0
 
Old 11-19-2008, 04:58 PM   #12
babhaskara
LQ Newbie
 
Registered: Nov 2008
Posts: 1

Rep: Reputation: 0
Dear all,

I faced the same problem with kernel 2.6.27.4 on Gigabyte notebook (SATA harddisk). In my case I had not enabled scsi & ahci to be built as modules. So here is what I had to do:
- Enable SCSI & AHCI in config ("make menuconfig"), build & re-create initrd ("mkinitrd -f /boot/initrd-2.6.27.4.img 2.6.27.4")
- Get the LV label by running "e2label /dev/sda5" (My root partition is on sda5); It was "/12".
- Edit grub.conf to add "root=LABEL=/12" & reboot

So you may confirm if you are loading the proper disk drivers and entry in grub.conf is right. I had to try different combinations for "root=" param before I got it working

Bhaskara.
 
Old 02-07-2009, 11:06 AM   #13
mukulm
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
I was having the same problem after installing Fedora 9 as a dual boot with Ubuntu. The problem was solved when I entered the root in the traditional format (i.e. non-UUID way). So instead of:

kernel /boot/vmlinuz root=UUID=...

I entered:

kernel /boot/vmlinuz root=/dev/sda3

Don't know the reason why this worked, but it solved the problem for me!

-Mukul
 
Old 02-09-2009, 12:43 AM   #14
sanjay.kashi
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
fedora5 kernel panic

i got the following error
root(hd0,6)
filesystem type is ext2fs, partition type 0x83 kernel/vmlinuz-2.6.15-1.2054-fc5amp ro root=/dev/volgroup00/logvol00 rhgb quiet ..........
ext3-fs:dm-0:couldn't mount because unsupported optional features(20002000)
mount:error mounting /dev/root on /sysroot as ext3:invalid argument
setuproot: moving /dev failed: no such file or directory
setuproot: error mounting /proc: no such file or directory
setuproot: error mounting /sys: no such file or directory
kernel panic - not syncing: Attempted to kill init!



please anyone help in getting the solution for this problem
 
Old 02-09-2009, 12:27 PM   #15
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
try:
tune2fs -O^dir_index /dev/volgroup00/logvol00
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unclean shutdown causes "Couldn't find matching filesystem: label=" error irnerdette Red Hat 3 06-02-2006 01:44 PM
FC5t3 error: mount: could not find filesystem '/dev/root' pathall Fedora 1 03-10-2006 10:39 PM
RH9 "remounting root filesystem in read-write mode" ChrisHax Linux - Newbie 3 07-23-2004 09:54 PM
"unable to find device node for /dev/x in /dev!" during install zombiedeth *BSD 0 02-02-2004 02:38 AM
dump + restore to backup linux ; "Couldn't find matching filesystem: LABEL=/" on boot markus1982 Linux - General 4 09-21-2002 01:16 PM


All times are GMT -5. The time now is 07:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration