LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 03-21-2006, 04:07 PM   #1
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 346

Rep: Reputation: 31
FC4 --> FC5: GDM hosed


I just upgraded my FC4 system to FC5 with the dvd disk installer. The is now up and running, I can ssh in and mount its nfs shares on my laptop. But I can't seem to login with gdm. Under FC4, I had it set up to log me in automatically (I am the only user on the machine). Now, however, I get an error message:

Code:
Your session lasted less than ten seconds. 
There may be something wrong with your installation 
or you may be out of diskspace.

Try logging in a failsafe session to see if you can fix this problem.
It also indicates that something is wrong with a library:

Code:
/usr/bin/gnome-session 
/usr/lib/libgnomevfs-2.so.0
symbol lookup error
undefined symbol: g-thread ...
I assume that this is an issue with gdm and the gdm-greeter, but I am not sure. Nor do I have any idea how to proceed, other than to install Ubuntu instead Anyone have any ideas?

Last edited by Kropotkin; 03-21-2006 at 05:34 PM.
 
Old 03-21-2006, 04:42 PM   #2
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 346

Original Poster
Rep: Reputation: 31
After posting the message above, I encountered this message in the Slackware forum: http://www.linuxquestions.org/questi...d.php?t=386010

Code:
"Re: "Your session only lasted 10 seconds...."
I'm not very skilled using command-line stuff in Linux so here is what worked for me:
1. Log in as root rather than your normal user name.
2. Access the User Manager via APPLICATIONS, SYSTEM SETTINGS, USERS AND GROUPS
3. Correct the Home Directory that is shown for the normal user name. Mine incorrectly showed "/root" as the home directory. I changed it to "/home/username". Reboot and log in normally. All works fine now. Hope this helps someone else.
Alas, I don't even get to the login prompt. However, I edited /etc/gdm/custom.conf on the command line and turned off the auto-login, but that didn't help; I no longer get the error message; all that is displayed is the arrow cursor with the blue tail.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it possible to do an "in-place" upgrade from FC4 to FC5? ArchW Fedora 9 04-22-2006 04:24 AM
"Subjective" - How Smoothly Will Uprgrade From FC4 to FC5 Go? mrclisdue Fedora 5 03-22-2006 08:54 PM
FC5-test3 --> FC5-release - Anyone tried it? GL1800 Fedora 5 03-22-2006 04:16 PM
FC4 gdm issues digitaldrowning Linux - Software 4 02-09-2006 02:16 PM
FC4/FC5 installation problems udazzleme Fedora 9 01-24-2006 06:44 PM


All times are GMT -5. The time now is 07:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration