LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora - Installation (http://www.linuxquestions.org/questions/fedora-installation-39/)
-   -   FC2 freezes on first boot (http://www.linuxquestions.org/questions/fedora-installation-39/fc2-freezes-on-first-boot-221128/)

Davebomb 08-22-2004 11:49 PM

FC2 freezes on first boot
 
I am new to Linux.

I installed Fedora Core 2 today for the first time, a dual boot with Windows XP. The install went smoothly, rebooted, and begun some kind of initialization routine. It gets throught about eight operations (such as setting host name) and then freezes on "starting NFS4 idmapd". After about ten minutes I reboot and then during startup there is a message saying an unclean shutdown was detected. It goes through a few operations that seem to be double-checking the system and then freezes on "enabling swap space." It then freezes up every time on "enabling swap space" after every restart. So I haven't even been able to get to a command prompt yet. Also, during startup there is a message that flashes by quickly, saying something like "ACPI: PAE and S3 don't like each other, disabling S3."

Can anyone point me in the right direction to start troubleshooting this?

System Info:
ECS 648FX-A Motherboard with onboard LAN and sound.
Pentium 2.4 Hyper-Threading
512 MB DDR RAM PC 3200
Nvidia FX 5600 Video Card
CDR Drive + DVD ROM + Floppy
TV Wonder Tuner Card
160 GB Hard Drive with 3 partitions
800 MB Swap
52 GB for Fedora
100 GB for Windows

Briska_69 08-24-2004 08:26 PM

FC2 Post-Install Hangs
 
I am having the same problem. Installation goes smoothly and upon initial boot the system hangs on "probing for new hardware". After letting it sit for an hour or so I reboot and them the system hangs at "enabling swap space" I have checked and made sure that I am not using plug and play in my bios settings as well as hours of searching the forums for the answer, with no luck. My system specs are listed below. HELP PLEASE!!!!!!!!!! (Im sure that if i wasn't such a noob I wouldn't be having such a hard time with this)

scoobdoobery 08-28-2004 02:22 PM

FC2 Post-Install Hangs
 
I have experienced a very similar problem...
For me, FC2 hangs whenever it tries to bring up the cups service. I thought that I could solve this problem by merely disabling the service and then updating it later. Perhaps this tactic will solve your problem(s).

You can do this by editing the grub booting options by following the directions at the bottom of the grub screen (for me it's just hitting e on the preferred kernel). Then, you edit that kernel to go into single user mode by deleting the "ro" in the middle of the instruction line and appending a "single" at the end of the line. Now you can use chkconfig to edit/disable services that are screwing up the booting sequence. This can be done by following chkconfig's syntax. You can try just turning off all levels of whichever service is hanging and maybe that will help. I think that it was something like (in the case of cups) "chkconfig --list cups" to see which levels it was on for and for example "chkconfig --level 2 cups off" in order to turn off a specific level (in this case 2). However, don't quote me on it as I haven't tried this in a while. You can then cleanly reboot by simple typing "reboot" and you'll be back into the typical booting process without single user mode. Remember not to try to mess around a lot in single user mode as you can really mess things up that way.

Unfortunately, this didn't really fix FC2's hanging problems for me... Though it skipped past cups without any problem, it would hang on another service and, if that service were also disabled, hang on yet another until it started hanging on necessary services. I have not been able to figure out how to remedy this problem and would like anybody's insight.

In any event, I hope that you don't have the same problem as me as I'm about to give up on FC* altogether. :(

scoobdoobery 09-01-2004 07:02 PM

C'MON!
 
Someone else has to have had a problem like this... Does anyone out there know how to fix it or even what's wrong in the first place?

akalmonab 02-24-2005 02:11 PM

Hi all, I had very similar problem when i first installled FC2 so I waited for FC3 and it was fixed. now I friend of mine ran in to the same problem and he was able to resolve it by editing the grub.conf file found in the /etc directory. at the end of the line that load the kernel you are using add the word "quite" What this does is disable the graphical boot screen that FC2 now uses. I am not sure why or how this works but it does. I went back to FC2 and sure enough after the install it hung on the "enabling swap space". I did the edit my friend suggested and it worked.

Oh before i forget you can edit the grub.conf at boot time. press the arrow keys up and down so that you gain access at the grub configurator seconds after your bios settings are done. if you have set a grub password you already know what I am talking about. Select the kernel you want to load. Press the "e" for edit write the "quiet" at the end of the line and then "b" for boot........best of luck.!

vi /etc/grub.conf
kernel /vmlinuz-2.6.10-1.760_FC3 ro root=LABEL=/ quiet

arctic123 05-01-2005 10:08 AM

actually heres what I did. went to grub, pressed "a" got rid of the "rhgb quiet" at the end on the line and now mine works fine.


All times are GMT -5. The time now is 05:08 AM.