LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-27-2004, 08:54 PM   #1
eudyptes_eudypt
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Yummed to 2.6.9-1.6_FC2 & X won't start


Performed a "routine" yum update last week, which installed a new kernel (to 2.6.9-1.6_FC2) and loaded a number of X fonts, etc. Now I cannot boot Gnome.

When I enter "startx" at the command line, I get the Fedora splash screen, but it blows up loading Gnome and gives the following message:

error while loading shared libraries: /usr/lib/libfontconfig.so.1
undefined symbol: FT_Get_BDF_Property

I checked, and libfontconfig.so.1 is present, and is symbolically linked to libfontconfig.so.1.0.4, also in /usr/lib.

I can start an xterm, and can also start a non-desktop X session. But, when trying to start Gnome (or KDE for that matter), I get the same message.

Does anyone have any ideas as I'm pulling my hair out and hope I don't have to reinstall to see if that rectifies the problem (but would rather not right now...)

Ideas are greatly appreciated...
 
Old 11-28-2004, 07:35 AM   #2
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
"and loaded a number of X fonts, etc"

It might be worth looking at this set of changes, and reverting them.

GNOME and KDE rely on fontconfig working, but xterm doesn't know what fontconfig is, so it sounds to me like you have correctly pegged it as a fontconfig/font issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Phục hồi dữ liệu bị mất???, cứ pollsite General 1 06-27-2005 12:39 PM
Hard drives start at hdc && fdisk doesn't show hde triet Linux - Hardware 0 11-03-2004 09:25 PM
GNOME & KDE start together TMS Linux - Newbie 0 06-08-2004 07:58 AM
SUSE 9.0- suse help & java web start- take 3mins "before" they start to load Bodkin Linux - Distributions 3 11-16-2003 09:23 AM
sshd start & restart JeRrYmAn Linux - Newbie 3 10-07-2003 09:05 AM


All times are GMT -5. The time now is 12:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration