LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-23-2013, 12:52 PM   #1
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Rep: Reputation: 55
Yumex Problems - Fails


fedora 18 / KDE

I have problems starting Yumex, something about backend not running.

Yum runs normal doing installs or updates.

Nothing shows up in /var/log/yum or var/log/messages when yumex FAILS.


$ yumex -d
15:20:52 : INFO - Using config file : /home/jim/.config/yumex/yumex.conf
15:20:52 : INFO - Using config file : /home/jim/.config/yumex/yumex.conf
15:20:52 : DEBUG - Current Yumex Settings:
15:20:52 : DEBUG - autorefresh: True
15:20:52 : DEBUG - branding_title: 'Yum Extender'
15:20:52 : DEBUG - bugzilla_url: 'https://bugzilla.redhat.com/show_bug.cgi?id='
15:20:52 : DEBUG - color_downgrade: 'goldenrod'
15:20:52 : DEBUG - color_install: 'darkgreen'
15:20:52 : DEBUG - color_normal: 'black'
15:20:52 : DEBUG - color_obsolete: 'blue'
15:20:52 : DEBUG - color_update: 'red'
15:20:52 : DEBUG - debug: True
15:20:52 : DEBUG - disable_netcheck: False
15:20:52 : DEBUG - disable_repo_page: False
15:20:52 : DEBUG - history_limit: 15
15:20:52 : DEBUG - no_gpg_check: False
15:20:52 : DEBUG - plugins: True
15:20:52 : DEBUG - proxy: ''
15:20:52 : DEBUG - recentdays: 14
15:20:52 : DEBUG - remove_requirements: False
15:20:52 : DEBUG - repo_exclude: ['debug', 'source']
15:20:52 : DEBUG - show_newest_only: True
15:20:52 : DEBUG - skip_broken: False
15:20:52 : DEBUG - typeahead_search: False
15:20:52 : DEBUG - use_sortable_view: False
15:20:52 : DEBUG - use_sudo: False
15:20:52 : DEBUG - win_height: 494
15:20:52 : DEBUG - win_sep: 300
15:20:52 : DEBUG - win_width: 1000
15:20:52 : DEBUG - yum_conf: '/etc/yum.conf'
15:20:52 : DEBUG - yumdebuglevel: 2
15:20:53 : DEBUG - network interface wlan0 (rtl8188eu) is connected
15:20:53 : DEBUG - network interface wlan0 (rtl8188eu) is connected
15:20:54 : INFO - Connected to an network
15:20:54 : DEBUG - Getting package lists - BEGIN <yumexgui.populate_package_cache>
15:20:54 : DEBUG - network interface wlan0 (rtl8188eu) is connected
15:20:54 : INFO - Starting yum child process
15:20:54 : DEBUG - Initialize yum backend - BEGIN <yum_backend.setup>
15:20:54 : DEBUG - Setup START <yum_backend.setup>
15:21:08 : ERROR - ERROR: Fatal Error : backend-not-running
15:21:08 : ERROR - ERROR: Backend not running as expected

Yum Extender will terminate
--> exit code : None
15:21:08 : DEBUG - Quiting the program !!! <yum_backend.quit>
15:21:08 : INFO - yum backend process is ended
15:21:08 : DEBUG - Backend reset completed <yum_backend.quit>
15:21:08 : DEBUG - Quiting the program !!! <yum_backend.quit>
15:21:08 : INFO - yum backend process is ended
15:21:08 : DEBUG - Backend reset completed <yum_backend.quit>
Program Terminated
[jim@localhost ~]$
 
Old 08-23-2013, 01:59 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,535

Rep: Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807
you need to run it as root , and not as a normal user
Code:
su -
yumex
" su" will not work you need to use the " -"
 
Old 08-23-2013, 04:20 PM   #3
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Original Poster
Rep: Reputation: 55
su -
yumex won't run, it tells you it cannot be run as root.

It tells you to run command;

yumex --root #to force it to run and that is the only way it will run.
 
Old 08-23-2013, 06:23 PM   #4
Galaxy_Stranger
Member
 
Registered: Oct 2003
Distribution: CentOS 6 and Fedora
Posts: 240

Rep: Reputation: 36
Try forcing as root. Login as root at the command-line, then:
Code:
yumex --root
See if that works.
 
Old 08-23-2013, 07:58 PM   #5
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,400

Original Poster
Rep: Reputation: 55
That is what I said in my previous Post.
 
Old 08-23-2013, 08:06 PM   #6
Galaxy_Stranger
Member
 
Registered: Oct 2003
Distribution: CentOS 6 and Fedora
Posts: 240

Rep: Reputation: 36
Oops.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is anyone else having problems with yumex-2.9.7? maestro52 Fedora 2 04-02-2010 02:09 PM
yum -y install yumex - Fails! rayj00 Linux - Software 7 10-03-2006 04:09 AM
yumex key problems mickeyboa Fedora 2 03-08-2006 06:03 PM
Yumex problems in FC4 mickeyboa Fedora 2 12-31-2005 04:35 PM
Yumex mickeyboa Fedora 6 09-17-2005 07:04 PM


All times are GMT -5. The time now is 08:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration