LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   yum update issue (http://www.linuxquestions.org/questions/fedora-35/yum-update-issue-503444/)

crazy8 11-20-2006 10:48 PM

yum update issue
 
Ok I am running FC4 right now and the other night I did a "yum update" and had it install everything it found that needed to be updated. Well my instructer and I from school set my system up to use my wirless USB adaptor for internet. So we used ndiswraper and recompiled the kernel and all this other fun stuff that I realy have no clue how to do on my own. So here is the deal. After I did the yum update I know longer can get online. How would I go about solving this issue? Also when I go into "Network Device Control" and click "Activate" I get this "Device wlan0 does not seem to be present, delaying initialization." so whats the deal? Is there a way I can fix this and get my Wireless USB working again? I am new to linux but I am learning. One more thing, if I was to upgrade to FC5 or even 6 would I have to worry about this issue happening again?

Thanks for all the help in advance. Keep up the great work here.

squall1986 11-21-2006 03:02 AM

Hey, I'm pretty new to Linux as well, but it seems to me that since you updated your kernel, you might have to redownload ndiswrapper in case it wasn't included in the repositories you used when you updated with yum.

reddazz 11-21-2006 04:30 AM

If YUM installed a new kernel, then you have to setup your network connection from scratch or boot using the old kernel instead of the new one.

crazy8 11-21-2006 09:45 AM

You know I think you guys are right. I remember going into my directory where the kernels are (looking for something else) and saw I beleive it was 2.6.17-2324 or something like that. I am using the 2.6.17 or 2.6.11 or whatever the newest one is that doesnt have the "-" anyway yea I think I did see them. So if I dont want to use those kernels can I just delete the folders for them or no?

I dont think redoing ndiswraper is an option since we had to do a custom build and had to go through all these hoops to get it working. My ITT Tech instructor did most of the work, no way can I go about doing it alone especially since I dont know how to recompile a kernel.lol

Thank both of you for the help. I didnt notice on the boot screen any extra kernels (I wasnt realy looking for any either) so tonight I will pay attention and see what I figure out.

Thanks again

reddazz 11-21-2006 10:44 AM

Don't delete those kernels manually. Use the rpm command e.g.
Code:

#rpm -qa | grep -i kernel
A list of installed kernels will be listed. Uninstall the ones you do not need by doing
Code:

#rpm -e kernel-version
Alternatively you can leave the kernels installed and make sure you boot from whichever kernel was working properly with your wireless card. You can make this kernel the default in your /boot/grub/menu.lst or /boot/grub/grub.conf.

crazy8 11-21-2006 03:32 PM

since I went ahead and just did the full "yum update" rather then looking at the list, is there a way I could do a full yum update WITHOUT a kernel update? Also just so I know, When I do a "yum list" (this might be a stupid question) and I am looking at the list are updated kernels listed as kernels or atleast have "kernel" in the package name with in the list?

Thank you all a ton.

Hitboxx 11-21-2006 07:06 PM

Here's how it(mine) looks
Code:

[shrikant@shricore ~]$ yum list | grep -i kernel
kernel.i686                              2.6.18-1.2849.fc6      installed     
kernel.i686                              2.6.18-1.2798.fc6      installed     
kernel-headers.i386                      2.6.18-1.2798.fc6      installed     
kernel-xen.i686                          2.6.18-1.2798.fc6      installed     
kernel.i586                              2.6.18-1.2849.fc6      updates       
kernel-PAE.i686                          2.6.18-1.2849.fc6      updates       
kernel-PAE-devel.i686                    2.6.18-1.2849.fc6      updates       
kernel-devel.i586                        2.6.18-1.2849.fc6      updates       
kernel-devel.i686                        2.6.18-1.2849.fc6      updates       
kernel-doc.noarch                        2.6.18-1.2849.fc6      updates       
kernel-headers.i386                      2.6.18-1.2849.fc6      updates       
kernel-kdump.i686                        2.6.18-1.2849.fc6      updates       
kernel-kdump-devel.i686                  2.6.18-1.2849.fc6      updates       
kernel-xen.i686                          2.6.18-1.2849.fc6      updates       
kernel-xen-devel.i686                    2.6.18-1.2849.fc6      updates       
yum-kernel-module.noarch                1.0.1-1.fc6            extras


crazy8 11-21-2006 07:10 PM

Ok that helps, now I know what to look for to make sure it doesnt happen again...Thanks alot guys, I realy appreciate it

reddazz 11-22-2006 03:28 AM

Quote:

Originally Posted by crazy8
since I went ahead and just did the full "yum update" rather then looking at the list, is there a way I could do a full yum update WITHOUT a kernel update? Also just so I know, When I do a "yum list" (this might be a stupid question) and I am looking at the list are updated kernels listed as kernels or atleast have "kernel" in the package name with in the list?

Thank you all a ton.

To make sure that the kernel does not get upgraded when you run "yum update" or "yum upgrade", edit /etc/yum.conf and put the following
Code:

# Exclude the following
exclude=kernel*


crazy8 11-22-2006 02:07 PM

Awsome. Thank you all so much, youve been a big help.

crazy8 11-23-2006 12:49 PM

Ok I guess I do have one last question which was regarding to make my 2.6.17 kernel the default. I found the menu.lst and grub.conf, so here are my questions.

1) How do I do it (make the kernel default)
2) Do I need to edit both of them or just one?

Thank you all again so much

Hitboxx 11-23-2006 08:44 PM

1) Edit grub.conf as root and find a value called 'default'. Set it to a number starting from 0 for the subsequent kernel entries.,i.e 0 sets the top entry to boot, 1 sets the second entry and so on.
2) Editing grub.conf should be enough on fedora systems. The menu.lst is provided as an option but is the default on other distros like debian.


All times are GMT -5. The time now is 03:56 AM.