LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Yum update errors (http://www.linuxquestions.org/questions/fedora-35/yum-update-errors-404174/)

gnjunior 01-16-2006 05:14 PM

Yum update errors
 
Hi,

When I try to yum update FC4 I get those errors:

--> Running transaction check
Error: Missing Dependency: ocaml = 3.09.1-1.fc4 is needed by package labltk
Error: Unable to satisfy dependencies
Error: Package dlm-kernel needs /lib/modules/2.6.14-1.1653_FC4, this is not available.
Error: Package labltk needs ocaml = 3.09.1-1.fc4, this is not available.
Error: Package cman-kernel needs /lib/modules/2.6.14-1.1653_FC4, this is not available.
Error: Package GFS-kernel needs /lib/modules/2.6.14-1.1653_FC4, this is not available.
Error: Package gnbd-kernel needs /lib/modules/2.6.14-1.1653_FC4, this is not available.

Here's the list of the repositories used during yum update:

[root@localhost ~]# yum update
Setting up Update Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
dries 100% |=========================| 951 B 00:00
dag 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
newrpms.sunsite.dk 100% |=========================| 951 B 00:00
updates 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00

Do you think those errors are "normal" and will eventually fix themself, as those packages become available?

or

Do you think the problem is caused by the mixing or too many of those repositories?

and if so

I'm a newbie to Linux and after numerous installations of Fedora 4, I always encounter some kind of error in yum updates after a while, for future installation, how can I avoid this?

I find the repositories incompatibility thing very confusing for me and any clarification or advice will be appreciate.

Thanks

Athlon XP2400+
2.6.13-1.1526_FC4

Gethyn 01-16-2006 07:32 PM

I don't think you need any of those packages (unless you installed them on purpose). Maybe try removing them. If you don't want to do that, you can always use the --exclude option to exclude any packages that cause errors from being updated by yum. Someone else was complaining of errors with the same (or similar) packages the other day, you might try looking for their post and maybe seeing if they have any advice on how they got around the problem.

gnjunior 01-17-2006 08:47 AM

Quote:

Originally Posted by Gethyn
I don't think you need any of those packages (unless you installed them on purpose). Maybe try removing them. If you don't want to do that, you can always use the --exclude option to exclude any packages that cause errors from being updated by yum. Someone else was complaining of errors with the same (or similar) packages the other day, you might try looking for their post and maybe seeing if they have any advice on how they got around the problem.


Hi,

OK, I've found the thread:

sorry link not allowed for me

First I did 'yum update kernel*', I updated to 2.6.14-1.1656_FC4,
followed by 'yum update' that reduce error to one:

Error: Missing Dependency: ocaml = 3.09.1-1.fc4 is needed by package labltk

so I did 'yum --exclude labltk update' and so on until it work:

yum --exclude labltk --exclude lablgl --exclude lablgtk update

and finally updated:

Install 11 Package(s)
Update 230 Package(s)
Remove 0 Package(s)
Total download size: 597 M

But strangely after that last update my kernel were updated again and this time to an earlier version 2.6.14-1.1653_FC4??? and worst or gladly, they were not install in the same location as the others; /usr/src/kernels!

So I removed the 2.6.14-1.1653_FC4 kernel with yumex, who automatically remove those too:
GFS-kernel
cman-kernel
dlm-kernel
gnbd-kernel
lablgtk

Which are the errors I've got in the fist place (see top).

To make a long story short, if I understand right, yum update try to update two different kernel at the time.

What do you think?

Thanks

Gethyn 01-17-2006 10:36 AM

That does seem quite strange. Maybe yum is accessing different mirrors when you run it, and they don't all have exactly the same versions of kernels? I don't really know what's going on, I've not had this problem and don't know enough about how yum works to offer much insight. The only advice I can suggest is to avoid updating the kernel for a while. This is usually a good idea anyway, unless there is a reason you need to change to another kernel it's best to stick with one that works for you, as changing it often tends to break things. I don't understand the ocaml error at all. If it's not causing you any problems, it's probably best to exclude it from updates for now, and maybe try updating in a week or two (as you suggested in your original post).

Of course, if you're lucky, someone who has a better idea what they're talking about might see this thread and tell you what's actually going on...

gnjunior 01-17-2006 07:55 PM

Hi,

lablgtk update depend on: ocaml = 3.09.1-1.fc4, I have: ocaml = 3.09.1-1.2.fc4.rf.

I don't think this one gonna be resolve anytime soon.


GFS-kernel, cman-kernel, dlm-kernel, gnbd-kernel depend on kernel 2.6.14-1.1653_FC4

I won't change 2.6.14-1.1656_FC4 for 2.6.14-1.1653_FC4 especially if install in a new directory which will complicate Nvidia drivers compilation, among other things.



This command works fine:

yum --exclude *kernel --exclude lablgtk update

Thanks for your help Gethyn


All times are GMT -5. The time now is 06:53 AM.