LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Yum update error (http://www.linuxquestions.org/questions/fedora-35/yum-update-error-432174/)

natewlew 04-06-2006 12:00 AM

Yum update error
 
I seem to be having trouble updating with yum. A few days ago I did an update on a fresh install. I entered all the data from:
http://www.stanton-finley.net/fedora...s.html#Warning and updated my system. Everything went well. Then I realized I didn't get KDE 3.5. So I added a KDE repo (I forgot where I got that from). Then I did another yum update. Thats when I got my error:
Quote:

Running transaction check
--> Processing Dependency: libslp.so.1 for package: kdenetwork
--> Processing Dependency: xscreensaver-extras for package: kdeartwork
--> Processing Dependency: libIlmImf.so.2 for package: kdegraphics
--> Processing Dependency: libgpgme.so.11(GPGME_1.0) for package: kdepim
--> Processing Dependency: libdns_sd.so.1 for package: kdebase
--> Processing Dependency: xscreensaver-gl-extras for package: kdeartwork
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Processing Dependency: liblcms.so.1 for package: kdegraphics
--> Processing Dependency: liblcms.so.1 for package: ImageMagick
--> Processing Dependency: libgpgme.so.11 for package: kdepim
--> Processing Dependency: libdbus-qt-1.so.1 for package: kdebase
--> Processing Dependency: libjasper-1.701.so.1 for package: kdelibs
--> Processing Dependency: libxmms.so.1 for package: kdeutils
--> Processing Dependency: libIlmImf.so.2 for package: kdebase
--> Processing Dependency: perl(DCOP) for package: kdesdk
--> Processing Dependency: libhpip.so.0 for package: hpijs
--> Processing Dependency: libmal.so.0 for package: kdepim
--> Processing Dependency: libgnokii.so.2 for package: kdepim
--> Processing Dependency: dhcdbd for package: NetworkManager
--> Processing Dependency: libdns_sd.so.1 for package: kdelibs
--> Processing Dependency: libjasper-1.701.so.1 for package: ImageMagick
--> Processing Dependency: libmeanwhile.so.0 for package: kdenetwork
--> Processing Dependency: libIlmImf.so.2 for package: kdelibs
--> Processing Dependency: libHalf.so.2 for package: kdelibs
--> Processing Dependency: kdelibs-apidocs for package: kdevelop
--> Processing Dependency: python-numeric for package: pygtk2
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xmms.i386 1:1.2.10-21.fc4 set to be updated
---> Package kdelibs-apidocs.noarch 6:3.5.1-1.2.kde set to be updated
---> Package xscreensaver-extras.i386 1:4.21-4 set to be updated
---> Package libmal.i386 0:0.31-2.fc4 set to be updated
---> Package libsane-hpaio.i386 0:0.9.8-3.2 set to be updated
---> Package openslp.i386 0:1.2.1-4.fc4 set to be updated
---> Package dhcdbd.i386 0:1.9-1.FC4 set to be updated
---> Package meanwhile.i386 0:0.5.0-1.2.fc4.rf set to be updated
---> Package xscreensaver-gl-extras.i386 1:4.21-4 set to be updated
---> Package mDNSResponder.i386 0:107.1-0.0.fc4 set to be updated
---> Package gnokii.i386 0:0.6.12-4.fc4 set to be updated
---> Package jasper.i386 0:1.701.0-9.fc4 set to be updated
---> Package dbus-qt.i386 0:0.33-3.2.fc4.kde set to be updated
---> Package kdebindings.i386 0:3.5.1-0.1.fc4 set to be updated
---> Package lcms.i386 0:1.15-1.2.fc4.rf set to be updated
---> Package gpgme.i386 0:1.1.2-3.fc4 set to be updated
---> Package python-numeric.i386 0:23.7-2 set to be updated
---> Package OpenEXR.i386 0:1.2.2-6.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libfltk_gl.so.1.1 for package: OpenEXR
--> Processing Dependency: libfltk.so.1.1 for package: OpenEXR
--> Processing Dependency: ruby >= 1.8 for package: kdebindings
--> Processing Dependency: libpth.so.20 for package: gpgme
--> Processing Dependency: gnupg2 >= 1.9.6 for package: gpgme
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Processing Dependency: libruby.so.1.8 for package: kdebindings
--> Processing Dependency: libmikmod.so.2 for package: xmms
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package fltk.i386 0:1.1.6-1.2.fc4.rf set to be updated
---> Package mikmod.i386 0:3.1.6-35.FC4 set to be updated
---> Package ruby-libs.i386 0:1.8.4-1.fc4 set to be updated
---> Package ruby.i386 0:1.8.4-1.fc4 set to be updated
---> Package gnupg2.i386 0:1.9.20-2.fc4 set to be updated
---> Package pth.i386 0:2.0.6-1.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libksba.so.8(KSBA_0.9) for package: gnupg2
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Processing Dependency: pinentry >= 0.7.1 for package: gnupg2
--> Processing Dependency: libksba.so.8 for package: gnupg2
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package pinentry.i386 0:0.7.1-4 set to be updated
---> Package libksba.i386 0:0.9.13-2.fc4 set to be updated
--> Running transaction check
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Finished Dependency Resolution
Error: glibc-common conflicts with glibc > 2.3.5

I don't know how to fix my glibc problem.

jlo_sandog 04-06-2006 02:14 PM

try updating glibc, glibc-devel, and glibc-common. My install shows that they have the same version (2.4-4). In fact I think you have mismatched versions.

gerrit 04-06-2006 03:05 PM

yum conflict
 
hi natewieuw and jlo sandog

I have de same error width the next results
Om a amd7 system there I have no problem
The date of the new files a the same

Installed Packages
glibc.i386 2.3.5-10 installed
glibc-common.i386 2.3.6-3 installed
glibc-common.i386 2.3.5-10 installed
glibc-devel.i386 2.3.5-10 installed
glibc-headers.i386 2.3.5-10 installed
glibc-kernheaders.i386 2.4-9.1.94 installed
Available Packages
glibc.i386 2.3.6-3 updates-released
glibc-debuginfo.i386 2.3.6-3 updates-released
glibc-debuginfo-common.i386 2.3.6-3 updates-released
glibc-devel.i386 2.3.6-3 updates-released
glibc-headers.i386 2.3.6-3 updates-released
glibc-profile.i386 2.3.6-3 updates-released
glibc-utils.i386 2.3.6-3 updates-released

[root@Amd6 ~]# yum update glibc.i386
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package glibc.i386 0:2.3.6-3 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.3.5-10 for package: glibc-devel
--> Processing Dependency: glibc = 2.3.5-10 for package: glibc-headers
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-devel.i386 0:2.3.6-3 set to be updated
---> Package glibc-headers.i386 0:2.3.6-3 set to be updated
--> Running transaction check
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Finished Dependency Resolution
Error: glibc-common conflicts with glibc > 2.3.5

natewlew 04-06-2006 09:11 PM

Thanks for your reply but I still seem to get the same error:
Quote:

[root@localhost]# yum update glibc glibc-devel glibc-common

Added 25 new packages, deleted 25 old in 9.30 seconds
Could not find update match for glibc-common
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for glibc to pack into transaction set.
glibc-2.3.6-3.i686.rpm 100% |=========================| 135 kB 00:03
---> Package glibc.i686 0:2.3.6-3 set to be updated
---> Package glibc-devel.i386 0:2.3.6-3 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.3.5-10 for package: glibc-headers
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Processing Dependency: glibc-headers = 2.3.6-3 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-headers.i386 0:2.3.6-3 set to be updated
--> Running transaction check
--> Processing Conflict: glibc-common conflicts glibc > 2.3.5
--> Finished Dependency Resolution
Error: glibc-common conflicts with glibc > 2.3.5
I seems my problem is glibc-common. There isn't an update for it and thats where the conflict is (I think:scratch:).
Maybe I should download a newer version on glibc-common from somewhere else and install it?

jlo_sandog 04-07-2006 02:52 AM

looking at this
http://download.fedora.redhat.com/pu...pdates/4/i386/
shows that the latest version for FC4 is 2.3.6. Do Yum list *glibc* to see whats installed

natewlew 04-07-2006 03:18 PM

Thanks for all of your help. I don't know what the problem was but I now have centos on my box.

praveencusat 06-13-2007 01:18 PM

May be this will solve the problem

move fedora-development.repo and fedora-updates.repo out of /etc/yum.repos.d/ and replace them with fedora-development.repo.rpmnew and fedora-updates.repo.rpmnew.

courtesy: http://www.ioncannon.net/linux/68/up...ora7-with-yum/

econ0003 06-27-2007 05:01 PM

Possible Solution
 
I had the same problem when updating glibc on fedora core 5. The command below fixed the problem for me.

yum update glibc glibc-common glibc-headers glibc-devel

praveencusat 06-29-2007 03:16 PM

Quote:

Originally Posted by econ0003
yum update glibc glibc-common glibc-headers glibc-devel

Thanks "econ003", this helped me to solve the problem. Thanks a lot

I had some Error in resolving dependency for some other packages. So I un-installed them. Everything then worked fine for me. Thanks again

veselo123 08-16-2008 12:22 AM

Quote:

Originally Posted by praveencusat (Post 2805014)
Thanks "econ003", this helped me to solve the problem. Thanks a lot

I had some Error in resolving dependency for some other packages. So I un-installed them. Everything then worked fine for me. Thanks again

I have such problem ! when i type this command :

# yum list glibc.i686
Loading "allowdowngrade" plugin
Loading "fastestmirror" plugin
Loading "changelog" plugin
Loading "kernel-module" plugin
Loading "installonlyn" plugin
Loading "tsflags" plugin
Loading "skip-broken" plugin
Loading "protectbase" plugin
Loading "downloadonly" plugin
Loading "priorities" plugin
Setting up repositories
rpmforge 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 951 B 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
0 packages excluded due to repository priority protections
Installed Packages
glibc.i686 2.5-18.el5_1.1 installed



and when i try to type : yum update or yum groupinstall "Development Libraries" or



yum list glibc.i686
Loading "allowdowngrade" plugin
Loading "fastestmirror" plugin
Loading "changelog" plugin
Loading "kernel-module" plugin
Loading "installonlyn" plugin
Loading "tsflags" plugin
Loading "skip-broken" plugin
Loading "protectbase" plugin
Loading "downloadonly" plugin
Loading "priorities" plugin
Setting up repositories
rpmforge 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 951 B 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
0 packages excluded due to repository priority protections
Installed Packages
glibc.i686 2.5-18.el5_1.1 installed
You have new mail in /var/spool/mail/root
[root@localhost ~]# yum groupinstall "Development Libraries"
Loading "allowdowngrade" plugin
Loading "fastestmirror" plugin
Loading "changelog" plugin
Loading "kernel-module" plugin
Loading "installonlyn" plugin
Loading "tsflags" plugin
Loading "skip-broken" plugin
Loading "protectbase" plugin
Loading "downloadonly" plugin
Loading "priorities" plugin
Setting up Group Process
Setting up repositories
Loading mirror speeds from cached hostfile
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
0 packages excluded due to repository priority protections
Package zlib-devel - 1.2.3-3.x86_64 already installed and latest version
Package readline-devel - 5.1-1.1.x86_64 already installed and latest version
Package ncurses-devel - 5.5-24.20060715.x86_64 already installed and latest version
Package bzip2-devel - 1.0.3-3.x86_64 already installed and latest version
Package libtermcap-devel - 2.0.8-46.1.x86_64 already installed and latest version
Package lockdev-devel - 1.0.1-10.x86_64 already installed and latest version
Package cyrus-sasl-devel - 2.1.22-4.x86_64 already installed and latest version
Package xmlsec1 - 1.2.9-8.1.x86_64 already installed and latest version
Package gpm-devel - 1.20.1-74.1.x86_64 already installed and latest version
Package slang-devel - 2.0.6-4.el5.x86_64 already installed and latest version
Package db4-devel - 4.3.29-9.fc6.x86_64 already installed and latest version
Package gmp-devel - 4.1.4-10.el5.x86_64 already installed and latest version
Package curl-devel - 7.15.5-2.el5.x86_64 already installed and latest version
Package xmlsec1-devel - 1.2.9-8.1.x86_64 already installed and latest version
Package boost-devel - 1.33.1-10.el5.x86_64 already installed and latest version
Package libcap-devel - 1.10-26.x86_64 already installed and latest version
Package gdbm-devel - 1.8.0-26.2.1.x86_64 already installed and latest version
Package libattr-devel - 2.4.32-1.1.x86_64 already installed and latest version
Package hesiod-devel - 3.1.0-8.x86_64 already installed and latest version
Package libogg-devel - 2:1.1.3-3.el5.x86_64 already installed and latest version
Package libxml2-devel - 2.6.26-2.1.2.1.x86_64 already installed and latest version
Package expat-devel - 1.95.8-8.2.1.x86_64 already installed and latest version
Package libusb-devel - 0.1.12-5.1.x86_64 already installed and latest version
Package libvorbis-devel - 1:1.1.2-3.el5_1.2.x86_64 already installed and latest version
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package dbus-devel.x86_64 0:1.0.0-7.el5 set to be updated
---> Package pcsc-lite-devel.x86_64 0:1.4.4-0.1.el5 set to be updated
---> Package krb5-devel.x86_64 0:1.6.1-25.el5 set to be updated
---> Package glibc-devel.x86_64 0:2.5-24 set to be updated
---> Package rpm-devel.x86_64 0:4.4.2-48.el5 set to be updated
---> Package libacl-devel.x86_64 0:2.2.39-3.el5 set to be updated
---> Package coolkey-devel.x86_64 0:1.1.0-6.el5 set to be updated
---> Package openldap-devel.x86_64 0:2.3.27-8.el5_2.4 set to be updated
---> Package libselinux-devel.x86_64 0:1.33.4-5.el5 set to be updated
---> Package python-devel.x86_64 0:2.4.3-21.el5 set to be updated
---> Package xulrunner-devel.x86_64 0:1.9.0.1-1.el5_2 set to be updated
---> Package openssl-devel.x86_64 0:0.9.8b-10.el5 set to be updated
---> Package kudzu-devel.x86_64 0:1.2.57.1.17-1 set to be updated
---> Package libuser-devel.x86_64 0:0.54.7-2.el5.5 set to be updated
---> Package pam-devel.x86_64 0:0.99.6.2-3.27.el5 set to be updated
---> Package newt-devel.x86_64 0:0.52.2-10.el5 set to be updated
---> Package pciutils-devel.x86_64 0:2.2.3-5 set to be updated
--> Running transaction check
--> Processing Dependency: dbus = 1.0.0-7.el5 for package: dbus-devel
--> Processing Dependency: pam = 0.99.6.2-3.27.el5 for package: pam-devel
--> Processing Dependency: python = 2.4.3-21.el5 for package: python-devel
--> Processing Dependency: krb5-libs = 1.6.1-25.el5 for package: krb5-devel
--> Processing Dependency: xulrunner = 1.9.0.1-1.el5_2 for package: xulrunner-devel
--> Processing Dependency: nss-devel >= 3.11.99.5 for package: xulrunner-devel
--> Processing Dependency: openldap = 2.3.27-8.el5_2.4 for package: openldap-devel
--> Processing Dependency: rpm = 4.4.2-48.el5 for package: rpm-devel
--> Processing Dependency: pcsc-lite-libs = 1.4.4-0.1.el5 for package: pcsc-lite-devel
--> Processing Dependency: openssl = 0.9.8b-10.el5 for package: openssl-devel
--> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-devel
--> Processing Dependency: libuser = 0.54.7-2.el5.5 for package: libuser-devel
--> Processing Conflict: python-devel conflicts python < 2.4.3-21.el5
--> Processing Dependency: libxul.so()(64bit) for package: xulrunner-devel
--> Processing Dependency: glibc = 2.5-24 for package: glibc-devel
--> Processing Dependency: nspr-devel >= 4.7.0.99.2 for package: xulrunner-devel
--> Processing Dependency: glibc-headers = 2.5-24 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package python.x86_64 0:2.4.3-21.el5 set to be updated
---> Package openldap.x86_64 0:2.3.27-8.el5_2.4 set to be updated
---> Package nss-devel.x86_64 0:3.12.0.3-1.el5.centos set to be updated
---> Package openssl.x86_64 0:0.9.8b-10.el5 set to be updated
---> Package nspr-devel.x86_64 0:4.7.1-1.el5 set to be updated
---> Package glibc-headers.x86_64 0:2.5-24 set to be updated
---> Package rpm.x86_64 0:4.4.2-48.el5 set to be updated
---> Package glibc.x86_64 0:2.5-24 set to be updated
---> Package krb5-libs.x86_64 0:1.6.1-25.el5 set to be updated
---> Package pam.x86_64 0:0.99.6.2-3.27.el5 set to be updated
---> Package pcsc-lite-libs.x86_64 0:1.4.4-0.1.el5 set to be updated
---> Package dbus.x86_64 0:1.0.0-7.el5 set to be updated
---> Package libuser.x86_64 0:0.54.7-2.el5.5 set to be updated
---> Package xulrunner.x86_64 0:1.9.0.1-1.el5_2 set to be updated
---> Package libselinux.x86_64 0:1.33.4-5.el5 set to be updated
--> Running transaction check
--> Processing Dependency: openldap = 2.3.27-8.el5_1.3 for package: openldap-clients
--> Processing Dependency: libnss3.so(NSS_3.12)(64bit) for package: xulrunner
--> Processing Dependency: glibc-common = 2.5-24 for package: glibc
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-libs
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-devel
--> Processing Dependency: nss >= 3.11.99.5 for package: xulrunner
--> Processing Dependency: python = 2.4.3-19.el5 for package: python-devel
--> Processing Dependency: nspr >= 4.7.0.99.2 for package: xulrunner
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-python
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.12)(64bit) for package: xulrunner
--> Processing Dependency: nss = 3.12.0.3-1.el5.centos for package: nss-devel
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-build
--> Processing Dependency: libnssutil3.so()(64bit) for package: xulrunner
--> Processing Dependency: glibc-headers = 2.5-18.el5_1.1 for package: glibc-devel
--> Processing Dependency: openldap = 2.3.27-8.el5_1.3 for package: openldap-servers
--> Processing Dependency: openldap = 2.3.27-8.el5_1.3 for package: compat-openldap
--> Processing Dependency: krb5-libs = 1.6.1-17.el5_1.1 for package: krb5-workstation
--> Processing Dependency: nspr = 4.7.1-1.el5 for package: nspr-devel
--> Processing Dependency: krb5-libs = 1.6.1-17.el5_1.1 for package: krb5-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package krb5-workstation.x86_64 0:1.6.1-25.el5 set to be updated
---> Package rpm-python.x86_64 0:4.4.2-48.el5 set to be updated
---> Package rpm-libs.x86_64 0:4.4.2-48.el5 set to be updated
---> Package nss.x86_64 0:3.12.0.3-1.el5.centos set to be updated
---> Package nspr.x86_64 0:4.7.1-1.el5 set to be updated
---> Package glibc-common.x86_64 0:2.5-24 set to be updated
---> Package openldap-servers.x86_64 0:2.3.27-8.el5_2.4 set to be updated
---> Package openldap-clients.x86_64 0:2.3.27-8.el5_2.4 set to be updated
---> Package rpm-build.x86_64 0:4.4.2-48.el5 set to be updated
---> Package compat-openldap.x86_64 0:2.3.27_2.2.29-8.el5_2.4 set to be updated
--> Running transaction check
--> Processing Dependency: krb5-libs = 1.6.1-17.el5_1.1 for package: krb5-devel
--> Processing Dependency: python = 2.4.3-19.el5 for package: python-devel
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-libs
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-devel
--> Processing Dependency: glibc-headers = 2.5-18.el5_1.1 for package: glibc-devel
--> Processing Dependency: openldap = 2.3.27-8.el5_1.3 for package: compat-openldap
--> Processing Dependency: glibc-common = 2.5-18.el5_1.1 for package: glibc
Error: No Package Matching glibc.i686


All times are GMT -5. The time now is 08:02 PM.