LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 10-20-2006, 07:51 AM   #1
edd8990
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Rep: Reputation: 0
Yum update broke X server :(


Hi.

LAst night I used yum to run a full update (Excluding geronimo specs which is still failing due to dependencies)

But anyway, when I turned it on this morning, it started to boot fine. It gets to the point "starting udev [OK]" then at the point where the gui normally comes up, the screen just goes black. I have tried booting both the new kernel installed in last nights update, and the old one, and the same happens in both. I used my FC5 rescue disk to get to a terminal, but had no idea what to do to fix it. I tried running startx (as root) and the screen just goes black again.

Anyone have any ideas?

Thanks

-Edd
 
Old 10-20-2006, 05:11 PM   #2
Simon_6162
Member
 
Registered: Jul 2004
Location: UK
Distribution: Fedora, Gentoo, Redhat Enterprise
Posts: 141

Rep: Reputation: 16
Hello,

I just had the same issue and mine has something to do with the ati drivers and the latest kernel which I got from livna rpm's

The combination that failed was
kernel-2.6.18-1.2200.fc5
kmod-fglrx-8.29.6-1.2.6.18_1.2200.fc5.i686.rpm
xorg-x11-drv-fglrx-8.29.6-1.lvn5.i386.rpm

If this isn't what your running then don't bother with the rest of this post but I spent and hour on this problem so thought I would post about it!

I need to use TV out so I decided to roll back the drivers to the last stable version. You can also just disable them. Below tells you how to do both.

1) Boot into init 3 (none gui mode)
when you get to grub highlight the previous kernel version (2.6.17-1.2187_FC5) and press e, the on the next screen select the second line down and press e the add " 3" without the quotes to the end of that line and press return then b.

2) Wait for the system to load. Then log in as root

3) If you don't really need the ati drivers you can just disable them using the command below. If you do need then jump to 4.
Code:
ati-fglrx-config-display disable
change disable to enable later on when they get fixed !
then reboot, all done

4) To rollback the drivers you need to uninstall the ati drivers and you might as well remove the other kernel as well
Code:
rpm -e xorg-x11-drv-fglrx kmod-fglrx
rpm -e kernel-2.6.18-1.2200.fc5
#if you have the kernel devel package then run the command below
rpm -e kernel-devel-2.6.18-1.2200.fc5
5) Download the old ati drivers for your previously working kernel again
(This assumes you also have the kernel-2.6.17-1.2187_FC5 installed )
Code:
wget http://rpm.livna.org/fedora/5/i386/kmod-fglrx-8.28.8-1.2.6.17_1.2187_FC5.i686.rpm
wget http://rpm.livna.org/fedora/5/i386/xorg-x11-drv-fglrx-8.28.8-1.lvn5.i386.rpm
6) Install the packages you just got
Code:
rpm -Uhv *fglrx*rpm
7.) Disable yum from updating the kernel and the ati drivers
edit /etc/yum.conf and add the line below to the main section.

Code:
exclude=kernel* kmod-fglrx* xorg-x11-drv-fglrx*
8) All done reboot


I hope this helps you

Simon

Last edited by Simon_6162; 10-20-2006 at 05:13 PM.
 
Old 10-22-2006, 04:40 AM   #3
edd8990
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Yes! Thanks alot, it's working now!

One question: Isn't it unsafe to tell yum not to update the kernel?
 
Old 10-22-2006, 08:33 AM   #4
Simon_6162
Member
 
Registered: Jul 2004
Location: UK
Distribution: Fedora, Gentoo, Redhat Enterprise
Posts: 141

Rep: Reputation: 16
It depends on what the kernel update did, I know is was .17 to .18 and it added more drivers including my wifi card, which makes it annoying it doesn't work. I can't find much about security flaws on the web but I haven't looked that hard. So long as you have a properly configured firewall I can't imagine you'll come across any problems.

Any one else got some thoughts on this ??

Keep an eye on livna http://rpm.livna.org/fedora/5/i386/ for a new version of the xorg-x11-drv-fglrx and then try updating again when one is available (update the kernel as well). If it doesn't work repeat the above but for the new driver and kernel versions ! you can list them using
Code:
rpm -qa | grep PACKAGE
What graphics card are you using ? I'm using a 9200se but I also have a 9550 amd that works fine.

Simon
 
Old 10-22-2006, 09:15 AM   #5
edd8990
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Ahh thanks. I'll keep an eye on it then.

I'm using a raedon mobility 9000
 
Old 10-25-2006, 09:28 PM   #6
IndianaTux
LQ Newbie
 
Registered: Jan 2006
Location: Jasper, Indiana, USA
Distribution: Linux Mint 16 'Petra' Cinnamon
Posts: 26

Rep: Reputation: 15
I ran into a similar issue. Thought I'd share my experience.

I was having what seems to be a very popular issue. I installed FC5 last week, and after rebooting, the login would not come up (black screen, no response, monitor went to sleep from "No Signal").

(I'm running on a Sapphire Radeon 9250 SE 256MB PCI card.)

Following advise from another thread, I reinstalled with VESA as default driver (typed "linux vesa" at installer prompt). Install completed normally, I rebooted and here I am. The other threads also mentioned installing the Livna driver. Following the instructions at stanton-finley.net, I did so. When I rebooted into the new kernel, I got as far as a black background with a white-outlined X in the middle of the screen. The Xserver never completely started. So, I rebooted into the older kernel and here I am, running with the VESA drivers and waiting for an updated driver from Livna. I suppose I could uninstall the drivers and old kernel, but it's simpler in my opinion just to select the older kernel from the boot menu for the time being.

INTux
 
Old 10-25-2006, 09:42 PM   #7
The_Bear
LQ Newbie
 
Registered: Oct 2006
Location: Boston, MA
Distribution: Fedora
Posts: 7

Rep: Reputation: 0
Lol, I had just started a thread here with this same exact problem. The only difference is I'm using an nVidia 7300LE. You suggested in your post:

Quote:
Originally Posted by Simon6162
1) Boot into init 3 (none gui mode)
when you get to grub highlight the previous kernel version (2.6.17-1.2187_FC5) and press e, the on the next screen select the second line down and press e the add " 3" without the quotes to the end of that line and press return then b.
I hate to say this, but I am completely new to Linux and am not at all familiar with these, simple looking, but new commands. I have installed Linux to be able to participate and learn more, but am just having trouble getting started. If it wouldn't be too much trouble for you, could you please explain a couple of your steps so they are a little more "newbie" inclined? I would greatly appreciate it.

P.S. Once it kicks me out of the X, it turns me loose on a prompt. It is from here that I would need help directing to fix this issue, since I don't even know what commands I can do or anything else.

Last edited by The_Bear; 10-25-2006 at 09:43 PM.
 
Old 10-26-2006, 07:49 PM   #8
The_Bear
LQ Newbie
 
Registered: Oct 2006
Location: Boston, MA
Distribution: Fedora
Posts: 7

Rep: Reputation: 0
Firstly, I apologize for the double post. I think I can follow all the other directions, but how do you boot into init 3, non gui mode? I hope to get this fixed to start playin on it again. I appreciate your time.

Joe

P.S. I didn't even think about the edit button, but one last thing is I do have a dual boot system Xp and Linux, and I can't do anything before grub pops up, or at least I don't think I can.

Last edited by The_Bear; 10-26-2006 at 07:52 PM.
 
Old 10-27-2006, 03:43 AM   #9
edd8990
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by The_Bear
Firstly, I apologize for the double post. I think I can follow all the other directions, but how do you boot into init 3, non gui mode? I hope to get this fixed to start playin on it again. I appreciate your time.

Joe

P.S. I didn't even think about the edit button, but one last thing is I do have a dual boot system Xp and Linux, and I can't do anything before grub pops up, or at least I don't think I can.
I can answer this one now!

When you get to the screen where you choose between linux and windows, highlight linux, but instead of pressing enter, press "e". Then there should be three lines of text, go to the second line, and press "e" again. At the end of the line, add the number "3" (Without quotes), and press return. Then press "b".
 
Old 10-27-2006, 11:42 AM   #10
Simon_6162
Member
 
Registered: Jul 2004
Location: UK
Distribution: Fedora, Gentoo, Redhat Enterprise
Posts: 141

Rep: Reputation: 16
Quote:
Originally Posted by The_Bear
Lol, I had just started a thread here with this same exact problem. The only difference is I'm using an nVidia 7300LE. You suggested in your post:



I hate to say this, but I am completely new to Linux and am not at all familiar with these, simple looking, but new commands. I have installed Linux to be able to participate and learn more, but am just having trouble getting started. If it wouldn't be too much trouble for you, could you please explain a couple of your steps so they are a little more "newbie" inclined? I would greatly appreciate it.

P.S. Once it kicks me out of the X, it turns me loose on a prompt. It is from here that I would need help directing to fix this issue, since I don't even know what commands I can do or anything else.

Hello, My first impression of your problem is that it is an mis-configured /etc/X11/xorg.conf file. This might have been the problem for our problem as well but I tried all the options I could think of and then gave up.

I would suggest looking for en example xorg.conf file for your graphics card, I've never used nvidia so I can't really help you.

If you do want to remove the nvidia drivers and switch back to the default mesa drivers then my instructions will work so long as you switch the package and driver versions.

rpm -qa | grep nvidia
#should list the names I think!

You can also use the command below to enable and disable the nvidia drivers.

Code:
/usr/sbin/nvidia-config-display disable
If you can get to a terminal without using the init 3 process then just do that, the only reason we had to use that is we got a blank screen that we couldn't even get to the terminal on. init 3 is a different startup process that doesn't try to use Xwindows.

for information on what the commands do that I listed at the terminal after you login type

Code:
man rpm 
or 
man grep 
or 
man init
This brings up the manual for that command the up and down arrows scroll about and q exits the manual !

To edit text files at the terminal I recomend nano press ctrl and the keys listed at the bottom of the window to perform actions. eg ctrl+x exit. to open a file use the -w switch.

Code:
nano -w /etc/X11/xorg.conf
Lastly if you still have no luck try making a new post of no x display and post the contents of /etc/x11/xorg.conf I'm sure someone will help.

Good Luck

Simon
 
Old 10-29-2006, 02:16 PM   #11
The_Bear
LQ Newbie
 
Registered: Oct 2006
Location: Boston, MA
Distribution: Fedora
Posts: 7

Rep: Reputation: 0
An update.

I really feel like a moron writing this, but I guess my issue wasn't related to yours. Once it quit x and kicked me out to the shell prompt in (dos)? mode, it said there was an error in my file system. I read your posts and thought it to be the same as my problem. It said to run Fsck or something similar, which when I did, it fixed everything for me. Now it boots up fine and everything else. I appreciate the time you took to help me figure out the problem though. I'm not sure what happened or how it happened, but it seems it fixed itself, and all is well.

Thank you,
Joe
 
Old 10-29-2006, 08:15 PM   #12
Simon_6162
Member
 
Registered: Jul 2004
Location: UK
Distribution: Fedora, Gentoo, Redhat Enterprise
Posts: 141

Rep: Reputation: 16
No problem, we've all done the same at some point.

Simon
 
Old 11-01-2006, 08:03 PM   #13
henry_shadowjet
Member
 
Registered: Oct 2006
Posts: 55

Rep: Reputation: 15
Hi, I am new to this forum. I have just recently installed Fedora Core 6 on my desktop and now I would to enable 3D support for my ATi Radeon 9200SE, if that is possible at all. Please kindly remind me if I am breaching any posting rules here.

I am running a Fedora Core 6 system and have tried your proposed solution for Fedora Core 5. It doesn't seem to work though. Using the FC5 RPMs does not solve my problem, X server just throws an error and re-create the xorg.conf file all over again after giving a few error feedback on a bluescreen during startup. OK, that's probably not smart, I know, but I was desperate

Unfortunately, rpm.livna.org does not have any previous driver for ATi fglrx, only has the latest one, which if installed, and enabled using the ati-fglrx-config-display enable would completely stuff up my monitor similar to the initial post described above. My monitor would go blank and display "out of range". My monitor is Acer FP581 which supports up to 1024x768x32.

I would like to know if there are any workaround for this issue on a Fedora Core 6 system. Any help would be appreciated.

Thank you very much for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X server not working after yum update & font server problems snow93 Linux - Software 1 08-02-2006 06:26 AM
i think i broke yum... nshorts Fedora 1 05-24-2006 11:29 AM
X Server Crashed after Yum Update a1opus Fedora 8 03-23-2006 10:00 PM
OMG Yum just broke Infernal211283 Linux - Newbie 5 01-14-2006 08:42 AM
Upgrading from FC2 to FC3 broke yum! ericcarlson Fedora 4 12-29-2004 01:47 PM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration