LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   yum [Errno 4] IOError (http://www.linuxquestions.org/questions/fedora-35/yum-%5Berrno-4%5D-ioerror-837783/)

sulekha 10-13-2010 07:41 AM

yum [Errno 4] IOError
 
Hi all,

whenever i give the command

yum install gcc
I am getting the following error message

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...64&repo=addons error was
[Errno 4] IOError: <urlopen error <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
>
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...x86_64&repo=os error was
[Errno 4] IOError: <urlopen error <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
>
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...epo=centosplus error was
[Errno 4] IOError: <urlopen error <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">


output of the the command yum repolist enabled
is as follows:-

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...64&repo=addons error was
[Errno 4] IOError: <urlopen error <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
>
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...x86_64&repo=os error was
[Errno 4] IOError: <urlopen error <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
>
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...epo=centosplus error was
[Errno 4] IOError: <urlopen error <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">


I am using centos 5.5 64 bit version

How to fix this error ?

John VV 10-14-2010 03:12 PM

the error ? at this time i do not know
BUT "yum install gcc" is the WRONG command

Code:

yum grouplist
-- then from that list --

yum groupinstall " Development Tools" Development Librarys "

-- and the optional " Gnome Development "


but as to the error ?
what did you do last ? Before this started , what did you install ?

sulekha 10-16-2010 10:13 AM

thanks for that information, BTW , my IO error disappeared when I changed my address of my proxy server.

John VV 10-16-2010 03:23 PM

Quote:

thanks for that information, BTW , my IO error disappeared when I changed my address of my proxy server.
the fact you were using a proxy in the FIRST place would have been very nice to know about in the first post


All times are GMT -5. The time now is 12:23 PM.