LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   xorg.conf looks right (to me), but still no 2nd monitor? (http://www.linuxquestions.org/questions/fedora-35/xorg-conf-looks-right-to-me-but-still-no-2nd-monitor-245718/)

browman 10-21-2004 06:56 PM

xorg.conf looks right (to me), but still no 2nd monitor?
 
Could someone enlighten me as to why my second monitor won't fire up. It did so once, after the first adjustment of system-config-display, but since then it simply doesn't show up when in X. It does however work during the loading screen?

Here's my xorg.conf:


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "on"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules/extensions/nvidia"
ModulePath "/usr/X11R6/lib/modules/extensions"
ModulePath "/usr/X11R6/lib/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "HM903D/DT"
DisplaySize 360 290
HorizSync 30.0 - 130.0
VertRefresh 50.0 - 200.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Nokia 447E"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 110.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 3 (generic)"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "radeon"
VendorName "Videocard Vendor"
BoardName "ATI Radeon 7000"
BusID "PCI:0:12:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

-----------------
Thanks in advance

bushidozen 10-23-2004 04:22 AM

It seems like you might need to add the "TwinView" option under the "Device" section. I have an NVIDIA GeForce 5700 LE with 2 17" monitors and my "Device" section is as follows:

Section "Device"
Identifier "Videocard0"
# Driver "vesa"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "VESA driver (generic)"
Option "TwinView"
Option "SecondMonitorHorizSync" "30.0 - 83.0"
Option "SecondMonitorVertRefresh" "56.0 - 75.0"
Option "MetaModes" "1280x1024, 1280x1024"
Option "TwinViewOrientation" "LeftOf"
Option "ConnectedMonitor" "DFP, DFP"

Obviously, you will probably have to tweak these settings to your monitors, but it works perfect for me.

By the way the "TwinView" option stretches the X Window System across both screens, so they act as on large monitor.

browman 10-23-2004 05:27 AM

Cheers for the advice... I decided to RTFM in the end...:study:

Still no joy. I think it may be because I'm using the Nvidia drivers. My setup is an old GeForce3 Ti 500 and a cheap PCI Radeon (for the second screen).

I don't think that twinview is available to me on my main card.

Unfortunately when I set Xinerama to "On", I get an error message saying that OpenGL features are not available with Xinerama, which appears to come from the Nvidia driver, and then the second screen doesn't display.

Grr

:mad:


All times are GMT -5. The time now is 10:40 AM.