LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 09-09-2007, 03:50 AM   #1
kojot
LQ Newbie
 
Registered: Jul 2007
Location: Latvia
Distribution: Fedora
Posts: 13

Rep: Reputation: 0
xkb


Hello.
I use Fedora 7, desktop environment - KDE.
Keyboard Layout:
There are not country flags in available layouts list, only language cods.
How can I add country flags in available layouts list?

Last edited by kojot; 09-09-2007 at 03:52 AM.
 
Old 09-09-2007, 05:32 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
They should be in the KDE "Keyboard Layouts" configuration. If you are referring to the indicator/switch on the task bar, under the switching options tab, click on the "Show Country Flag" button.
 
Old 09-10-2007, 12:21 AM   #3
kojot
LQ Newbie
 
Registered: Jul 2007
Location: Latvia
Distribution: Fedora
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
They should be in the KDE "Keyboard Layouts" configuration. If you are referring to the indicator/switch on the task bar, under the switching options tab, click on the "Show Country Flag" button.
In my first post, I forgot to say "Show Country Flag" button is ON.
KDE "Keyboard Layouts" configuration -> "Layout" tab:
There are not country flags in available layouts list, only language cods.
 
Old 09-10-2007, 12:00 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
If you are referring to the Keyboard Layout List, then I don't know why you aren't seeing flags. I ran kcontrol and selected the page and looked with lsof but didn't see any resources being used that would supply them.

You could run "rpm -qV$(rpm -qf $(which kcontrol))" to locate the package supplying kcontrol and verify it.
Also try running "kcontrol" in the shell and see if there are messages about not finding some resource. The flags should be in /usr/share/locale/l10n/.

Last edited by jschiwal; 09-10-2007 at 12:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xkb maintainer Cyborg16 Linux - Software 1 02-19-2006 06:31 AM
What does XKB mean in this words? hkl8324 Debian 1 10-03-2005 02:54 AM
XKB configuration rainexpected Linux - Laptop and Netbook 0 08-29-2005 09:34 PM
In need of xkb / kxkb help! saitoshi Linux - General 0 10-21-2004 03:50 AM
xkb glass Linux - General 5 12-14-2002 01:19 AM


All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration