LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-26-2005, 10:19 AM   #1
paulBottomley
LQ Newbie
 
Registered: Oct 2005
Location: Canterbury, UK
Distribution: Fedora Core 4
Posts: 12

Rep: Reputation: 0
X changed resolution while trying to install an nVidia driver


Hello,

My problem began when I tried to install an nVidia driver for Fedora Core 4.

"Log out of X", said the instructions, so I tried to use /sbin/telinit 3 from a terminal window, which seemed to freeze after "starting anacron... [OK]". No prompt or anything.

I tried again, and eventually got to a prompt with "init 1". Running the driver installer from there brought up a message that implied that it was not a good idea to run it at runlevel 1, so I cancelled it.

Then I typed "startx" to start everything up again, which worked, only now its in 800x600 mode instead of 1280x1024, and the option to get it back to that has disappeared.

Also a window came up when I logged back in saying something about a difference between Gnome and X defaults (?), but I'm afraid I can't remember exactly what it said. It does not come up any more.

If someone could tell me why runing telinit 3 from a terminal window crashed, how to get my resolution back, and why on earth it changed in the first place (so I don't do it again, mug that I am ), I would be very grateful.

OK I managed to get to runlevel three and install the driver. I updated the xorg.conf file like the readme said, but its still only 800x600. I'm all confused.

Thank you


Last edited by paulBottomley; 10-26-2005 at 05:23 PM.
 
Old 10-26-2005, 05:36 PM   #2
paulBottomley
LQ Newbie
 
Registered: Oct 2005
Location: Canterbury, UK
Distribution: Fedora Core 4
Posts: 12

Original Poster
Rep: Reputation: 0
Smile fixed

I think restarting the computer, as opposed to restarting X did it, but it might have been that I changed xorg.conf again to have 1280x1024 in it.

Either way, It is happy and now everything looks very small in contrast to what it was before :P

I'm still curious why running in runlevel 1, not installing the driver, and then restating X made it do what it did though.


Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get Resolution higher than 1024x768 with NVIDIA driver AntWarrior Ubuntu 3 03-17-2007 09:30 PM
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 07:34 AM
NVidia driver problem with screen resolution dabump Mandriva 3 12-20-2004 08:32 AM
changed driver to nvidia, can't login to X, need to change driver back to vesa how??? Fear58 Linux - Software 7 12-08-2004 12:08 AM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 06:14 AM


All times are GMT -5. The time now is 03:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration