LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-23-2006, 03:35 AM   #1
gimmee
Member
 
Registered: Jul 2006
Location: New Zealand
Distribution: Fedora 17 64bit (Desktop) Fedora 15 (Laptop)
Posts: 98

Rep: Reputation: 16
Wink wpa_supplicant confused on psk="secret password"


Hi all

When configuring wpa_supplicant.conf one of the entries for using wpa is

psk="yoursecretpassword"

If my router is set as wpa pre-shared key and as an example the router has:

WPA Shared Key: jackandjill

Is this what I enter into the wpa_supplicant.conf file, like,

psk="jackandjill"

or am i meant to use :wpa_passphrase Gimmee jackandjill

and use the long key that is output from this into

psk=257257377777231753275237632573257327532

Just a bit confused on this part. Can access my router with no encryption no worries but am still struggling to get wpa_supplicant to work. I think I might need to uninstall it and do a fresh compile and make sure the config file is set properly when I do make install.

Anyway thanks for any help on this query.

Cheers

Gimmee
 
Old 12-23-2006, 04:16 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
The wpa_supplicant installation adds a README file and sample configurations under the /usr/share/doc/packages/wpa_supplicant directory. Your distro may have a device configuration program where you can enter the key in the form that you want.
Code:
sample config from the wpa_supplicant man page on the web:
# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
#
# home network; allow all valid ciphers
network={
        ssid="home"
        scan_ssid=1
        key_mgmt=WPA-PSK
        psk="very secret passphrase"
}
#
So I think that you just need to enter the same passphrase in your wpa_supplicant.conf file's psk="passphrase" entry as you have in your router's config.

What I did is use a oneliner to create a 32 byte random key ( 64 hexidecimal digits ). That would be a lot harder to guess.

Code:
dd if=/dev/random bs=32 count=1 2>/dev/null | od -t x2 | sed -e '3d' -e 's/^.\{8\}//' -e 's/ //g' | tr -d '\n' ; echo
Then I use this to configure the router and all the computers.

Last edited by jschiwal; 12-23-2006 at 04:18 AM.
 
Old 12-23-2006, 05:05 AM   #3
gimmee
Member
 
Registered: Jul 2006
Location: New Zealand
Distribution: Fedora 17 64bit (Desktop) Fedora 15 (Laptop)
Posts: 98

Original Poster
Rep: Reputation: 16
Hey there jschiwal

Thanks for that. I like the one liner you gave me. That should be great and clears up things for me a little. Will give it another try. At the moment I have just left my wpa-psk enabled on the router but am using windows to log, argghh. Been trying a couple of weeks now on and off when I get a chance in this busy season to sort it but no luck as yet.

Not giving up yet.

Cheers

Gimmee
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Best Data V.92 External Modem $ Lexmark 5150 Printer in Mepis "Top Secret" tjsmyj Linux - Hardware 0 10-17-2006 08:26 PM
"Secret Cookie" raysr Suse/Novell 21 10-12-2006 03:00 AM
"wpa_supplicant and dhcpcd" known problems? the_mich Linux - Networking 0 03-13-2006 09:38 AM
wpa_supplicant "no suitable AP found." fatblueduck Linux - Wireless Networking 0 07-25-2005 07:36 PM
wpa_supplicant not picking up WPA-PSK AP derfelcadarn Linux - Wireless Networking 2 04-07-2005 11:48 AM


All times are GMT -5. The time now is 09:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration