LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 07-23-2005, 08:03 PM   #1
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Rep: Reputation: 47
wlan0 doesn't work without eth0?


I just bought a desktop wireless card for my 2nd pc that needed the ndiswrapper to work. I put my eth0 nic in my second pc with the wireless nic so that I could get needed files off the internet with eth0. Now my wireless card is setup correctly as wlan0 (I shutdown eth0 and used wlan0 to surf the net) and I thought I no longer needed eth0, so I went to network configuration as root and deleted eth0 and the wlan0 DNS info that related it to eth0. Then I shut down the pc and removed the ethernet card and left in the wireless.

When I did a reboot my wireless card could not find my wireless network or any others...scan showed nothing. What's going on?

Last edited by linuxhippy; 07-23-2005 at 08:10 PM.
 
Old 07-23-2005, 10:14 PM   #2
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 210

Rep: Reputation: 31
What's your network topology?

do you have both computers connected to a common wireless router?
Or one of the two computers has two NICs, one to the internet and another wireless to the internal network?

Quote:
so I went to network configuration as root and deleted eth0 and the wlan0 DNS info that related it to eth0.
I am a little bit confused. There is no wlan0 DNS info that relates to eth0. I am affraid that you deleted some wlan0 configurations.

Reconfigure wlan0 with all the parameters as appropriate for your network (ESSID, Key, mode, etc).
 
Old 07-23-2005, 10:58 PM   #3
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
I put the eth0 card and the wlan0 card in the same pc to get the wlan0 card software (ndiswrapper) working. Then when I thought the wireless connection was good, I removed any software entries relating to it (eth0) and my router's DNS (Westell). Then I removed the hardware or the ethernet card.

I rebooted and iwlist scan couldn't find any networks...not even my neighbor's.

I don't want to configure the wireless card to my network and would rather have it default to any essid since this 2nd pc is for a friend of mine who lives a couple miles away. His wireless network is not encrypted.
 
Old 07-24-2005, 07:56 AM   #4
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
I did a make uninstall of ndiswrapper and deleted any ndiswrapper files/directories on my pc. Then I shut down my pc and put my eth0 card back in. Rebooted and now my eth0 is set up ok. I just built the ndiswrapper1.2 module and installed it. I've been getting this error on make, though the ndiswrapper module loads up with no errors:

*** WARNING: Kernel is compiled with 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTACKS option, recompile and install kernel


Could this prevent wlan0 from working properly?

How do I enable 4kstacks in my Fedora Kernel rpm?
 
Old 07-24-2005, 01:03 PM   #5
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 210

Rep: Reputation: 31
For your first question:
You mentioned that you were able to connect using the wireless card. isn't it?
If you have connected successfully then I don't think it's likelly that the 4K stacks are the problem.

For the second question
If you really think that the 4K stacks are the problem you can try installing This patch from linuxant.

I have not tried it.

Oh, I forgot to ask. What Fedora Core are you using? the links I sent are for FC3, if you need them for a different FC, then just change the address line appropriatelly.
 
Old 07-24-2005, 01:04 PM   #6
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 210

Rep: Reputation: 31
What do you get when you type the following commands in a console?
Code:
/sbin/iwconfig
/sbin/ifconfig
 
Old 07-24-2005, 03:32 PM   #7
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
I'm using FC4. Right now I am able to get online and iwconfig & ifconfig look right-they give me the ESSID and IP address after I assign a essid and run dhclient. Right now I also have my eth0 card in (no modem connected). When I took the eth0 card out of my pc last night, then I wasn't even able to do a iwlist scan wlan0 to see what networks were present. I'm about to take the eth0 card out without removing the device from network configuration.

What's a good GUI application for wireless? I have kwifimanager but it will only report what networks are present (it scans what's available but doesn't let you choose the network) and give you signal strength. I'd like a GUI program that will allow you to scan networks, select a network, and set up the network so that you have an IP address.

EDIT: Pulled the eth0 card and kept it inactive in network sys config and now I can get online. I just have to modprobe ndiswrapper (activating it on startup gives an error), assign an ESSID, and dhclient wlan0. Being this pc is for a Win user, he'll need a nice little point and click app besides kwifimanager that'll do all this. Suggestions?

Last edited by linuxhippy; 07-24-2005 at 04:42 PM.
 
Old 07-26-2005, 01:21 PM   #8
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 210

Rep: Reputation: 31
From your other threads I get that you have this card working isn't it?

Now you just need a way to find available networks and choose which one you want to use?
 
Old 07-26-2005, 08:43 PM   #9
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,189

Original Poster
Rep: Reputation: 47
That's right-it works now...but only if you go about it with keys as root. Autostarting the wlan0 device on boot gives an error about checking a cable. Can I put together a little script that automatically logs a user onto any available ESSID and gets a IP address? Ndiswrapper does automatically load up (it's in modprobe.conf) and wlan0 is assigned a MAC address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remapping wlan0 to eth0 Berhanie Linux - Networking 1 02-17-2005 08:59 AM
Basic eth0 vs. wlan0 question johnemil Linux - Wireless Networking 9 09-13-2004 03:06 PM
Eth0 to WLAN0 how do i rename it? XeoNoX Linux - Wireless Networking 5 02-22-2004 06:54 AM
Starting wlan0 instead of eth0 eo697 Linux - Networking 2 10-12-2003 06:02 PM
route wlan0 to eth0 hwood7587 Linux - Networking 1 07-13-2003 07:47 PM


All times are GMT -5. The time now is 11:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration