LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-08-2006, 10:47 AM   #1
maul
LQ Newbie
 
Registered: Oct 2004
Location: New York
Distribution: Slackware 10
Posts: 18

Rep: Reputation: 0
Wireless setup problems on IBM Thinkpad T41


I have Fedora core 4 installed on my Thinkpad T41. The kernel is 2.6.15
I have been trying to get my wireless card to work but have been unsucessfull. I Have downloaded and installed the ipw2100 Driver, firmware and kernel module and also the ieee80211 kernel module using yum. I still get the following error when I try to activate eth1

"e1000 device eth1 does not seem to be present, delaying initialization."

What I dont understand is why it is trying to use the e1000 driver...it is supposed to use the ipw2100 driver

when I do an lsmod I dont see the ipw2100 listed.
modprobe ipw2100 gives the following error.

modprobe ipw2100
WARNING: Error inserting ieee80211_crypt (/lib/modules/2.6.15-1.1833_FC4/updates/net/ieee80211/ieee80211_crypt.ko): Invalid module format
WARNING: Error inserting ieee80211 (/lib/modules/2.6.15-1.1833_FC4/updates/net/ieee80211/ieee80211.ko): Invalid module format
FATAL: Error inserting ipw2100 (/lib/modules/2.6.15-1.1833_FC4/updates/drivers/net/wireless/ipw2100/ipw2100.ko): Invalid module format

anyone know whats going on? Let me know if you guys need anymore information.

Thanks
 
Old 03-08-2006, 01:03 PM   #2
maul
LQ Newbie
 
Registered: Oct 2004
Location: New York
Distribution: Slackware 10
Posts: 18

Original Poster
Rep: Reputation: 0
I managed to fix it.
I removed all the ipw2100 related packages using yum and then installed just the ipw2100 firmware. That did the job.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless on ibm thinkpad r50p laurentwahl Linux - Laptop and Netbook 2 05-16-2005 09:11 PM
IBM ThinkPad T41 Standby Problem w/ Centrino deathkrush Linux - Laptop and Netbook 9 12-09-2004 11:56 PM
FC3 IBM t41 & Wireless Raggit Linux - Laptop and Netbook 3 11-28-2004 09:29 AM
DISCUSSION: Installing SuSE 9.0 to dual boot on an IBM ThinkPad T41 with XP dkpw LinuxAnswers Discussion 0 08-23-2004 07:43 PM
bluetooth and usb port on ibm T41 thinkpad oliverbong Linux - Laptop and Netbook 1 07-26-2004 03:47 AM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration