LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Wireless Nick doesn't receive IP from DHCP (http://www.linuxquestions.org/questions/fedora-35/wireless-nick-doesnt-receive-ip-from-dhcp-627809/)

3azz 03-13-2008 01:58 PM

Wireless Nick doesn't receive IP from DHCP
 
Hi all,

I can't figure out what's happening here!

My wireless network is broadcasting SSID and is configured using WPA-PSK.

My laptop is configured with an Intel 3945ABG wireless NIC. As far as I can figure out, using all the manuals and trouble shooting guides, everything is configured correctly.

ifcfg-wlan0 looks like:
# Intel Corporation PRO/Wireless 3945ABG Network Connection
DEVICE=wlan0
ONBOOT=no
BOOTPROTO=dhcp
HWADDR=00:19:d2:5c:18:78
NETMASK=
DHCP_HOSTNAME=Pluto
IPADDR=
DOMAIN=
TYPE=Wireless
ESSID=BlackHat
CHANNEL=11
MODE=Managed
RATE=Auto
USERCTL=no
PEERDNS=yes
IPV6INIT=no
NM_CONTROLLED=no

When I type /sbin/iwlist wlan0 scan it returns:
wlan0 Scan completed :
Cell 01 - Address: 00 : 14 : 7C : B0 : D9 : F1
ESSID:"BlackHat"
Mode:Master
Frequency:2.462 GHz (Channel 11)
Channel:11
Quality=87/100 Signal level=-46 dBm Noise l
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s;
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s;
48 Mb/s; 54 Mb/s
Extra:tsf=000000fea68024dc

So it looks like my wifi-card is running and it can see the accesspoint.

But when I do: /sbin/dhclient wlan0, it returns:
Internet Systems Consortium DHCP Client V3.0.6-Fedora
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit isc.org
wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:19:d2:5c:18:78
Sending on LPF/wlan0/00:19:d2:5c:18:78
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

When I look in dmesg, it returns:
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: CTS protection enabled (BSSID=00:14:7c:b0:d9:f1)
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:7c:b0:d9:f1
wlan0: RX authentication from 00:14:7c:b0:d9:f1 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:14:7c:b0:d9:f1
wlan0: RX AssocResp from 00:14:7c:b0:d9:f1 (capab=0x431 status=0 aid=20)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present

So, it looks like it is authenticated, which means, that the encryption is not the issue, right? It also replies, that there are no IPv6 routers present. Strange, since I did not configure IPv6 in the config file.
But nevertheless, in this case, the access point is purely a (3Com) access point with a Cisco ASA5505 firewall behind it, which actually does support IPv6...

My laptop is a dual boot with Windows Vista and Vista mainly uses IPv4 on wireless.

Any idea what the problem here might be? I am already busy for two weeks now, trying to get Fedora 8 running with wireless.

Thanks for your help in advance! :)

1jnike 03-13-2008 02:49 PM

Hi 3azz,

You seem to have the wireless device disabled at bootup, see below;

ifcfg-wlan0 looks like:
# Intel Corporation PRO/Wireless 3945ABG Network Connection
DEVICE=wlan0
ONBOOT=no
BOOTPROTO=dhcp
HWADDR=00:19:d2:5c:18:78
NETMASK=
DHCP_HOSTNAME=Pluto
IPADDR=
DOMAIN=
TYPE=Wireless
ESSID=BlackHat
CHANNEL=11
MODE=Managed
RATE=Auto
USERCTL=no
PEERDNS=yes
IPV6INIT=no
NM_CONTROLLED=no

Have you tried the network management, under System - Adminstration - Network, ensure your wireless device in active!

I hope this is of help

Jnike

hardlessons 09-27-2008 08:45 PM

I got mine working...
 
....somehow! At last! I came through a series of stages and difficulties in getting my wifi work on my toshiba satellite with an intel 4965 AGN and here I am now, finally untethered and mobile.
When I was in the same state as yours, the only thing that worked for me was I unplugged the ethernet cable and rebooted and bingo the wireless connected finally.
Until then it kept asking for the secret key again and again. Here are some of my configs/command outputs (I didnt basically change anything manually):

[mahesh@localhost ~]$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"SKY09521"
Mode:Managed Frequency:2.412 GHz Access Point: 00:1B:BF:C1:25:32
Bit Rate=54 Mb/s Tx-Power=14 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=100/100 Signal level:-33 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

virbr0 no wireless extensions.


[mahesh@localhost ~]$ uname -a
Linux localhost 2.6.27-0.352.rc7.git1.fc10.i686 #1 SMP Tue Sep 23 21:26:04 EDT 2008 i686 i686 i386 GNU/Linux


[mahesh@localhost ~]$ lspci | grep 4965
04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)


These are the steps which i had to climb:

1. Initially when I installed Fedora, my Wifi was detected, showed up in Network Manager, iwconfig etc., but as inactive. So i beleive there was no driver problems and no need to do the madwifi, ndiswrapper, mac80211 steps that I found in some forums. The error I was getting (See Applications->System tools->System Log) was some SELinux related error. Something like "SELinux is preventing /sbin/consoletype ". So I turned off SELinux (I was obviously desperate to get wifi working on Linux, for more than 2 weeks)

2. Then that one went away, but started getting some "close-on-exec failed on /var/lib/dhclient/dhclient.leases" error. Till now I have been dual booting to my Vista to get help from Internet, tried saving webpages to my usb drive and follow them from Linux. But I gave up here and borrowed and connected an Ethernet cable and got online from Linux. Some forums had mentioned that the update of dhcp will solve this problem. So here is what I did
su -
yum install PackageKit
yum check-update
yum update (this took about an hour for me, downloading some 1GB of updates and installing them)

3. And that too went away (may require a reboot). But wifi still wouldn't connect. It keeps asking me for the secret key again and again, and repeatedly says something like
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10.

4. I was just going to give up on Fedora and try something else (this is my 3rd try, the first two being ubuntu and opensuse. On ubuntu my wifi was not detected at all and I tried installing madwifi, ndiswrapper etc. etc. as per the forums, but each one had some problem or the other). But I just unplugged my ethernet cable and rebooted once. And tried reluctantly to connect to wifi but the sweetheart worked.

Since I have been fighting very hard for this, I am even more motivated to help anyone facing a similar problem. Feel free to email me on mahesh_isin@yahoo.co.in to get a quicker response.

Here is my other file contents:

[mahesh@localhost /]$ cat /etc/sysconfig/networking/devices/ifcfg-wlan0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Wireless
DNS1=
DEVICE=wlan0
HWADDR=00:13:e8:2b:cc:0f
BOOTPROTO=dhcp
NETMASK=
DNS3=
DHCP_HOSTNAME=localhost.localdomain
IPADDR=
DNS2=
DOMAIN=
SEARCH=
ONBOOT=yes
USERCTL=no
PEERDNS=yes
IPV6INIT=no
ESSID=
CHANNEL=1
MODE=Auto
RATE=auto
NM_CONTROLLED=yes

[mahesh@localhost /]$ cat /etc/sysconfig/networking/devices/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:1b:38:10:6c:46
ONBOOT=yes
DHCP_HOSTNAME=localhost.localdomain
NM_CONTROLLED=no
TYPE=Ethernet


All times are GMT -5. The time now is 05:54 AM.