LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-13-2006, 09:11 AM   #1
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Rep: Reputation: 15
wireless configuration problem in FC5


I have installed a TP-LINK TL-WN651G PCI wireless network adapter in my FC 5 machine. (Atheros chipset) Then installed kernel modules and madwifi from Livna.(correct for kernel version)

Was unable to configure the card using the System->Administration->Network->New->Wireless connection because the card was not recognised there. But it was recognised in new ethernet connection as wifi0.

I can see the network by name in NetWorkManager gui, but am unable to do anything with it or configure the connection for WPA etc. When activated in network GUI I am unable to ping the router either.

I have read many posts and Googled for hours, but have only served to confuse myself further. All works fine when dual booting to XP.

Can anyone advise me on how to configure wifi0? Or is it ath0 that should be configured, in which case why is there a device called wifi0 appearing?

Additional info: ifconfig
ath0 Link encap:Ethernet HWaddr 00:14:78:75:4B:42
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:230 (230.0 b)

eth0 Link encap:Ethernet HWaddr 00:20:ED:73:0D:6F
inet addr:10.1.1.3 Bcast:10.255.255.255 Mask:255.0.0.0
inet6 addr: fe80::220:edff:fe73:d6f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8433 errors:0 dropped:0 overruns:0 frame:0
TX packets:8514 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4479371 (4.2 MiB) TX bytes:1296734 (1.2 MiB)
Interrupt:17 Base address:0xe000

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry: off RTS thr: off Fragment thr: off
Encryption key: off
Power Management: off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:3902 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



Last edited by gchandler; 06-13-2006 at 09:12 AM.
 
Old 06-13-2006, 07:02 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
It's using the aetheros chipset apparantly? So configure ath0
 
Old 06-13-2006, 08:45 PM   #3
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
It's using the aetheros chipset apparantly? So configure ath0
This is the problem. In the Fedora Network config gui 'ath0' does not appear anywhere so I can't configure it there in the new wireless network wizard. I don't know why its not showing up, or how to configure it if it doesn't show up. I assume there is a conf type file somewhere.

I'm no power user of Fedora - just learning my way for the last 12 months (I'm retired now)

Thanks for any help you can give
 
Old 06-13-2006, 09:10 PM   #4
dave_mwi
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Rep: Reputation: 0
ifconfig ath0 up

gchandler -

I might be blowing smoke up...but try this from the console as root:

Code:
ifconfig ath0 up
And then try and use your gui network wizard...

As well, type this from the command line as root:

Code:
iwlist ath0 scan
and paste the output here - this will start to get you on your way for connecting to your access point. If it shows you command not found and you are root, then you might need to install wireless-tools with yum.

Last edited by dave_mwi; 06-13-2006 at 09:16 PM.
 
Old 06-13-2006, 09:22 PM   #5
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Original Poster
Rep: Reputation: 15
I tried ifconfig ath0 up,

then:

Quote:
[root@shambhavi ~]# iwlist ath0 scan
ath0 Scan completed :
Cell 01 - Address: 00:14:78:AE:C1:C8
ESSID:"TP-LINK"
Mode:Master
Frequency:2.437 GHz (Channel 6)
Quality=54/94 Signal level=-41 dBm Noise level=-95 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Extra:wme_ie=dd180050f2020101000003a4000027a4000042435e0062322f00
Extra:ath_ie=dd0900037f0101001dff7f
but still no sign of it in Network config gui wizard. Is there somewhere where I need to associate ath0 with wifi0?
 
Old 06-13-2006, 10:01 PM   #6
gchandler
Member
 
Registered: Aug 2003
Location: Australia
Distribution: Linux Mint 10
Posts: 69

Original Poster
Rep: Reputation: 15
Further information that may assist from dmesg command. The comments on ath0 bother me, but I don't know what they mean.

I should also mention the NetworkManager does correctly list the network name and provides a graphical indication of signal strength so it picking up card OK. But I don't know how to configure it using this.

From dmesg:

Quote:
eth0: RealTek RTL8139 at 0xe0806000, 00:20:ed:73:0d:6f, IRQ 17
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.16.16 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.8.4.2 (svn 1578)
ath_rate_sample: 1.2 (svn 1578)
ath_pci: 0.9.4.5 (svn 1578)
ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 18
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 7.9 phy 4.5 radio 5.6
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0xea000000, irq=18
NET: Registered protocol family 23

And further down list.....

bridge-ath0: enabling the bridge
bridge-ath0: can't bridge with ath0, bad header length 88
bridge-ath0: interface ath0 is not a valid Ethernet interface
eth0: no IPv6 routers present
ath0: no IPv6 routers present
eth0: no IPv6 routers present
eth0: link down
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Last edited by gchandler; 06-13-2006 at 10:04 PM.
 
Old 07-12-2006, 10:28 PM   #7
Amankhan
LQ Newbie
 
Registered: Feb 2006
Posts: 1

Rep: Reputation: 0
I am experiencing this exact same problem with my own wireless card. Previously my card worked with no problems, but once I upgraded to the 2.6.17-1245 kernel things went south. I can also post any relevant messages and/or info., but at this point my problem is identical to what gchandler is experiencing.

Edit: Problem solved. For whatever reason, the Madwifi driver (which appears to have updated during the same kernel update...) did not insert an alias line into /etc/modprobe.conf. Once I manually inserted this line, everything works OK.

Last edited by Amankhan; 07-13-2006 at 12:02 AM.
 
Old 07-17-2006, 06:15 PM   #8
pwalden
Member
 
Registered: Jun 2003
Location: Washington
Distribution: Fedora FC19, Raspbian
Posts: 295

Rep: Reputation: 38
I am seeing this too on my Atheros based card using MadWiFi driver.

I suspect the madwifi-ng driver is not setting the *correct bits* for the fedora configuration manager to recognize the car as a wireless, rather than ethernet card. A bug in MadWifi or Fedora, who knows?

So I found another thread that solved this the hard way by physically setting the configuration script. At least Iam now working.

http://forums.fedoraforum.org/showthread.php?t=112716

Note: I got the HWADDR from ifconfig -a
==========
Quote:
A working configuration for madwifi requires:

1. In /etc/modprob.conf

alias wifi0 ath_pci
alias ath0 ath_pci
options ath_pci autocreate=sta

2. In /etc/sysconfig/networking/devices/ifcfg-ath0

IPV6INIT=no
ONBOOT=yes
USERCTL=yes
PEERDNS=yes
TYPE=Wireless
DEVICE=ath0
HWADDR=00:0f:b5:ee:e3:43 (replace with your hardware mac)
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=ap54g (replace with your access point id)
CHANNEL=1 (leave at 1 and it should pick up the correct channel for the above ap)
MODE=Managed
RATE=Auto

Obviously don't place my comments () in the files!

3. /etc/sysconfig/networking/devices/keys-ath0

KEY=your encryption key

Now you should be able to use either the gui or cli to manage the ath0 interface as fedora's scripts will parse these configuration files and call iwconfig for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Orinoco Silver wireless card problem of FC5 gorilla294 Linux - Wireless Networking 1 06-09-2006 10:13 AM
I can't connect to my wireless AP in FC5, why am I unable to activate my wireless. ruggersway Linux - Wireless Networking 1 05-09-2006 04:58 PM
Problem wireless card configuration pierre44 Linux - Wireless Networking 1 08-08-2005 04:08 PM


All times are GMT -5. The time now is 09:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration