LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   windows in X are missing the title bar in new fedora core 5 (FC5) installation, et al (http://www.linuxquestions.org/questions/fedora-35/windows-in-x-are-missing-the-title-bar-in-new-fedora-core-5-fc5-installation-et-al-459024/)

mr.v. 06-28-2006 01:41 AM

windows in X are missing the title bar in new fedora core 5 (FC5) installation, et al
 
Hi all--

I have a strange problem. I'm fairly new to linux and when I first booted up Fedora Core 5 and it went into X-windows, things seemed fine. The windows looked fairly similar as they do in windows XP with a top title bar that had a minimize, maximize and close button. I could also move them around.

Then I decided to install the NVIDIA driver. I had a few problems at first but then I got everything working. However, things began to get weird after that.

When I load X-windows it seems to hang for a while after entering my username/passwd on "Window Manager" and then proceeds to load and everything seems fine. But what's strange is any program I run is missing its title bar with the minimize, maximize, and close button. It also gets stuck to the top left of the screen where the "start menu" (sorry for the windows term, I don't know what it's called in linux).

The program's main menu is however present. Having done a modicum of programing it would appear as though applications cannot get a proper window with a title-bar and insets from the windowing system, but can still paint its client-area. Seems strange.

Also other things have stopped working too. The button on the bottom left to "show desktop" returns an error saying "window manager does not support show desktop or is not installed"

The "screensaver" program in the preferences menu works fine but the "desktop background" program seems to start in the lower bar taskbar but then fails to appear.

Any ideas about what seems to be the problem or how I can go about fixing it?

reddazz 06-28-2006 01:52 AM

So what desktop environment are you running?

Hitboxx 06-28-2006 02:39 AM

Quote:

The button on the bottom left to "show desktop" returns an error saying "window manager does not support show desktop or is not installed"

The "screensaver" program in the preferences menu works fine but the "desktop background" program seems to start in the lower bar taskbar but then fails to appear.
GNOME i guess..

mr.v. 06-28-2006 02:48 AM

Sorry I seem to have forgotten that detail.

I'm using Gnome.

reddazz 06-28-2006 05:05 AM

It seems like there is a problem with metacity or some other GNOME settings. Try logging in as a different user and see if the problem persists. If it doesn't, login to a terminal (make sure you are not logged into GNOME), then delete your .gonf and .gnome direcotires (after backing them up first) and see if you can get back your distros default GNOME settings.

Hitboxx 06-28-2006 12:58 PM

Open the terminal and type 'metacity'. If its ok you should see your titlebars and all. If not type 'gdmsetup' in the terminal, give the root password, go to the 'Security' tab in the window that opens up, go to 'configure X-Server button' and set it to 'Standard' and see if works.

Note: You need to do this before it works(after you set it to 'standard')
Code:

Hit Ctrl-Alt-F1, login as root, type 'gdm-restart' at terminal prompt
OR
reboot your pc.

IF still not working, try installing 'metacity' again.

mr.v. 06-28-2006 01:56 PM

Thanks redazz for the suggestions. I tried them but it still failed. I even tried reinstalling metacity and nautilus but it didn't work...

shrikant.odugoudar-- trying to run metacity was a great suggestion. I had no idea you could just run the window program even after the X-server started and it would place the borders on everything.

I did as you suggested and ran metacity in the terminal. It gave me the following error:
metacity: error while loading shared libraries: /usr/lib/libGLcore.so.1: cannot restore segment prot after reloc: Permission denied

so in the nvidia install guide they told me to do use the following commands for 2 files because it had something to do with SELinux which I didn't really understand.

chcon -t texrel_shlib_t /usr/lib/xorg/modules/drivers/nvidia_drv.so

and
chcon -t texrel_shlib_t /usr/lib/xorg/modules/extensions/libglx.so.1.0.8762

so I used the same command (not that I have any idea what it means) to these files too and Wammo it worked

I did:
chcon -t texrel_shlib_t /usr/lib/libGLcore.so.1

ran metacity and got the same error but with a DIFFERENT file:

so I did:
chcon -t texrel_shlib_t to that file and ran metacity again. I think it demanded one more file after that too.

finally I typed metacity again and BANG! I got the title bars back! So I guess it has something to do with SELinux and permissions. I'm still trying to figure out the basic file permissions using CHMOD. Maybe I should have left SELinux alone until I understand Fedora better. Again, I don't really understand but the "chcon -t texrel_shlib_t" seems to have fixed the problem.

Thanks everyone!

reddazz 06-28-2006 02:35 PM

Ahh the joys of Selinux. Personally I think if you are not running Linux on an important server, you could be better of just disabling selinux because it seems to interfere with a lot of things if you intend to use linux on the desktop.

lucktsm 06-28-2006 04:21 PM

The same thing happend to me, basically Gnome stops working all together. I installed KDE and kept on going, but it now I will try to disable selinux.

swint144 02-23-2007 07:55 PM

Quote:

Originally Posted by mr.v.
ran metacity and got the same error but with a DIFFERENT file:

so I did:
chcon -t texrel_shlib_t to that file and ran metacity again. I think it demanded one more file after that too.

finally I typed metacity again and BANG! I got the title bars back!

So which file was that? I'm having the same issue - no title bar. I can still operate everything else normally, it just makes it a pain to move the windows around. I kinda like the extra screen estate, though....

LukiX 05-27-2007 06:10 AM

Title Bar Missing
 
Hi everyone.

I have been using FC6 for the last fews days and have been enjoying it, but i also ended up having the same problem where my titlebar was not visible, and most applications were loading in the top-right corner.
It seems as though this has been an issue that has been arising from time to time.

I followed the procedures for removing .gconf etc from my homedir, and restarting gdm, the problem was fixed instantly, however I have found what appears to be a cause of the loss of titlebar problem, well perhaps..

After restarting gdm, i went straight to System\Prefereneces\Desktop Effects. Enabled them and turned on ´Workspaces on a Cube´. Straight away, I lost my titlebar and applications were being launched to top-right corner.

Are any of you that are having this problem using Desktop Effects:Pengy:
Could this be a bug that needs reporting:Pengy:

Cheers.

mr.v. 05-27-2007 09:36 AM

Hey,

this is kind of an old thread =) but anyway, when you select "desktop effects" you actually switch to using a different window manager known as compiz. Compiz uses the AIGLX component of X Org > 7 to run it.

Maybe it's erroring. To catch those errors, you can try running compiz in a console (instead of clicking "desktop effects") to see if it throws some stderr messages to figure out what's going wrong.

PrimalOne 10-08-2008 02:19 PM

This may or may not be relevant, and I apologize if it isn't relevant. I'm very new to Linux (only been playing with it for about a month, but I had it installed on my computer back in the Redhat 5.1 days *LOL*). Anyway, I had this happen where I lost the title bar when installing the emerald theme manager. I had to type in the console window 'emerald --replace'

If I closed the console window I lost the title bar again. What worked for me was to reopen a console window (still not having title bars at this point) and typing 'metacity --replace' which brought back my title bars, then I was able to close the console window and still had title bars.

It may help it may not.

John VV 10-08-2008 02:54 PM

PrimalOne did you see that the first post was on 06-28-2006
2 1/4 YEARS AGO.

PrimalOne 10-16-2008 07:11 PM

lol....nope, sorry


All times are GMT -5. The time now is 09:21 PM.