LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   wicd won't start (http://www.linuxquestions.org/questions/fedora-35/wicd-wont-start-4175443411/)

mickeyboa 12-29-2012 04:28 PM

wicd won't start
 
Fedora 17

Installed wicd and it won't start.

Dec 29 17:18:16 localhost dbus-daemon[573]: dbus[573]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.9" (uid=1000 pid=1052 comm="kded4 ") interface="org.wicd.daemon" member="GetConnectionStatus" error name="(unset)" requested_reply="0" destination="org.wicd.daemon" (uid=0 pid=1642 comm="/usr/bin/python -O /usr/share/wicd/daemon/wicd-dae")
Dec 29 17:18:16 localhost dbus[573]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.9" (uid=1000 pid=1052 comm="kded4 ") interface="org.wicd.daemon" member="GetConnectionStatus" error name="(unset)" requested_reply="0" destination="org.wicd.daemon" (uid=0 pid=1642 comm="/usr/bin/python -O /usr/share/wicd/daemon/wicd-dae")



/var/log/wicd

2012/12/29 17:18:10 :: ---------------------------
2012/12/29 17:18:10 :: wicd initializing...
2012/12/29 17:18:10 :: ---------------------------
2012/12/29 17:18:10 :: wicd is version 1.7.2.1 755
2012/12/29 17:18:10 :: setting backend to external
2012/12/29 17:18:11 :: trying to load backend external
2012/12/29 17:18:11 :: successfully loaded backend external
2012/12/29 17:18:11 :: trying to load backend external
2012/12/29 17:18:11 :: successfully loaded backend external
2012/12/29 17:18:11 :: Automatically detected wireless interface wlan0
2012/12/29 17:18:11 :: setting wireless interface wlan0
2012/12/29 17:18:11 :: automatically detected wired interface p33p1
2012/12/29 17:18:11 :: setting wired interface p33p1
2012/12/29 17:18:11 :: setting wpa driver wext
2012/12/29 17:18:11 :: setting use global dns to False
2012/12/29 17:18:11 :: setting global dns
2012/12/29 17:18:11 :: global dns servers are None None None
2012/12/29 17:18:11 :: domain is None
2012/12/29 17:18:11 :: search domain is None
2012/12/29 17:18:11 :: setting automatically reconnect when connection drops True
2012/12/29 17:18:11 :: Setting dhcp client to 0
2012/12/29 17:18:11 :: Wireless configuration file found...
2012/12/29 17:18:11 :: Wired configuration file found...
2012/12/29 17:18:11 :: chmoding configuration files 0600...
2012/12/29 17:18:11 :: chowning configuration files root:root...
2012/12/29 17:18:11 :: Using wireless interface...wlan0
2012/12/29 17:18:11 :: Using wired interface...p33p1

frankbell 12-29-2012 08:54 PM

Code:

2012/12/29 17:18:11 :: chmoding configuration files 0600...
 2012/12/29 17:18:11 :: chowning configuration files root:root...
 2012/12/29 17:18:11 :: Using wireless interface...wlan0
 2012/12/29 17:18:11 :: Using wired interface...p33p1

It looks like it's starting, but not connecting. Have you reached the point of configuring a wireless network and passkey? If not, it could be waiting for a connection to be configured. Have you tried starting the wicd GUI with the command "wicd-client" (you may need to do this as root; if it works, put it in your startup applications).

Let us know what happens. It can help additional troubleshooting.

mickeyboa 12-30-2012 03:14 PM

/usr/bin/wicd-client: line 40: /usr/bin/wicd-gtk: No such file or directory

just what gtk dependency does it need.

frankbell 12-30-2012 07:54 PM

According to the Arch wiki, wicd-gtk is the name of the client package. At least for Arch, it has been split off into a separate package from the wicd base package.

You might check your repos to see whether it exists as a separate package. When I installed on Slackware, I just needed one package (it was on the Slackware extra's CD), and I can't speak for Fedora.

https://wiki.archlinux.org/index.php/Wicd

There's some more information at the wicd page on Sourceforge, but I think it may be a little out-dated for your situation. http://wicd.sourceforge.net/download.php

I hope this helps; I don't feel particularly optimistic about my Google-fu on this one, I fear. Good luck.

mickeyboa 12-31-2012 12:37 PM

I guess I will have to go back to NetworkManager, because wicd just won't do it , I get to the point to see AP's available and Properties to set key and IP's and when I click on OK and it does nothing. Nothing is happening.

frankbell 12-31-2012 08:46 PM

Sorry I couldn't help more.

I prefer wicd, but I did have one Ubuntu system on which wicd stopped working after an upgrade and I had to fall back to network manager. I never figured out why wicd stopped, but, frankly, I didn't try very hard. I found that network manager had improved significantly in the interim.

Timothy Miller 12-31-2012 11:23 PM

I've found wicd is EXTREMELY sensative if you have any other network management software installed. So if network-manager is installed still, even if it's not actively configured to manage an interface, I've found wicd will fail.

Also, after setting passkey in wicd, you have to actively tell it to connect again (irritating little thing). If you chose "connect automatically" it will in FUTURE boots connect automatically, but for that one time, will not connect until actively told to again.


All times are GMT -5. The time now is 03:03 PM.