LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-19-2006, 05:42 PM   #31
oldjoe
Member
 
Registered: Nov 2006
Location: Woodstock, IL
Distribution: Fedora Core 6 2.6.18-2868
Posts: 78

Original Poster
Rep: Reputation: 15

I continued with the ndiswrapper installation. I had to recreate the link to the /lib/modules folder and then did the make install. No problems there. Then when I tried to load the module, this is what I got:

[root@localhost ndiswrapper-1.28]# modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.18-1.2849.fc6/misc/ndiswrapper.ko): Invalid module format

????????
 
Old 11-19-2006, 06:51 PM   #32
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
I think you just yum remove the nvidia module and yum install it again, like you did the first time, that creates the module for your current kernel. As for the improper module format, I am now officially lost. Have you tried make uninstalling the ndiswrapper and just trying the precompiled one you can get through yum?
 
Old 11-20-2006, 12:18 AM   #33
oldjoe
Member
 
Registered: Nov 2006
Location: Woodstock, IL
Distribution: Fedora Core 6 2.6.18-2868
Posts: 78

Original Poster
Rep: Reputation: 15
Invalid module format

I was able to get the nvidia package I needed. What I did was removed the kernel (with the Add/remove software GUI) and then installed ndiswrapper that way. It worked but now which step do I go to? Now when I type depmod -a, I get no warning. So, at least that is fixed. But I figured I need to load the module with modprobe ndiswrapper and I am still getting the:

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.18-1.2849.fc6/extra/ndiswrapper/ndiswrapper.ko): Invalid module format

Should I post a new thread to see if anyone knows how to fix this.
 
Old 11-20-2006, 12:22 AM   #34
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
you may wish to spawn a new thread since the current title no longer very accurately descibes your problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum update error natewlew Fedora 9 08-16-2008 12:22 AM
yum update error vegetassj2 Linux - Software 4 09-07-2006 01:01 PM
Yum Update Error in FC4 egrim Fedora 2 04-22-2006 11:05 AM
Yum Update error fcoutel Red Hat 1 12-30-2004 10:22 AM
Error message using yum update Seventh_Warrior Fedora 7 06-23-2004 12:47 PM


All times are GMT -5. The time now is 03:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration