LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-12-2009, 06:16 PM   #1
newbie-123
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
white screen of death - enable desktop effects on F10


I foolishly 'enabled desktop effects' and have now got a white screen and nothing else other than a pointer.

I have certain found this & other forums helpful in getting everything else working OK, but for this particular problem although there are similar posts they don't seem to work in my case - I can't find the files they refer to

I can get to the command line - but need help beyond that. I am a complete Linux novice - so go gentle

It would be great to fix the problem, but I am quite happy if someone can tell me how to get to 'disable desktop effects' by tabbing to the right place (I have searched but can't find out how to get to the menu, or where the option is in the menu)

F10 was a fresh install over a Vista installation - everything has been working pretty much ok - certainly no graphics problems.

Happy to provide any info (but you will need to tell me how)
 
Old 02-12-2009, 06:37 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Well, we will need to know which desktop (GNOME?,KDE?, Other?) you're using.

If you're (or "were") using KDE, you can enable a "KDE fresh start by (from the command line, after logging on as yourself) doing a mv ~/.kde ~/.kde~; if it was GNOME, then mv ~/.gmome2 ~/.gnome2~ should do the trick. (You may also need to mv .gnome2-private.)

Note that this will produce a completely "fresh start," and all your current settings will be lost. You can, however, recover some of those settings from the backup files you will have created when you renamed the control directories. Just copy them back to the new .kde (or .gnome2) directory in the correct place. (The file and sub-directory names are fairly easy to figure out, although I think that the KDE ones are somewhat simpler.)
 
Old 02-12-2009, 07:05 PM   #3
newbie-123
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I 'was' running Gnome.

Logged in as myself (not SU) did the 2 x mv - double checked they were done OK - then restarted - & the white screen returned

Double checked the directories & they have been re-instated though with less content(which I guess as expected)

Persistent 'feature'
 
Old 02-12-2009, 09:38 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Weirdness. I've only got the WSoD on KDE, so I've never had to re-initialize GNOME.

Try this: Go to the command line, log in as "root", and create a new user id/password:
Code:
# useradd Tester
# lpasswd -P test Tester
Note: You must have logged in as "root" to use the lpasswd command, not just done a su - to open a "root" session. Easiest, if you didn't start by logging in as "root," to open a new tty by, say, <ctrl>-<alt>-F2 for tty2.

Then do a ls -a /home/Tester to see what default files have been created in the new user's directory. (Unless you've got a good memory, or there aren't any such files, note these down.)

Then do a su Tester - to log in as "Tester," and start an X-session for "Tester" on tty8 with the command startx -- :1.

That should get you into a fresh GNOME session where you can open a terminal window and do a ls -a to see which files GNOME has created for you. Then you can log out of the tty8 session, and do the mv thing to the additional file(s) you've identified.

By the way, since my first suggestion didn't work, once you've identified the offending file(s), you can presumably restore the other files from the backups you created.

<edit>
Oh, if that works, and you can restore your GNOME display, please post here the name of the offending file(s) so the next poor sole with this problem can, hopefully, find an answer.
</edit>

Last edited by PTrenholme; 02-12-2009 at 09:47 PM.
 
Old 02-13-2009, 03:22 AM   #5
newbie-123
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I don't understand the tty bit.

The only way I have managed to get ant kind of access has been to create a dummy entry in grub, then move to F10 press "a", and append "quiet 3" to give me a login prompt. At this point I then logged in as "root" - just wanted to check that I got this ok.

Did useradd ok, but when I did the lpasswd, I got prompted for a password tried my su password, and "test" - neither worked "Authentication failed for Tester."

So - escaped out of that.

ls -a /home/Tester gave

.bash_logout
.bash_profile
.bashrc
.gnome2 (nothing else under here)
.mozilla (extensions & plugins - both empty)

Did su Tester - looked to be logged on ok - although i did not get prompted for a password (which I guess was the lpasswd problem?)

startx -- :1

Wow - a GUI :-)

Terminal window, ls -a gave loads of new files & directories. I assume it is just the files under .gnome2 that are of interest? - If yes I will go through these.

BTW - My next question (assuming this all goes OK) - will be how to delete the new user Tester ? - I won't embarras myself by saying I now have a couple to get rid of (note to self - don't deviate from intructions)
 
Old 02-13-2009, 07:41 AM   #6
newbie-123
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
update - still getting white screen.

Presumably, because I did not create a password, i cannot logon via the normal Fedora login.

Back to logging in as root. After each change below, I tried loggin in as the 'white' use via the GUI and by SU 'white' and then startx -- :1 and got the white screen both times.


The files under .gnome and under .gnome_private are the same for Tester and for the 'white' user - with the exception that the white user has
./gnome/keyring/login.keyring

Deleting this - still get white screen

Logged on again as root. Looked at all the differences at the level of

/home/Tester

Loads of new directories and files. So mv 'd all to same name with ~ on end. Still get white screen.

Tried to mv the .gnome and .gnome-private from the Tester account to the 'white' account. Because I forgot the SU bit I got a GUI, but it was for root. Trying the 'white' account - still get white screen.

Tried to mv the .gnome and .gnome-private to .gnome~ and .gnome-private~ to see if it would create valid new ones. Still get white screen
 
Old 02-13-2009, 10:50 AM   #7
newbie-123
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
SOLVED

To get back to the original desktop assuming the menus etc are as per a basic install of Fedora10

log-on as the user with the 'white' screen (via the normal GUI)

Once loged in, move cusor to top left corner and left click (to get focus on the menu bar - not sure if there is a shortcut for this)

Then, basically use the arrow keys to get the the 'effects' menu. Which for me was:
2 right arrow
1 down arrow
1 right arrow
1 down arrow
1 right arrow
1 down arrow
<cr> (to get the 'effects' window)

<ctrl> d (for deselect)
<cr> (to choose deselect)

Screen now returns


Thanks very much for the help (I needed to see the Tester logon to be able to play with the menus)

Now about deleting those Tester accounts...
 
Old 02-13-2009, 12:25 PM   #8
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Deleting the "Tester" account is relatively straight forward now you've got your desktop back. Just go to "System -> Administration -> Users and Groups," select the Tester user, and push "Delete."

An empty user doesn't really take up much space, so I like to keep "Tester" around for testing (duh) applications, scripts, etc., before actually installing them. And, as you discovered, it can be handy sometimes to have an alternate user id that you can use. (I've got some for my grandchildren to use as well, but that's another issue.)
 
Old 03-22-2009, 07:31 AM   #9
brizly
LQ Newbie
 
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0
alternate solution?

Hello,

just got the same problem after moving my account /home/user/*
from on pc to another, where the first one had the hardware for effects, the second hasn't.

For me also works to 'ssh -X' in from another machine,
then start 'desktop-effects' from console
(which leads to the small window like in the 'blind-navigation-solution' from above).
there i disabled effects.
After that i logged in on the 'new' machine.

_____
luck up
brizly
 
  


Reply

Tags
desktoplinux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
white screen of death in ubuntu - post nvidia driver install eoinrua Linux - Newbie 14 05-18-2009 01:11 PM
Dual boot XP Mandriva 08 white screen of death ADDn00b Mandriva 7 03-11-2008 02:49 PM
Fedora 7 + KDE + Beryl = White Screen of Death hacker supreme Linux - Software 3 09-11-2007 11:08 AM
White screen of death after restoring from backup.Mandrake leongoogs Linux - Newbie 1 04-09-2005 02:10 AM
White Screen of Death! malinruin Linux - Laptop and Netbook 1 08-21-2003 02:11 PM


All times are GMT -5. The time now is 10:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration