LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   whereis ssh? (http://www.linuxquestions.org/questions/fedora-35/whereis-ssh-4175420216/)

mickeyboa 08-03-2012 12:43 PM

whereis ssh?
 
F17

Where is ssh ? it is shown in Firewall as enabled, but not in Services, no ssh shown.

# service ssh start
Redirecting to /bin/systemctl start ssh.service
Failed to issue method call: Unit ssh.service failed to load: No such file or directory. See system logs and 'systemctl status ssh.service' for details.

[root@Acer mickey]# systemctl status ssh.service
ssh.service
Loaded: error (Reason: No such file or directory)
Active: inactive (dead)

YankeePride13 08-03-2012 12:48 PM

Check in /etc/init.d

frankbell 08-03-2012 09:35 PM

If you are talking about the ssh server to accept ssh connections, I think you might be looking for sshd.

http://www.labtestproject.com/linnet...sh_server.html

SharpyWarpy 08-04-2012 04:47 AM

frankbell is right. Run this:
systemctl status sshd.service
and post the output.

mickeyboa 08-04-2012 11:04 AM

$ systemctl status sshd.service
sshd.service - OpenSSH server daemon
Loaded: loaded (/usr/lib/systemd/system/sshd.service; disabled)
Active: inactive (dead)
CGroup: name=systemd:/system/sshd.service

SharpyWarpy 08-04-2012 01:51 PM

Okay run
systemctl enable sshd.service
then
systemctl start sshd.service
Then run
systemctl status sshd.service
and post the output. If everything goes well you should have ssh services every time you boot from now on. Actually all this can be done with a GUI program, I think through the firewall configuration. But just try the above first since it will use the appropriate firewall ports.

mickeyboa 08-04-2012 06:34 PM

]# systemctl status sshd.service
sshd.service - OpenSSH server daemon
Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled)
Active: active (running) since Sat, 04 Aug 2012 19:31:59 -0400; 29s ago
Process: 8100 ExecStartPre=/usr/sbin/sshd-keygen (code=exited, status=0/SUCCESS)
Main PID: 8124 (sshd)
CGroup: name=systemd:/system/sshd.service
└ 8124 /usr/sbin/sshd -D

Aug 04 19:31:59 BigOne sshd-keygen[8100]: Generating SSH2 RSA host key: [ OK ]
Aug 04 19:31:59 BigOne sshd-keygen[8100]: Generating SSH1 RSA host key: [ OK ]
Aug 04 19:31:59 BigOne sshd[8124]: Server listening on 0.0.0.0 port 22.
Aug 04 19:31:59 BigOne sshd[8124]: Server listening on :: port 22.

SharpyWarpy 08-04-2012 08:32 PM

Well good, you got it running. Congrats. :*)

SharpyWarpy 08-05-2012 11:24 AM

You might want to mark your thread as "Solved" for the benefit of other users. You can do so at the top of the page, just click on "Solved".


All times are GMT -5. The time now is 05:32 AM.