LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   what is versionlock?? (http://www.linuxquestions.org/questions/fedora-35/what-is-versionlock-444887/)

Hitboxx 05-15-2006 01:12 AM

what is versionlock??
 
Hi guys,

Im unable to do an update,list,etc any packages at all.

i get this error
Code:

Process 2988 (yum) has been started.
Please be patient, this may be a lengthy operation...

(Command being executed: yum -y info updates).

***
***
*** Unable to read version lock configuration: [Errno 5] OSError: [Errno 2] No such file or directory: '/etc/yum/pluginconf.d/versionlock.list'
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Loading "downloadonly" plugin
Loading "changelog" plugin
Loading "protectbase" plugin
Loading "versionlock" plugin
Loading "tsflags" plugin
Loading "kernel-module" plugin
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
0 packages excluded due to repository protections
Reading version lock configuration
Process exited normally with code 1.

KYum, Pup, Yumex all return errors.

HELP
Thanks

MRMadhav 05-15-2006 02:05 AM

Hey I am also getting these errors. It began when i updated yum and installed more utilities to yum via yumex. Perhaps if i revert back this will be fixed but i don't know how to do that! Any suggestions?

Hitboxx 05-15-2006 02:56 AM

Update
 
Hi,

Yes i installed them too and the problems started.

But now ok.

i did this.
Code:

[root@shrilinx shrikant]# yum list installed | grep yum
kyum.i386                                0.7.5-3.fc5            installed
yum.noarch                              2.6.1-0.fc5            installed
yum-changelog.noarch                    0.6-2.fc5              installed
yum-downloadonly.noarch                  0.6-2.fc5              installed
yum-fastestmirror.noarch                0.6-2.fc5              installed
yum-kernel-module.noarch                0.6-2.fc5              installed
yum-protectbase.noarch                  0.6-2.fc5              installed
yum-tsflags.noarch                      0.6-2.fc5              installed
yum-utils.noarch                        0.6-2.fc5              installed
yumex.noarch                            1.0.0-1.0.fc5          installed

Then
Code:

[root@shrilinx shrikant]# yum remove yum-versionlock
Its all fine now.

But can someone plz tell what happened here?

Thanks

Theorist 07-14-2006 02:05 PM

Hi shrikant.odugoudar,
versionlock plugin for YUM is for you to prevent YUM from updating the versions or "lock the version" of some selected packages if you wish to, by mentioning it in /etc/yum/pluginconf.d/versionlock.list file. This plugin is not needed if you do not intend to do so.

Once this plugin is installed, every time when YUM starts, it checks for the existence of /etc/yum/pluginconf.d/versionlock.list file. Since, it is by default not created, the simple way to solve this issue is to create a blank file named versionlock.list in /etc/yum/pluginconf.d/ folder. Try doing it.

With Regards,
Theorist


All times are GMT -5. The time now is 01:22 PM.