LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Closed Thread
 
Search this Thread
Old 05-31-2004, 11:31 AM   #1
fsbooks
Member
 
Registered: Jan 2002
Location: Missoula. Montana, USA
Distribution: fedora, slackware, suse
Posts: 447

Rep: Reputation: 31
wget --exclude-directories option broken? (fc2)


When I run the following command with wget (wget-1.9.1-5) from fedora core 2, it does not exclude the updates/2/i386/debug directory, probably the SRPMS directory as well, but I kill it first.

$ wget --verbose --limit-rate=7k -t7 -w7 --random-wait -E -k -K -nH --cut-dirs=2 -x -np -m -X */i386/debug/,*/i386/SRPMS/ -a /tmp/fedoraN.log ftp://mirrors.kernel.org/fedora/core/updates/2/i386


Note that the wget binary from wget-1.8.2-15.3 (fedora core 1) when run in fedora core 2 works fine.

I tried a bug report to fedora, but their bugzilla seemed broken (I did search, but got no relevant hits). Can anyone duplicate this problem?

Thanks, Chris
 
Old 01-03-2008, 03:17 AM   #2
rino.caldelli
Member
 
Registered: Apr 2005
Location: perugia
Distribution: ubuntu
Posts: 181

Rep: Reputation: 31
exclude option wants a full path, not one relative to the download URL

so if downloading from http://ayo.freshrpms.net/fedora/linu.../RPMS.updates/

you would do --exclude-directories=fedora/linux/3/i386/RPMS.updates/debug,fedora/linux/3/i386/RPMS.updates/headers

Hope it helped!
 
1 members found this post helpful.
Old 06-20-2009, 05:29 PM   #3
elitenoobboy
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by rino.caldelli View Post
exclude option wants a full path, not one relative to the download URL

so if downloading from http://ayo.freshrpms.net/fedora/linu.../RPMS.updates/

you would do --exclude-directories=fedora/linux/3/i386/RPMS.updates/debug,fedora/linux/3/i386/RPMS.updates/headers

Hope it helped!
So, if that command executed properly, then the bug would be that it ignore the wildcards such as * instead of it ignoring te exclude directories completely. The man page says it should accept wildcards.
 
Old 06-20-2009, 06:08 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,260
Blog Entries: 54

Rep: Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841
The practice of responding to a thread that died out long ago is not helpful.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tar won't exclude directories. yougene Slackware 9 12-01-2005 09:32 AM
wget broken after new packages in -current sh1ft Slackware 3 12-22-2004 11:50 PM
Exclude directories when backing up with 'tar'? wolfpeach Linux - Newbie 2 06-28-2004 10:54 AM
Using the exclude option absolutely with rsync karlovac Programming 0 03-01-2004 12:39 PM
wget & --exclude-directories Tinkster Slackware 4 07-20-2003 10:02 PM


All times are GMT -5. The time now is 08:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration