LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-22-2005, 09:19 AM   #1
kasra
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Rep: Reputation: 0
Vnc Server Strange Behavior In Fedora Core 3



Abstract : VNC SERVER Dons't let any remote connection in, unless I login to my server locally first.

Greetings,

I have a silly problem with Fedora Core 3 and it's VNC Server;

VNC is supposed to provide you remote access to your server, including remote login, right?

Now guess how my VNC works, if and only if I ALREADY logged in to my server, I can have remote access via VNCVIEWER. But when I just turn on my server and don't log in (In other words, I only boot the system but stay behind GNOME loin prompt), all remote VNCVIEWER requests receive a “connection refused” message.

My Guesses
It seems to me that unless I don't actually log into my server as root, the VNC server doesn't start. I don't know whether it's a runlevel issue (i.e. I should set vncserver to start in lower runlevels like 3), or there is a VNCSERVCER configuration problem.

Please help.
Kasra

Last edited by kasra; 06-22-2005 at 09:21 AM.
 
Old 06-25-2005, 05:07 PM   #2
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
There are several ways to set up VNC services - how did you enable VNC ?
 
Old 06-26-2005, 03:45 AM   #3
kasra
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for your help

I installed and enabled the vncserver in services to start in runlevel 5.
But everytime I check it, it is not running unless I start it manually.

A friend suggested me to uncomment the following line in my config file and said:

"You have no uncommented VNCSERVERS line. Since it looks like you are
trying to use root (which is a bad idea), you need at minimum"


# VNCSERVERS="1:myusername"

and I changed it to this:

VNCSERVERS="1:root"

But it doesn't help eighther.

I have also a new question; on what runlevels the vnc server should be enabled?

Many Thanks...
Kasra
 
Old 06-26-2005, 06:11 AM   #4
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
He's right that you shouldn't login as root directly, especially not over a network connection - it is bad practice, and some network services reject or restrict logging in as root for that reason.

The method you've described generates a desktop for the listed user on bootup, but you need to run vncpasswd as that user to set the access password (this is completely separate from your normal login password). In a terminal window:

vncpasswd

Note that running two GNOME desktops simultaneously for the same account is not recommended - the settings system isn't built for two copies of GNOME accessing the same user's settings at the same time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 1 VNC Server Problems alannerd Linux - Networking 2 07-09-2005 05:17 AM
VNC Server setup for Fedora Core 3 HELP!!! PLZ bkz81 Linux - Networking 7 06-09-2005 03:49 PM
VNC on Fedora core 2 inventorriz Linux - Networking 7 06-21-2004 07:42 AM
Strange happenings after installing VNC server tawalker Linux - Software 2 03-02-2004 08:17 AM
Ximian Evolution weird behavior in Fedora Core 1. grayswander Fedora 2 01-20-2004 01:20 PM


All times are GMT -5. The time now is 01:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration