LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 08-22-2007, 11:08 AM   #1
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Rep: Reputation: 206Reputation: 206Reputation: 206
VNC over SSH - too slow!


I have configured my /etc/sysconfig/vncservers file on hostname.domain.com as:
Code:
VNCSERVERS="1:jameson"
VNCSERVERARGS[1]="-geometry 1280x1024 -nohttpd -localhost -depth 8 -nolisten tcp"
The server is running as:
Code:
bash$ ps aux | grep Xvnc
jameson  23992  0.0  0.1  46148  5572 ?        S    07:57   0:00 Xvnc :1 -desktop hostname.domain.com:1 (jameson) -auth /home/jameson/.Xauthority -geometry 1280x1024 -depth 8 -rfbwait 30000 -rfbauth /home/jameson/.vnc/passwd -rfbport 5901 -pn -localhost -nolisten tcp

When I try to access my display on hostname.domain.com:1 by:

Code:
client-bash$ env DISPLAY=client.thisdomain.com:0 ssh -X hostname.domain.com
server-ssh$ vncviewer localhost:1
at which point I get this on the stdout:
Code:
 TXImage:     Using default colormap and visual, TrueColor, depth 24.
the display that comes up is intolerably slow (refreshes a few small sections per second.) I know I have the bandwidth to do this without SSH, as I have been using it previously at 16 depth and it was quite quick.

What is going on here! Why is it so slow, and what is the TXImage message which suggests I am not receving 8-bit depth on the viewer?

Last edited by jhwilliams; 08-22-2007 at 11:12 AM.
 
Old 08-22-2007, 12:32 PM   #2
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Original Poster
Rep: Reputation: 206Reputation: 206Reputation: 206
Using the -via option of vncviewer solved this problem. Still not sure why the -X ssh forwarding option was so slow --- the vncviewer -via probably invokes some compression the ssh -X option does not.
 
Old 09-21-2007, 08:39 AM   #3
dilip5150
LQ Newbie
 
Registered: Sep 2007
Posts: 2

Rep: Reputation: 0
I would suggest NX or freenx, which is much faster than X or VNC but then you can only connect from a windows/linux machine to a linux machine. Also the fedora scripts to set these up are broken and you have to run the script, find which lines give you an error and correct those.

dilip
 
Old 09-25-2007, 08:05 AM   #4
doublejoon
Member
 
Registered: Oct 2003
Location: King George, VA
Distribution: RHEL/CentOS/Scientific/Fedora, LinuxMint
Posts: 366

Rep: Reputation: 44
Disable your wallpapers (maybe use just flat black)

Code:
Also in /etc/ssh/sshd_config
Compression yes
Code:
On your local machine
/etc/ssh/ssh_config
Compression yes

Also
VNCSERVERARGS[1]="-geometry 1280x1024 maybe to much resolution over vnc

Maybe 1024x768
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vnc over ssh ieuuk Linux - Networking 18 01-18-2006 07:11 AM
VNC too slow Steve Riley Ubuntu 2 07-27-2005 11:29 AM
vnc with ssh Paxmaster Linux - Networking 1 03-07-2005 09:05 PM
slow vnc dukeinlondon Linux - Networking 1 12-15-2003 04:02 PM
VNC and SSH jrmann1999 Linux - Networking 0 12-26-2001 09:43 AM


All times are GMT -5. The time now is 09:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration