LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-27-2008, 11:51 AM   #1
pramhus
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Rep: Reputation: 0
Unhappy virtualbox usb permissions with fedora 9


I have installed virtualbox on a fedora 9 installation . I am using an XP quest . Windows XP works but I can't get the usb ports accessed under XP . How do I set the permissions for the usb ports to be available to the XP quest ? The
 
Old 06-28-2008, 06:40 AM   #2
BallsOfSteel
Member
 
Registered: Mar 2008
Location: Florida
Distribution: Fedora mainly, but I am open to others.
Posts: 273

Rep: Reputation: 33
Are you running Virtualbox as root or sudo? I ran into a couple of problems because I was running it as a regular user.
 
Old 06-29-2008, 03:48 PM   #3
pramhus
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by BallsOfSteel View Post
Are you running Virtualbox as root or sudo? I ran into a couple of problems because I was running it as a regular user.
I was running as a regular user . I have reinstalled virtualbox as a root
user and can use the usb ports . There should be some files that allows access to the usb ports as a regular user , but I can't find them.
 
Old 07-27-2008, 01:37 AM   #4
Ivan Platonov
LQ Newbie
 
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by pramhus View Post
I have installed virtualbox on a fedora 9 installation . I am using an XP quest . Windows XP works but I can't get the usb ports accessed under XP . How do I set the permissions for the usb ports to be available to the XP quest ? The
USB in Virtualbox 1.6.2 on Fedora 9.
-------------------------------------------------------

1. Make a file for starting script on boot:
su
"root password"
touсh /etc/udev/rules.d/51-usb-group.rules
with next content, filled in your favorite text editor (lets say nano /etc/udev/rules.d/51-usb-group.rules):

##########################################################################
SUBSYSTEM=="usb_device", RUN="/etc/udev/scripts/set-usb-group '%c'"
##########################################################################

2. Make a folder:
mkdir /etc/udev/scripts
and file inside:
touсh /etc/udev/scripts/set-usb-group
with next content, filled in your favorite text editor (lets say nano /etc/udev/scripts/set-usb-group):

##########################################################################
#! /bin/sh

ret=false
if [ "$1" != "" ]; then
if [ -f /proc/$1 ]; then
chgrp usb /proc/$1 && \
chmod g+rw /proc/$1 && \
logger udev/set-usb-group: `ls -l /proc/$1`
ret=true
fi
if [ -e /dev/$1 ]; then
chgrp usb /dev/$1 && \
chmod g+rw /dev/$1 && \
logger udev/set-usb-group: `ls -l /dev/$1`
ret=true
fi
else
logger udev/set-usb-group: Called without device arg
exit 0
fi
if ! $ret; then
logger udev/set-usb-group: Setting permissions on device $1 failed
fi
##########################################################################

3. Change an owner of file and attribute:

chown -v root /etc/udev/scripts/set-usb-group
chmod -v go-rwx,u+rwx /etc/udev/scripts/set-usb-group

4. Find ID of vboxusers group in User and group manager (I have 501).
Add new row to /etc/fstab

##########################################################################
# devgid=501, 501 - это номер группы vboxusers
none /proc/bus/usb usbfs devgid=501,devmode=664 0 0
##########################################################################
Do not forget to add new line.

5. Reboot.
 
Old 12-21-2009, 03:20 AM   #5
msanpedro@digitronsoftwa
LQ Newbie
 
Registered: Dec 2009
Location: Los Angeles
Distribution: Fedora
Posts: 1

Rep: Reputation: 0
This is actually a permissions issue with the usb device in linux

the following should solve the problem without requiring to run VirtualBox as root:

0. su

1. lsusb (and find the particular usb device you wish to activate)

2. chmod a+rwx /dev/bus/usb/bus/id
(where bus is the bus id, id is the device id)
(example: chmod a+rwx /dev/bus/usb/002/013)

3. Restart / or start virtualbox and your usb device should be accessible.
 
Old 12-21-2009, 04:09 AM   #6
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,551
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by BallsOfSteel View Post
Are you running Virtualbox as root or sudo? I ran into a couple of problems because I was running it as a regular user.
VirtualBox is designed to be run as a regular user. Only the installation has to be done with root privileges. If it doesn't work for a regular user then something is mis-configured.
 
Old 12-21-2009, 04:12 AM   #7
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,551
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by pramhus View Post
I have installed virtualbox on a fedora 9 installation . I am using an XP quest . Windows XP works but I can't get the usb ports accessed under XP . How do I set the permissions for the usb ports to be available to the XP quest ? The
Which version of VirtualBox are you using and where did you get it from? Only the PUEL versions support USB devices, not the OSE versions. Have you tried running the VirtualBox USB configuration analysis script from this LQ post?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot use any USB devices in VirtualBox davidguygc Linux - Hardware 7 06-14-2010 08:36 AM
Is usb sopport available in virtualbox-ose? dv502 Linux - General 4 09-18-2009 07:16 AM
USB TV tunner not working in VirtualBox voger Linux - Software 8 10-14-2008 11:56 AM
USB Scanner help with VirtualBox linubex Mandriva 2 10-02-2007 10:49 PM
USB: Virtualbox - tried everything! adamruss Linux - Software 1 07-27-2007 08:04 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration