LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   vgaswitcheroo and kernel panic on fedora 20 (http://www.linuxquestions.org/questions/fedora-35/vgaswitcheroo-and-kernel-panic-on-fedora-20-a-4175490355/)

icos 01-06-2014 04:38 PM

vgaswitcheroo and kernel panic on fedora 20
 
Hi!

I've a dual vga laptop (intel + ati) and I've upgraded my distro from 19 to 20.
Everything is working pretty well, but now I can't disable the discrete card using vgaswitcheroo (like I used to do with fedora 19).

I'm using the latest kernel avaible (3.12.6-300.fc20.x86_64) and right now I'm using the intel vga, but I would disable the discrete card.

Code:

# cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Pwr:0000:01:00.0

I always used this command turn off ati card:
Quote:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
But now, after the upgrade to Fedora 20, if I try to do this system crash with a kernel panic (I suppose).

Any suggestion to avoid this?
Are there others ways to disable the ati card? I just would to turn off it.

If there are some logs where I can look, tell me and I will post them!

Thanks a lot!

RustyRussell 01-10-2014 04:19 PM

Exactly the same issue here.

Kernel is 3.12.6-200.fc19.x86_64

Machine is HP dv7, with i915 + radeon.

This may be relevant: https://git.kernel.org/cgit/linux/ke...f67729b95a9736

RustyRussell 01-11-2014 01:13 PM

Possible "cure" (works for me) is as follows (as root):

<code>
yum install fedora-release-rawhide
yum --disablerepo=* --enablerepo=rawhide install kernel-3.13.0_0.rc7.git4.1.fc21
</code>

The kernel version will change with time, but this one works for me at the time of writing.

Now reboot to the new kernel. Note, there's no need to do the "echo OFF > /sys/kernel/debug/vgaswitcheroo/switch" with this kernel, since it seems to automatically power down the unused adapter (DynOff).

icos 01-15-2014 02:26 PM

I've update to the last stable kernel avaible and everything is working again correctly!
With this one I have not any problem:
Code:

3.12.7-300.fc20.x86_64
Anyway, thanks for the advices! :)


All times are GMT -5. The time now is 03:28 AM.