LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-22-2005, 09:05 PM   #1
Pudge
Member
 
Registered: Mar 2004
Distribution: Fedora Core 3, Arch Linux 0.7
Posts: 57

Rep: Reputation: 15
USB KVM switch won't work with X server


I bought a USB KVM switch to switch between a Windows XP box and a Fedora Core 3 box. It didn't work. So I hooked up a PS2 KVM switch with a PS2 keyboard/mouse and it worked perfect.

I put the USB KVM switch with the USB keyboard/mouse back in and it doesn't work again. When booting up Fedora, KUDZU recognizes the USB KVM switch and even lists it correctly as a JustCom USB KVM switch. I then tell KUDZU to configure the KVM switch and it does it. However, the KVM will switch from Windows XP to Linux, but once in Linux, it will not switch back to Windows.

Next I discovered that it will switch back and forth between Windows and Linux in runlevel 3. I then do a init 5 and start X and it no longers switches back to Windows.

So, there seems to be a problem with the X server and the USB KVM switch. There must be something I need to add to the /etc/X11/xorg.conf file, but I have no idea what it is. Remember it works with the PS2 KVM switch and PS2 keyboard / mouse both in runlevel 3 and 5. With the USB KVM switch and USB keyboard / mouse, it works in runlevel 3 but does not work in runlevel 5.

I am open to any suggestions as this has me baffled. This is not my computer setup, so eliminating the Windows box is not an option.

EDIT:
Ooops, here is what I currently have in xorg.conf for the keyboard and mouse sections:

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection


Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Pudge

Last edited by Pudge; 06-22-2005 at 09:35 PM.
 
Old 06-22-2005, 10:13 PM   #2
Pudge
Member
 
Registered: Mar 2004
Distribution: Fedora Core 3, Arch Linux 0.7
Posts: 57

Original Poster
Rep: Reputation: 15
Looked in dmesg and found this:

ohci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 4 ports detected
usb 2-3: new full speed USB device using ohci_hcd and address 2
hub 2-3:1.0: USB hub found
hub 2-3:1.0: 4 ports detected
usb 2-3.1: new low speed USB device using ohci_hcd and address 3
input: USB HID v1.00 Keyboard [??\uffff???? ??????????????????????????????] on usb-0000:00:02.0-3.1
input,hiddev96: USB HID v1.00 Mouse [??\uffff???? ??????????????????????????????] on usb-0000:00:02.0-3.1
usb 2-3.4: new low speed USB device using ohci_hcd and address 4
input: USB HID v1.10 Keyboard [Justcom Technology USB KVM Switch] on usb-0000:00:02.0-3.4
input: USB HID v1.10 Mouse [Technology USB KVM Switch] on usb-0000:00:02.0-3.4

The last two lines show that Fedora knows the Justcom USB KVM switch is there, it just won't switch with the X server running.

One last thing, the KVM switches by a hot key only, and the hot key is to press "Scoll Lock" twice in rapid succession. I don't think it's possible to change the hot key. Is it possible that X server is filtering out the Scroll Lock key presses?

Pudge

Last edited by Pudge; 06-22-2005 at 10:20 PM.
 
Old 08-03-2005, 12:47 PM   #3
DrJonesAC2
LQ Newbie
 
Registered: May 2003
Posts: 9

Rep: Reputation: 0
Workaround

Hello,

I was also having trouble with this issue (KVM). While I was unable to find a solution to X not liking USB scroll lock commands I did find a workaround. In KDE (not sure about other window managers) you can hit Ctrl+Alt+F1 to switch to a command line terminal. This allows you to use scroll lock. To get back to your x session hit Ctrl+Alt+F7.

I hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KVM switch with Linux hkxx9 Linux - Newbie 32 07-08-2005 02:01 PM
KVM switch kingtas Linux - Newbie 7 02-17-2005 07:50 PM
Getting a KVM Switch to work with Linux MooMooFarm Linux - Hardware 5 11-16-2004 03:43 PM
KVM switch frankie_DJ Linux - Hardware 2 10-07-2004 02:05 AM
imps2 mouse doesn't work with KVM switch compu73rg33k Linux - Hardware 6 05-27-2004 10:29 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration