LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-29-2006, 06:10 PM   #1
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Rep: Reputation: 15
upgrade FC4 to FC5 failed due to dependencies


hi people,
I have tried to upgrade my system from FC4 to FC5 with yum, but I ran into the following error message:

Code:
Error: Missing Dependency: xorg-x11 is needed by package glitz
Error: Missing Dependency: xorg-x11-Mesa-libGL is needed by package glitz
Error: Unable to satisfy dependencies
Error: Package glitz needs xorg-x11-Mesa-libGL, this is not available.
Error: Package initscripts conflicts with kernel < 2.6.12.
Error: Package kudzu conflicts with kernel < 2.6.13.
Error: Package glitz needs xorg-x11, this is not available.

for initscripts and kudzu I have already deleted the previous core versions, but I still get this error

thanks for your help
 
Old 04-29-2006, 07:42 PM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
I'd say that xorg and kernel are on the exclude list.

Find yum, and check the config files.

Mind you updating xorg and kernel may leave you with config tasks after.
 
Old 04-29-2006, 08:07 PM   #3
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
hi,
no, i don't mind, but what I have to look for in the yum.conf file
 
Old 04-29-2006, 10:40 PM   #4
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 48
Quote:
Originally Posted by SofNine
hi people,
I have tried to upgrade my system from FC4 to FC5 with yum, but I ran into the following error message:
First of all, upgrading with Yum is not recommended. You should have upgraded using the installer if possible.

Quote:
Originally Posted by SofNine
Code:
Error: Missing Dependency: xorg-x11 is needed by package glitz
Error: Missing Dependency: xorg-x11-Mesa-libGL is needed by package glitz
Error: Unable to satisfy dependencies
Error: Package glitz needs xorg-x11-Mesa-libGL, this is not available.
Error: Package initscripts conflicts with kernel < 2.6.12.
Error: Package kudzu conflicts with kernel < 2.6.13.
Error: Package glitz needs xorg-x11, this is not available.
What is glitz? You should probably remove it. That package probably doesn't work with X.org 7

Quote:
Originally Posted by SofNine
for initscripts and kudzu I have already deleted the previous core versions, but I still get this error
How did you "delete" them? What does "rpm -q kudzu initscripts" return? Can you post the entire Yum output?
 
Old 04-29-2006, 10:49 PM   #5
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
I dont't know what glitz is...
I meant that i have deleted the kernel versions they conflict with(kudzu, initscripts), but as you can see it didn't work, but kudzu and initscripts are still installed, by the way what are they for...
 
Old 04-29-2006, 10:50 PM   #6
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
yum output:

Code:
--> Running transaction check
--> Processing Dependency: xorg-x11-Mesa-libGL for package: glitz
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Processing Dependency: xorg-x11 for package: glitz
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: xorg-x11-Mesa-libGL for package: glitz
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Processing Dependency: xorg-x11 for package: glitz
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Missing Dependency: xorg-x11 is needed by package glitz
Error: Missing Dependency: xorg-x11-Mesa-libGL is needed by package glitz
Error: Unable to satisfy dependencies
Error: Package glitz needs xorg-x11-Mesa-libGL, this is not available.
Error: Package initscripts conflicts with kernel < 2.6.12.
Error: Package kudzu conflicts with kernel < 2.6.13.
Error: Package glitz needs xorg-x11, this is not available.
[root@ppc7 etc]#
kudzu and initscripts:

Code:
[root@ppc7 etc]# rpm -q initscripts
initscripts-8.11.1-1
[root@ppc7 etc]# rpm -q kudzu
kudzu-1.1.116.3-1
[root@ppc7 etc]#
shall I remove kudzu and initscripts....
 
Old 04-29-2006, 10:57 PM   #7
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 48
Quote:
Originally Posted by SofNine
kudzu and initscripts:

Code:
[root@ppc7 etc]# rpm -q initscripts
initscripts-8.11.1-1
[root@ppc7 etc]# rpm -q kudzu
kudzu-1.1.116.3-1
[root@ppc7 etc]#
shall I remove kudzu and initscripts....
Those are the old FC4 versions. What kernels do you have installed? So have you actually upgraded or not? What instructions are you following to upgrade?
 
Old 04-29-2006, 11:46 PM   #8
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
I have followed this instructions:
http://www.brandonhutchinson.com/Upg..._with_yum.html

installed kernel:
Code:
[root@ppc7 etc]# rpm -q kernel
kernel-2.6.16-1.2096_FC4
[root@ppc7 etc]#
no, I couldn't complete my update due to the above mentioned error dependencies
 
Old 04-29-2006, 11:47 PM   #9
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
the upgrade failed
 
Old 04-30-2006, 04:01 AM   #10
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
How did you go about starting this update? If it were me, I would have downloaded the fedora-release rpm for FC5, installed that, then do "yum upgrade yum". When thats done, I would then do "yum upgrade". That should remove any obsolete packages.
 
Old 05-01-2006, 11:39 AM   #11
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
I have followed the instructions in the link I have mentioned above.
ok, and where can I find the right rpm package
 
Old 05-02-2006, 11:29 AM   #12
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
the fedora-release for FC 5 was installed successfully, but if i try to run yum upgrade yum it doesn't find any matches and if i try yum upgrade.....i run into the same error messages as mentioned above
 
Old 05-02-2006, 11:58 AM   #13
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Have you tried uninstalling glitz first and then doing the upgrade?
 
Old 05-02-2006, 02:20 PM   #14
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
that will remove 175 packages, you are sure that's a good idea.....
i don't want to destroy my distro....
 
Old 05-02-2006, 05:01 PM   #15
SofNine
Member
 
Registered: Apr 2006
Posts: 38

Original Poster
Rep: Reputation: 15
hi,
I have removed the glitz package and I guess it was a huge mistake, because i have only the command line, my entire desktop is gone....
and i still cannot upgrade....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4->FC5 upgrade problem jams Fedora 1 04-28-2006 11:15 PM
Upgrade FC4 - FC5 using yum, fails with initscripts dependency rendle Fedora 2 04-05-2006 10:32 AM
I can boot after upgrade from fc4 to fc5 yumener Fedora 2 03-24-2006 10:28 AM
problems with GDM after upgrade from fc4 to fc5 gottin Fedora 1 03-23-2006 03:28 PM
FC5 upgrade to one FC4 on multi-boot system killed the others PTrenholme Fedora 0 03-21-2006 11:15 PM


All times are GMT -5. The time now is 11:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration