LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-05-2005, 07:54 AM   #1
dandrzejewski
LQ Newbie
 
Registered: Feb 2005
Distribution: Fedora Core 3
Posts: 1

Rep: Reputation: 0
Updated system, now mouse wheel/buttons don't work


Hey all. I have a Microsoft Wireless Intellimouse Explorer 2.0. I had the extra buttons and wheel working just fine, until I ran a yum update yesterday. It updated the kernel, and now when I reboot, the mouse works, but the wheel does not and neither do the extra buttons.

Here's my mouse config in /etc/X11/xorg.conf
Code:
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/input/mouse0"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection
And here's my /etc/X11/xinit/xinitrc.d/mouse.sh:
Code:
xmodmap -e "pointer = 1 2 3 6 7 4 5"
This is per instructions from this forum.

Anyway, this was working fine, until I updated yesterday. Here's the yum.log for what all got updated:

Code:
Mar 04 07:41:43 Updated: gamin.i386 0.0.25-1.FC3
Mar 04 07:41:43 Updated: libtool-libs.i386 1.5.6-4.FC3.1
Mar 04 07:41:44 Updated: dmraid.i386 1.0.0.rc6-1_FC3
Mar 04 07:41:44 Updated: gamin-devel.i386 0.0.25-1.FC3
Mar 04 07:41:46 Updated: libtool.i386 1.5.6-4.FC3.1
Mar 04 07:41:51 Updated: HelixPlayer.i386 1:1.0.3-3.fc3
Mar 04 07:42:01 Updated: tzdata.noarch 2005f-1.fc3
Mar 04 07:44:05 Installed: kernel.i686 2.6.10-1.770_FC3
It's definitely the kernel. When I boot back to 766, everything works fine again. Is there something that was changed in 770 that can cause this?

Last edited by dandrzejewski; 03-05-2005 at 08:10 AM.
 
Old 03-06-2005, 08:27 AM   #2
Harryc
Member
 
Registered: Dec 2002
Location: New York, USA
Distribution: OpenSUSE 10.0
Posts: 220

Rep: Reputation: 32
What happens if you run the xmodmap from a console as root?

xmodmap -e "pointer = 1 2 3 6 7 4 5"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse buttons (any) don't work gmlion Linux - Hardware 3 06-15-2005 01:55 PM
5 button mouse + scroll whell = 2 buttons + no wheel jollyjoice Slackware 2 07-24-2004 02:49 PM
2 buttons and one wheel mouse vwal_13 Slackware 1 04-20-2004 10:51 AM
How to get scroll wheel and thumb buttons to work. DrD Linux - Newbie 2 02-07-2004 03:00 AM
emulate 3 buttons? (logitech ps/2 wheel mouse) spuzzzzzzz Linux - Hardware 6 01-03-2004 06:35 AM


All times are GMT -5. The time now is 06:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration